Should build gda module

Bug #406077 reported by Chris Coulson on 2009-07-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-python-extras (Ubuntu)
Wishlist
Unassigned

Bug Description

Looking at the build log, I see this:

The following modules will be built:

gtkhtml2
egg.trayicon
egg.recent
gtkmozembed (linking to xulrunner-1.9)
gtkspell
gdl
gksu2

The following modules will NOT be built:

gda
gksu
gksu.ui

I'm currently packaging the latest version of glom, and it depends on pygda-4.0. This needs enabling in gnome-python-extras.

Changed in gnome-python-extras (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Changed in gnome-python-extras (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
status: Triaged → In Progress
Changed in gnome-python-extras (Ubuntu):
assignee: Chris Coulson (chrisccoulson) → nobody
status: In Progress → Confirmed
tags: added: desktop-upgrade
Daniel Holbach (dholbach) wrote :

This needs a main inclusion report of libgda4. :/

Changed in gnome-python-extras (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-python-extras - 2.25.3-3ubuntu1

---------------
gnome-python-extras (2.25.3-3ubuntu1) karmic; urgency=low

  * Re-base on Debian unstable, remaining changes:
    - debian/control.in:
      + build-dep on python-all-dbg for debug packages
                     python-gnome2-dev (>= 2.22.3-0ubuntu3),
                     xvfb and libgl1-mesa-dri.
      + build-dep on xulrunner-1.9.1
      + bump libgdl-1-dev build-dep to >= 2.28.0
      + add python-gnome2-extras-dbg package
      + add Vcs-Bzr tag
      + Keep the python-gnome2-extras package around, as it is too
        late in the Karmic cycle to be removing it.
      + re-generate debian/control
    - adapt python-gda.install, python-gtkhtml2.install,
      python-gtkspell.install, python-gtkmozembed.install,
      python-gdl.install, python-gksu2.install and
      python-eggtrayicon.install to python 2.6 new package layout
    - debian/rules:
      + dbg-* targets and trick
      + move dh_pysupport call and use xvfb
    - debian/pyversions: 2.5 for new package layout
    - debian/patches/
      + 01_xul19.patch: add AC_PROG_CXX because you can't push C++ tests
        before detecting it (thanks Keybuk)
      + Re-generate debian/patches/70_autotools.patch
      + 04_use_PYTHON-config_check.patch: use python-config.
      + 05_fix_gdl_build.patch: ix to build with gdl in the archive, patch
        taken from http://bugzilla.gnome.org/show_bug.cgi?id=584126
  * This enables the pygda module (LP: #406077)

 -- Chris Coulson <email address hidden> Tue, 29 Sep 2009 01:12:08 +0100

Changed in gnome-python-extras (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.