Ubuntu

python gtkspell depends unneeded on GNOME

Reported by Benny on 2009-03-05
2
Affects Status Importance Assigned to Milestone
gnome-python-extras (Debian)
Fix Released
Undecided
Unassigned
gnome-python-extras (Ubuntu)
Wishlist
Unassigned

Bug Description

python gtkspell is a gtk module.
However, it is distributed in python-gnome2-extras. Hence, GTK applications that have spell checking depend on a lot of GNOME components without this needing to be the case.

For example: GRAMPS is a gtk app with spell checking.
Installing the python-gnome2-extra causes the install of:

The following extra packages will be installed:
  gnome-media gnome-media-common gstreamer0.10-alsa gstreamer0.10-plugins-base gstreamer0.10-plugins-good
  gstreamer0.10-x gvfs gvfs-backends libavc1394-0 libcamel1.2-14 libcdio-cdda0 libcdio-paranoia0 libcdio7
  libdv4 libebook1.2-9 libecal1.2-7 libedataserver1.2-11 libgda3-3 libgda3-bin libgda3-common libgdl-1-0
  libgdl-1-common libgnome-desktop-2-7 libgnome-media0 libgnomecups1.0-1 libgnomeprint2.2-0
  libgnomeprint2.2-data libgnomeprintui2.2-0 libgnomeprintui2.2-common libgtksourceview-common
  libgtksourceview1.0-0 libgvfscommon0 libiec61883-0 libmetacity0 libnautilus-burn4 liboil0.3
  libpanel-applet2-0 libshout3 libsoup2.4-1 libtotem-plparser12 libv4l-0 metacity-common
  python-gnome2-desktop

However, downloading the package, and doing:

sudo dpkg --force-depends -i python-gnome2-extras_2.19.1-0ubuntu11_amd64.deb

gives fully functional spell checking in GRAMPS.

Sebastien Bacher (seb128) wrote :

thanks for your bug report

Changed in gnome-python-extras:
importance: Undecided → Wishlist
status: New → Confirmed
Changed in gnome-python-extras:
status: Confirmed → Triaged
Changed in gnome-python-extras:
status: Unknown → New
Didier Roche (didrocks) wrote :

This bug is closed in debian2.25.3-1, bug watcher not synced. Syncing it manually

Changed in gnome-python-extras (Debian):
importance: Unknown → Undecided
Didier Roche (didrocks) wrote :
Changed in gnome-python-extras (Debian):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-python-extras - 2.25.3-2ubuntu1

---------------
gnome-python-extras (2.25.3-2ubuntu1) karmic; urgency=low

  * Merge from debian unstable, remaining changes: (LP: #375355)
    - debian/control.in: (LP: #338152)
      + build-dep on python-all-dbg for debug packages
                     python-gnome2-dev (>= 2.22.3-0ubuntu3),
                     xvfb and libgl1-mesa-dri.
      + add python-gnome2-extras-dbg package
      + add Vcs-Bzr tag
      + re-generate debian/control
    - adapt python-gnome2-extras.install, python-gtkhtml2.install,
      python-gtkspell.install, python-gtkmozembed.install,
      python-gdl.install, python-gksu2.install and
      python-eggtrayicon.install to python 2.6 new package layout
    - debian/patches/
      + 01_xul19.patch: add AC_PROG_CXX because you can't push C++ tests
        before detecting it (thanks Keybuk)
      + 01_use_PYTHON-config_check.dpatch converted to
        debian/patches/04_use_PYTHON-config_check.patch
      + Re-generate debian/patches/70_autotools.patch
    - debian/rules:
      + dbg-* targets and trick
      + move dh_pysupport call and use xvfb
    - debian/pyversions: 2.5 for new package layout
  * Remove python-gnome-gtkhtml-dbg package and merge its content into
    python-gnome2-extras-dbg

 -- Didier Roche <email address hidden> Thu, 14 May 2009 11:23:17 +0200

Changed in gnome-python-extras (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.