miro.real crashed with SystemError in MozillaBrowser() on PPC

Bug #181068 reported by Matteo Settenvini on 2008-01-07
26
Affects Status Importance Assigned to Milestone
Exaile
Invalid
Undecided
Unassigned
Miro
Invalid
Undecided
Unassigned
XULRunner
Invalid
Undecided
Unassigned
exaile (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
gnome-python-extras (Ubuntu)
Low
Unassigned
Hardy
Low
Alexander Sack

Bug Description

Binary package hint: miro

Also exaile-bzr gave me this problem some days ago, but I can't reproduce it reliably with that. With miro, it's everytime I start it.

ProblemType: Crash
Architecture: powerpc
Date: Mon Jan 7 19:08:46 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/miro.real
InterpreterPath: /usr/bin/python2.5
Package: miro 1.0-1ubuntu1
PackageArchitecture: powerpc
ProcCmdline: /usr/bin/python /usr/bin/miro.real
ProcCwd: /home/matteo
ProcEnviron:
 PATH=/home/matteo/sandbox/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/miro.real']
SourcePackage: miro
Title: miro.real crashed with SystemError in MozillaBrowser()
Uname: Linux Dahlia 2.6.22-14-powerpc64-smp #1 SMP Sun Oct 14 22:41:26 GMT 2007 ppc64 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin plugdev pulse pulse-access pulse-rt scanner users video

Matteo Settenvini (tchernobog) wrote :
Matteo Settenvini (tchernobog) wrote :

Still happening to both Exaile and Miro. Anyone else having the same problems?

Matteo Settenvini (tchernobog) wrote :

Still here; hardy is behind the door and still no fix for this. May at least someone point me in the right direction?

Johannes Sasongko (sjohannes) wrote :

Moving to Ubuntu's exaile package since this is not an Exaile bug.

Changed in exaile:
status: New → Invalid
Joao Ferreira (jff) wrote :

Happens to me:

*************** INITIALIZE MOZEMBED
location: /usr/lib/xulrunner-1.9b5/libxpcom.so
before 3
location: /usr/lib/xulrunner-1.9b5/libxpcom.so
failed 3
Traceback (most recent call last):
  File "/usr/bin/miro.real", line 112, in <module>
    startapp()
  File "/usr/bin/miro.real", line 59, in startapp
    import app
  File "/var/lib/python-support/python2.5/miro/app.py", line 626, in <module>
    import frontend
  File "/var/lib/python-support/python2.5/miro/frontend.py", line 62, in <module>
    import gtkmozembed
SystemError: dynamic module not initialized properly

Brian O'Keefe (okeefe) wrote :

Identical to Joao's error only launching Miro-1.2 stand alone.

Tyler Gannon (tgannon) wrote :

The problem seems to be that the hardy python-gnome2-extras package hasn't been rebuilt since before the latest xulrunner. I updated python-gnome2-extras from the intrepid repo at
http://launchpadlibrarian.net/15192571/python-gnome2-extras_2.19.1-0ubuntu8_powerpc.deb

Once that was installed I was able to run miro.

I'm glad to have this one solved for myself.

regards,
Tyler

Tyler Gannon (tgannon) wrote :

note also that Bug #189065 is fixed by upgrading python-gnome2-extras to the latest in the intrepid line.

Brian O'Keefe (okeefe) wrote :

Yep-that works tyler. thanks, now I can watch with Miro and hear with Exaile!

Chris Halse Rogers (raof) wrote :

From the comments this seems to be a python-gnome2-extras problem. Since it seems like a simple rebuild of the package will fix it, this could be SRU worthy.

Moving to gnome-python-extras pacakge, closing other tasks.

Changed in miro:
importance: Undecided → Medium
status: New → Confirmed
Changed in exaile:
status: New → Invalid
Changed in democracy:
status: New → Invalid
Changed in xulrunner:
status: New → Invalid
Changed in gnome-python-extras:
importance: Medium → Low
Changed in exaile:
status: New → Invalid
Changed in gnome-python-extras:
importance: Undecided → Low
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

subscribing alexander who did the xulrunner updates

Changed in gnome-python-extras:
assignee: nobody → asac

I've got an Ubuntu PowerPC machine - confirmed that a binary rebuild resolves this issue. Attached changelog

gnome-python-extras (2.19.1-0ubuntu8) hardy; urgency=low

  * No-changes binary rebuild for hardy to resolve
    runtime issues in miro (LP: #181068)

 -- Michael Casadevall <email address hidden> Tue, 26 Aug 2008 17:57:06 -0400

Alexander Sack (asac) wrote :

During IRC discussion we found out that this is not a regression due to a recent security update. e.g. it doesn't work if you downgrade xulrunner-1.9 either nor if you downgrade everything to hardy.

Changed in gnome-python-extras:
status: Confirmed → Triaged

Here's the debdiff to properly rebuild the package.

Subscribing ubuntu-sru

Intrepid is not affected. Just confirmed that.

Changed in gnome-python-extras:
status: Confirmed → Invalid
status: Invalid → Fix Released

A fix has been uploaded to hardy-proposed, and is waiting for archive admin to approve it (likely fridya).

Changed in gnome-python-extras:
status: Triaged → Fix Committed

On Wed, Sep 10, 2008 at 11:20:40PM -0000, Michael Casadevall wrote:
> A fix has been uploaded to hardy-proposed, and is waiting for archive
> admin to approve it (likely fridya).

Thank you for this. if there is no progress from archive admin side,
please let us know.

 - Alexander

Sebastien Bacher (seb128) wrote :

you should not change to fix commited while the upload has not been accepted

Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Matt Neilson (ichthyoboy) wrote :

Using python-gnome2-extras from -proposed allows Miro to start up and play videos fine, so confirmed as fixed.

Natan Yellin (aantny) wrote :

I can confirm that the -proposed version fixes this. Thanks.

Also confirmed by me. Subscribing ubuntu-sru .

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in gnome-python-extras:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers