Please simplify /dev/ttyUSB0 setup when installing gnome-ppp

Bug #59386 reported by ozonehole on 2006-09-07
14
Affects Status Importance Assigned to Milestone
gnome-ppp (Ubuntu)
Wishlist
MOTU

Bug Description

Binary package hint: gnome-ppp

I recently succeeded in getting Ubuntu to work with an external serial modem attached to my computer through the USB port. However, this was difficult to configure and I'm sure a newbie couldn't do it. Yet a simple change to gnome-ppp would have made it easy. More details below...

First, to describe my hardware: a notebook computer (IBM ThinkPad X31), which has no serial ports but has USB ports. I purchased a special cable which has a built-in adaptor, so that the USB port can be physically connected to an external serial modem.

The problem is this: the character device required for this set-up to work is /dev/ttyUSB0. Fortunately, this device does exist in Ubuntu, as you can see:

bob@x31:/> ls -l /dev/ttyUSB0
crw-rw---- 1 root dialout 188, 0 2006-09-07 09:36 /dev/ttyUSB0

The only trouble is that gnome-ppp does not recognize /dev/ttyUSB0. When you try to configure it, you are only offered these choices:

   /dev/modem
   /dev/ttyS0
   /dev/ttyS1
   /dev/ttyS2
   /dev/ttyS3

There is in fact no /dev/modem - it is a symbolic link. For me to make my hardware work, I had to create a symbolic link:

   ln -s /dev/ttyUSB0 /dev/modem

After this, I could configure gnome-ppp to access my modem using /dev/modem. So it worked - until I rebooted. Thanks to udev, every time I rebooted my /dev/modem would disappear and I had to create it manually again. To solve this problem, I created a start-up script (which I named modem.sh) with this content:

   #! /bin/sh
   #
   ln -s /dev/ttyUSB0 /dev/modem

I placed the script in /etc/init.d and ran this command:

   update-rc.d modem.sh defaults

Now I am able to use my modem with gnome-ppp, so my problem is solved. The only real issue is that all of the above would be nearly impossible for a Linux newbie to figure out. It occurs to me that this complexity would be rendered unnecessary if gnome-ppp simply offered /dev/ttyUSB0 as one of its choices. It is my suggestion that this should be done for the next release.

best regards,
Robert

Related branches

C de-Avillez (hggdh2) wrote :

Confirmed.

gnome-ppp/feisty uptodate 0.3.23-1
linux-image-generic/feisty uptodate 2.6.20.5.1
udev/feisty uptodate 103-0ubuntu5

/dev/ttyUSB* are not offered as options during gnome-ppp. USB serial devices recognised by usbserial and friends will, by default, be created under /dev/ttyUSB*.

Since gnome-ppp does not allow the user to specify another device... this renders the package unusable by the casual user. Although wireless USB modems are not yet extremely common, we can already see a lot of hits on the web on this. I would, then set this as a medium-to-high priority.

Some options:

1. make it possible for the user to specify a different device (instead of a fixed drop-down list);
2. update /etc/udev/rules.d so that the necessary soft links are created

I would rather go with (1) above.

I found this while looking at another issue relating to my wireless PCMCIA card and PPP, and while I was trying to gather more data on the issue.

It is also interesting to note that this bug has been unconfirmed/unassigned for almost 6 months.

Changed in gnome-ppp:
status: Unconfirmed → Confirmed
C de-Avillez (hggdh2) on 2007-03-22
Changed in gnome-ppp:
importance: Undecided → Medium
assignee: nobody → motu
Daniel T Chen (crimsun) on 2008-09-14
Changed in gnome-ppp:
importance: Medium → Wishlist
Colin McDermott (colmcd) wrote :

I noticed that in configuring a usb 3G modem that the Detect option detects the attached /dev/ttyUSB0

Yet this is not a listed option for selection. Is a screen tooltip saying "please click detect if trying to configure a USB modem" a warranted addition?

Else we would have to allow users to specify their own path to devices.

BTW "Although wireless USB modems are not yet extremely common" IMHO they are getting pretty common in Australia especially with mobile computing. The answer was always to go for the Ethernet variety but support for usb 3g modems out of the box would be very helpful. It is the first issue that I came across after setting up an ibm laptop for a friend of mine, she knows nothing about linux!

Overall some helpful screen prompting for Gnome-ppp and usb would be good.

hello i've ubuntu 9.04, i tryed ur instruction.. can't work out, tel me any idea? plz

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-ppp - 0.3.23-1ubuntu1

---------------
gnome-ppp (0.3.23-1ubuntu1) karmic; urgency=low

  * Add USB ports to drop-down menu (LP: #59386)
    - debian/patches/60_add_usb_ports.patch: add /dev/ttyUSB* to
      gnome-ppp.glade.
  * Properly send password to wvdial (LP: #84837)
    - debian/patches/61_send_password.patch: send password to the pipe
      instead of stdout in src/gnome-ppp-wvdial.c.
  * Fix minimize on connect option
    - debian/patches/62_minimize.patch: change window hint to
      GDK_WINDOW_TYPE_HINT_NORMAL in gnome-ppp.glade.
  * Fix "malformed input line" warning
    - debian/patches/63_comment.patch: write the comment line with a #
      so wvdial will ignore it in src/gnome-ppp.c.

 -- Marc Deslauriers <email address hidden> Wed, 09 Sep 2009 23:23:25 -0400

Changed in gnome-ppp (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers