Power Statistics window blank

Bug #951827 reported by andrer on 2012-03-10
326
This bug affects 69 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Medium
James M. Leddy
Precise
Medium
Unassigned
gnome-power
Fix Released
Medium
gnome-power-manager (Ubuntu)
High
Unassigned
Precise
Medium
Unassigned

Bug Description

[Summary]

Patch: https://code.launchpad.net/~ossug-hychen/ubuntu/precise/gnome-power-manager/fix-951827

bzr branch: lp:~ossug-hychen/ubuntu/precise/gnome-power-manager/fix-951827

[IMPACT]

 * To precise users, their Power Statistics often gets completely
   blank. No buttons, no information, nothing! It doesn't fix itself by closing the window and reopen it.

[TESTCASE]

 1. open power statics window from power indicator
 2. close and reopen power statics window several times
 3. after step2, the power statics window displays information correctly

[Regression Potential]

 * the patch is from upstream git repository and already include in
   quntal gnome-power-manager package, so the risk should be low.

[Original Report]

The Power Statistics often gets completely blank. No buttons, no information, nothing!

It doesn't fix itself by closing the window and reopen it.

Steps to reproduce:

1. Open the Power Statistics dialog from the power indicator. The windows appears normal.
2. Close using the close button in the lower right.
3. Reopen the window. The window appears normal.
4. Close using either the Launcher item or the title bar close button.
5. Reopen the window. The window is blank.

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-power-manager (Ubuntu):
status: New → Confirmed
Tim Rawlinson (tim-r) wrote :

This only happens when the window is closed by means other than the close button in the lower right, e.g., from the launcher item or the title bar.

Killing gnome-power-statistics and reopening fixes it until next time.

description: updated
Tim Rawlinson (tim-r) wrote :

Patch attached.

no longer affects: indicator-power (Ubuntu)
tags: added: precise

The attachment "fix.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
menthurae (menthurae) wrote :

This also affects me on a 12.04 AMD64 install with the latest updates.

Dr. Amr Osman (dr3mro) wrote :

please someone apply the patch so it reaches ubuntu users before final release

Chris (cmavr8) wrote :

Still exists in 12.04 final, fully updated today...
Any news from the ubuntu-reviewers team?

Chris (cmavr8) wrote :

BTW proposed fix woks.

Mini Howto:
- Download latest source from here http://ftp.gnome.org/pub/GNOME/sources/gnome-power-manager/3.4/
- untar
- cd to the unpacked directory
$ ./configure
(if it complains about missing packages, install their -dev versions and retry ./configure)
$ make
# make install

Chris (cmavr8) wrote :

Sorry, forgot to mention that after
"- cd to the unpacked directory"
one should change line 1817 of file src/gpm-statistics.c from "return FALSE;" to "return TRUE;"
and then continue with "./configure" etc...

Ivica Ico Bukvic (ico-o) wrote :

Confirming bug on Ubuntu 12.04 x86_64 with latest updates.

Changed in gnome-power-manager (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Kent Lin (kent-jclin) on 2012-06-12
Changed in oem-priority:
importance: Undecided → High
Steve Magoun (smagoun) on 2012-06-12
Changed in oem-priority:
status: New → Confirmed
importance: High → Medium
ONEEB Ahmad (oneeb.magpie) wrote :

I cant find any solution after google this bug so i decided to do it myself

rename the original file "gnome-power-statistics" to "power-statistics"

$ sudo mv /usr/bin/gnome-power-statistics /usr/bin/power-statistics

create a new file with name "gnome-power-statistics" having following code

#!/bin/bash

if [ "$(pidof power-statistics)" ]
then
  kill `pidof power-statistics`
fi
power-statistics
exit

and copy it to /usr/bin
allow it execution
and change owner to root

I m new to bash coding if any good suggestion i appreciate.

Changed in oem-priority:
assignee: nobody → James M. Leddy (jm-leddy)
tags: added: rls-q-incoming
Ivan Sagalaev (isagalaev) wrote :

Another ticket that was just marked as a duplicate of this one has a URL to the upstream bug: https://bugzilla.gnome.org/show_bug.cgi?id=674395

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-power-manager - 3.5.90-0ubuntu2

---------------
gnome-power-manager (3.5.90-0ubuntu2) quantal; urgency=low

  * Add running-after-close.patch: Stop gnome-power-statistics from keeping
    running after closing it. Thanks Tim Rawlinson! (LP: #951827)
 -- Martin Pitt <email address hidden> Mon, 10 Sep 2012 10:15:01 +0200

Changed in gnome-power-manager (Ubuntu):
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

For the record, I just committed the fix upstream as well:

  http://git.gnome.org/browse/gnome-power-manager/commit/?id=5093dbdc5df0b62550219509483a31dda73b6033

Thanks Tim! Unfortunately I don't have an email address from you, so I couldn't commit it under your name.

Changed in gnome-power:
importance: Unknown → Medium
status: Unknown → Fix Released
tags: removed: rls-q-incoming

[Summary]

Patch: https://code.launchpad.net/~ossug-hychen/ubuntu/precise/gnome-power-manager/fix-951827

bzr branch: lp:~ossug-hychen/ubuntu/precise/gnome-power-manager/fix-951827

[IMPACT]

 * To precise users, their Power Statistics often gets completely
   blank. No buttons, no information, nothing! It doesn't fix itself by closing the window and reopen it.

[TESTCASE]

 1. open power statics window from power indicator
 2. close and reopen power statics window several times
 3. after step2, the power statics window displays information correctly

[Regression Potential]

 * the patch is from upstream git repository and already include in
   quntal gnome-power-manager package, so the risk should be low.

description: updated
Changed in gnome-power-manager (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → Medium
Marc Deslauriers (mdeslaur) wrote :

ACK on the branch. Looks good. I've uploaded it to -proposed with a slightly modified, but more appropriate version number for processing by the SRU team.

Thanks!

Hello andrer, or anyone else affected,

Accepted gnome-power-manager into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-power-manager/3.4.0-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-power-manager (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
James M. Leddy (jm-leddy) wrote :

Hi Kent, Please make sure that this bug is satisfactory for the OEM by testing the package in -proposed.

Nara Huang (narahuang) wrote :

Using gnome-network-manager 3.4.0-0ubuntu1.1, this issue is fixed.

Kent Lin (kent-jclin) wrote :

Hi James,

Please see the comment #19. Nara has tested it and confirm it is fixed.

tekstr1der (tekstr1der) wrote :

This issue is fixed for me as well.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-power-manager - 3.4.0-0ubuntu1.1

---------------
gnome-power-manager (3.4.0-0ubuntu1.1) precise-proposed; urgency=low

  * debian/patches/git_terminate-gpm-when-closing-the-window.patch
    - fix Power Statistics window blank (LP: #951827)
 -- Hsin-Yi Chen (hychen) <email address hidden> Thu, 27 Sep 2012 14:11:33 +0800

Changed in gnome-power-manager (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in oem-priority:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.