Ubuntu

Oneiric displays 'Laptop battery critically low' message after AC is unplugged when 'charged' shown on battery indicator

Reported by Philip Khor on 2011-09-27
198
This bug affects 41 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Low
Unassigned

Bug Description

I'm using Oneiric 64 bit on a HP Compaq CQ40.
After the indicator displays 'charged' and the power source is unplugged, a pop-up shows 'Laptop battery critically low'. After clicking the Cancel button, the computer enters hibernation shortly.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-power-manager 3.2.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Tue Sep 27 18:15:50 2011
GnomeSessionIdleInhibited: No
GnomeSessionInhibitors: None
GnomeSessionSuspendInhibited: No
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
MachineType: Hewlett-Packard Compaq Presario CQ40 Notebook PC
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=d275a8c4-581f-43be-af49-5b0a4dfba5e1 ro quiet splash vt.handoff=7
SourcePackage: gnome-power-manager
UpgradeStatus: Upgraded to oneiric on 2011-09-13 (13 days ago)
dmi.bios.date: 11/29/2010
dmi.bios.vendor: Insyde
dmi.bios.version: F.67
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3607
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 99.C4
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnInsyde:bvrF.67:bd11/29/2010:svnHewlett-Packard:pnCompaqPresarioCQ40NotebookPC:pvrF.67:rvnHewlett-Packard:rn3607:rvr99.C4:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: Compaq Presario CQ40 Notebook PC
dmi.product.version: F.67
dmi.sys.vendor: Hewlett-Packard
gnome-power-bugreport: Error: [Errno 2] No such file or directory

Philip Khor (philip10khor) wrote :
summary: - Oneiric displays 'Laptop battery critically low' message after showing
- 'charged' on battery indicator
+ Oneiric displays 'Laptop battery critically low' message after AC is
+ unplugged when 'charged' shown on battery indicator
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-power-manager (Ubuntu):
status: New → Confirmed
François (francois-michonneau) wrote :

I have the same issue on a Dell latitude e6510.

After plugging the AC, a second battery shows up in the indicator (I'm using Gnome 3.2): one being empty (0%) and the other charging or at 100% if fully charged. See attached screenshot.

I also use Compaq Persario CQ40 with Oneric 64bit and I also face exactly the same issue.
Even if the battery is 70%, it say battery critically low and laptop suspends when on battery power.
My Oneric version is not Beta version it is the stable version I installed yesterday.

description: updated
fgr (f-gritsch) wrote :

fresh installation of 11.10 x64 on dell studio 1747 and I have the same problem: full accu, when I unplugg the laptop the warning pops up, that the battery is low and a few seconds later my laptop goes to sleep :(

Chris Musson (chris-cwm) wrote :

I have the same issue on Dell Mini 9 with ubuntu 11.10 i386. When removing the power cable, I usually get a dialog saying the battery is critically low and the laptop powers down 30 seconds later. Occasionally it does not happen (says 99% charged) and once it bizarrely said 96% but only 6 minutes left! So maybe the time left is being misreported.

In addition, when charging or fully charged the battery icon usually does not show the mains power type icon, it shows the battery type icon.

This did not happen in ubuntu 11.04.

Ron Hale-Evans (rwhe) wrote :

My problem is also on a Dell Mini 9 with 11.10. There is a command-line workaround at http://ubuntuforums.org/showthread.php?t=1721757, but I have found it only works intermittently.

russ jackson (russkier) wrote :

Please fix this, it has persisted with me since jaunty, I have used gconf-editor to fix this (editing apps/gnomepowermanager), but this time it is not working. I'm not understanding how this bug has survived 6 iterations. I cant even leave my desk with my laptop, something is horribly wrong...

Also, when you power the machine back up, it goes into panic and the machine needs to be restarted, c'mon guys, I know you can do it!

MSI Wind U100 2GB Ram

Thanks

Changed in gnome-power-manager (Ubuntu):
importance: Undecided → Low

May I inquire as to why a bug that results in the unavoidable powerdown of the computer and potential loss of data from badly supported hibernate functions (as per post # 6) is marked as low priority?

Karl Lyks (caranflo) wrote :

Same problem here, I have an hp pavilion dv6000 with amd turion 64 x2 processor and nvidia graphics. The problem begins when I upgrade to 11.10 from 10.04.

Ron Hale-Evans (rwhe) wrote :

The problem affects me gravely enough that I'm planning to downgrade to 10.04 unless this issue is elevated. It's difficult to credit that a bug that turns laptops into desktops has been assigned an importance of Low.

Ron Hale-Evans (rwhe) wrote :

Possible workaround: I tested 10.04 LTS and it is indeed free of this bug. Creating a dual-boot 11.10/10.04 machine is an option.

Why this bug is marked with low importance? It makes the laptop unusable in battery power.
And about the workaround mentioned in the #13 comment, I think it is rather suggesting not use 11.10 and rather asking to use 10.04.
Could this issue be considered as a high priority issue?

Thanks

Andrew Somerville (andy16666) wrote :

A lot of people seem to be moving back to the LTS, myself included. Of course many of us probably should have stuck with the LTS in the first place. It's just that historically, Ubuntu has done well enough with the six month releases that they could be used in a production environment. Hopefully they'll get better at some point, but many of us aren't in a position to wait.

Silvio (silviorrs) wrote :

Same problem here (hp pavilion dv5020 with amd turion 64 processor and ATI graphics). The problem begins when I instaled the 11.10. It makes my laptop unusable in battery power what is very important to me. Why this bug is low importance?

Amneet Bedi (amneetbedi) wrote :

Requesting the bright minds out there to please take this issue on priority! Its just frustrating to see my netbook hibernate even after clicking 'CANCEL' on the pop-up warning message. (PS: Using Sony Vaio VPCM126AG, Intel Atom Processor). The issue came up when upgraded the system from 11.04->11.10!

Hi,

Here is a work around that worked for me.
When the pop up comes do not click on the Cancel or OK button. Just use the close button on the window title bar (the cross button in red) to close the pop up. Doing this will not put the laptop in hibernate or suspend mode and you can continue work.
This worked for me very well. Please give it a try and share your findings, then we can suggest this as work around, till the issue is fixed permanently.

Thanks
Bishnu

Ron Hale-Evans (rwhe) wrote :

Bishnu, thanks for the suggestion. Your workaround didn't work for me, whether my netbook was configured to hibernate or shut down on low power. (Dell Inspiron 910 / Dell Mini 9.) The system powered down within 30 seconds even when I closed the pop up with the cross button. I'm glad someone has found a workaround, anyway.

As this breaks usability of the laptop in portable modes, I'd suggest heavily too that this be upgraded in priority.

Cary Townsend (carytownsend) wrote :

Same issue on Dell Mini 9 after upgrade. Tried live distro, same issue, so it's not caused by upgrade. Recalibrated battery, ran for 2.5 hours on battery to off, so it's safe to say the battery is not, in fact, critically low...

Cary Townsend (carytownsend) wrote :

Oh, and I agree -- this should be *much* more important that 'low', as it makes the laptop useless if I can't remove it from the corner where I charge it...

Ron Hale-Evans (rwhe) wrote :

Dell Mini 9 users, what firmware versions are you running? Mine is A04. Is anyone running the most recent (A07, May 2011)? Thanks.

Ron Hale-Evans (rwhe) wrote :

BIOS A05 in particular is reputed to fix many battery problems.

Ron Hale-Evans (rwhe) wrote :

I finally found a workaround in this thread: http://ubuntuforums.org//showthread.php?t=1866533 . Specifically,

$ gsettings set org.gnome.settings-daemon.plugins.power 'use-time-for-policy' 'false'

made it possible to run my netbook for several minutes without AC (I didn't bother trying longer), and dconf-tools and experiment show this setting is persistent across reboots.

The only drawback for me was that I couldn't reboot without AC; my netbook hung on a blank screen.

Good luck!

Amneet Bedi (amneetbedi) wrote :

The above workaround works!! :) Smiles :)
PS: u have to install dconf-tools for it ! Cheers :)

Cary Townsend (carytownsend) wrote :

Another workaround:

1) Close lid, let laptop go to sleep.
2) Unplug laptop.
3) Open lid, wakeup.
4) Use your laptop.
5) When done, close lid, let it go to sleep.
6) Plug in.

Works on my Dell Mini9...

How do we raise the severity to 'Critical'? This is a showstopper for effected laptop users...

Philip Khor (philip10khor) wrote :

"Changeable only by a project maintainer or bug supervisor."
I agree, it should be at least High.

Sly Houston (slyhouston) wrote :

I experience the same behavior, both after upgrading from 11.04, and with a clean install of 11.10. I'm using a Sager NP2096. If I click on my battery icon, I see a second (phantom) battery that's completely empty - so I'm not sure if my case is identical to the above. This is also a big show-stopper for me.

edicius (ediciusnj) wrote :

Same behavior here too as well. Very frustrating. Should at the very least be a 'High' importance.

Ron, I'm using a Mini 9 and honestly, I'm not sure if I've updated the BIOS ever on here. I'd up it to A07, but haven't had the time as yet to jump through all the hoops necessary (since the only update I've found is a Windows executable). Might try it this week and see if it makes any kind of difference, though with such an unorthodox method of updating the BIOS, I'm understandably nervous about bricking.

I've found that editing /usr/share/polkit-1/actions/org.freedesktop.upower.policy so that hibernate's <allow_active> to "no" fixed it for me. It completely removes hibernate functionality (a plus for me as I abhor that garbage). As an added bonus it removes it from the session menu.

calbaker (calbaker) wrote :

I tried reporting the bug under gnome battery status to see if this accomplishes anything: https://bugs.launchpad.net/battery-status/+bug/890314

@calbaker, thanks for the effort. However, we should not be splitting reports up. That's one and the same bug and there's no use having multiple issues filed.

calbaker (calbaker) wrote :

@Chauncellor, I did this because I thought this was a gnome specific bug and not an Ubuntu bug. I thought that is why it is marked as low priority, and I thought that reporting it under gnome would get it to a place where it can be a high priority. If it belongs here, mark it high priority. I'm pretty close to switching to Fedora, Debian, or some other distro because this is really a terrible problem to mark as low priority. I looked like an idiot a few weeks ago when presenting at a conference and my laptop decided to hibernate. What do you expect me to do, use my Windows 7 partition?

@calbaker, I'm sorry for your troubles. However, that's not the proper way of using launchpad. If this is indeed a gnome-specific bug then it should be reported upstream to bugzilla.gnome.org and then linked here.

Have you attempted the workarounds (including my post 31?).

Heiko Scheit (h-scheit) wrote :

So what is the 'proper way' of raising the priority of this bug? It is clear that this bug should have the highest priority and a fix should be included with the normal updates and not just a workaround.

I wrote the initial importance assigner on this bug requesting it be re-evaluated for Importance based on the terms at https://wiki.ubuntu.com/Bugs/Importance and citing specifically the following reasons:

Has a severe impact on a small portion of Ubuntu users (estimated)
Makes a default Ubuntu installation generally unusable for some users
A problem with an essential hardware component (disk controller, laptop built-in wireless, video card, keyboard, mouse)
Has a moderate impact on a large portion of Ubuntu users (estimated)

calbaker (calbaker) wrote :

@Chauncellor, I'll look into reporting the bug upstream. The workarounds did not work for my computer, and I've tried like 3 of them now.

Turns out this bug is a dupe. I found the correct bug and you'll all be happy to hear that the importance is more suitable.

Marking this as a duplicate of bug 531190.

calbaker (calbaker) wrote :

Excellent! I have subscribed to the new big, and it definitely appears to be the correct underlying problem.

Andrew Somerville (andy16666) wrote :

It looks like this bug is probably not duplicate of bug #531190. This issue appears to be specific to 11.10, and the other bug is related to the LTS, Lucid.

Luke Hall (lukazb) wrote :

upower is also behaving strangely. Looks like from time to time it shows bad data (see attachment). It seems that the "critical battery level" warning appers when the bad data has been received over a longer period which makes the routine calculating the remaining time go haywire.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers