Battery Power Status Not Reliably Detected

Bug #768557 reported by Tomás Gutiérrez on 2011-04-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 10.10, 64bit
Dell E5410
Binary package hint: gnome-power-manager

The battery indicator is not reliably responding to changes in charger connection/battery status. This started happening recently (within last month). Strange behavior is that in Virtualbox the guest OS (Win 7 in this case) does pick up the power status correctly and quickly.

The other strange behavior is that the battery meter is unresponsive when left-clicked and then select the status (i.e. "Laptop battery is charged").

This is critical because it's also affecting the standby/hibernate functionality.

I tried restarting gnome-power-manager but it was unresponsive.

On an interesting note, gnome-power-statistics works as expected, and updates immediately when there is a change.

description: updated
description: updated
description: updated

Interesting development - This only happens when I plug my iPhone 4 via USB to the computer. When it's plugged in the gnome-power-manager ceases to work correctly, even after the iPhone is disconnected. The only way to fix it is to bounce the gnome-power-manager process after disconnecting the device.

Please let me know what kind of logs/traces I should get in order to help resolve this issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers