Ubuntu

Laptop brightness on Dell XPS not controllable

Reported by Zordid on 2011-04-16
98
This bug affects 19 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Undecided
Unassigned

Bug Description

 ERROR: Method "GetBrightness" with signature "" on interface "org.freedesktop.UPower.KbdBacklight" doesn't exist

The brightness of my laptop's screen is not changed at all when using the Fn-Keys.
Ubuntu displays the notification area with the brightness setting displayed, it even shows that the brightness value is changed - but the actual brightness of the screen remains the same at all times!

Laptop: Dell XPS 17, Full-HD 3D display, Nvidea graphics.

Zordid (zordid-gmx) on 2011-04-16
tags: added: brightness control screen
Fabio Marconi (fabiomarconi) wrote :

Hello
Can you please folow this guide?
https://wiki.ubuntu.com/Kernel/Debugging/Backlight
For any question, just ask here.
Thanks
Fabio

Changed in ubuntu:
status: New → Incomplete
Zordid (zordid-gmx) wrote :

The behavior I see does not quite fit into the 4 categories described in the document.
Controls *seem* to work as function keys bring up the OSD and the bar can be moved up and down - only the screen's actual brightness does not change at all.

Okay, I tried the following:

 * added acpi_backlight=vendor to the kernel parameters => no changes in behavior and result.

 * looked at the /proc/acpi => no video there

 * looked at sys/class/backlight, found dell_backlight there with max brightness 15, actual_brightness can be changed with the fn-keys.

Then I did:
zordid@Dell-XPS:/sys/class/backlight/dell_backlight$ dmesg|grep 'ACPI: Video'
[ 14.193426] ACPI: Video Device [PEGP] (multi-head: yes rom: no post: no)
zordid@Dell-XPS:/sys/class/backlight/dell_backlight$ lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation Device 0dcd (rev a1)

What else do you need? I do not quite understand the next "steps"... sorry!
Can you give me a hint of what else is important?

Zordid (zordid-gmx) wrote :

I got a new discovery: when playing with the brightness values I left the actual_brightness at 0 (using the fn-keys).

After rebooting Ubuntu the screen's brightness was LOW! So, the brightness value actually ends up controlling the screen's brightness - but only at boot-time and only once!

I raised the level again using fn-keys (nothing happend on the screen), restarted and it was bright again!

Fabio Marconi (fabiomarconi) wrote :

Hello
Can you please run this in a terminal:

killall gnome-power-manager && gnome-power-manager --verbose 2>&1 | tee ~/gpm.log

This kills gnome-power-manager and re-executes it in verbose mode, saving the log file gpm.log to your home directory. Try to change the brightness then attach this file to the report.

The most useful things in this log are usually the values that g-p-m thinks that things are. You can look through to see if they match your expectations and what you've set them to by other means.
Thanks
Fabio

affects: ubuntu → gnome-power-manager (Ubuntu)
Zordid (zordid-gmx) wrote :

Here's the log file.

Turned brightness down to lowest setting and up again using the fn-keys. Nothing happened to the actual brightness, of course!

Fabio Marconi (fabiomarconi) wrote :

TI:00:21:52 TH:0x6d70a0 FI:gpm-backlight-kbd.c FN:gpm_backlight_kbd_init,646
 - ERROR: Method "GetBrightness" with signature "" on interface "org.freedesktop.UPower.KbdBacklight" doesn't exist

*** WARNING ***
TI:00:21:52 TH:0x6d70a0 FI:gpm-backlight-kbd.c FN:gpm_backlight_kbd_init,650
 - GetBrightness failed!

description: updated
Changed in gnome-power-manager (Ubuntu):
status: Incomplete → Confirmed
Fabio Marconi (fabiomarconi) wrote :

Hello Zordid
can you please run in a terminal
uname -a
and paste here the output
Thanks
Fabiio

Zordid (zordid-gmx) wrote :

uname -a yields:

Linux Dell-XPS 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

tags: added: amd64 natty
removed: brightness control screen
Timo Vanwynsberghe (timovwb) wrote :

I can confirm the exact same results on the same laptop.

Dell XPS l702x with full-hd 3d display and NVidia GT 555m.

$ uname -a
Linux timo-laptop 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Gary Herron (gherron-digipen) wrote :

I too can confirm this. I've the same machine (XPS l702x aka XPS 17), display (hd 3D), and graphics card (GT 555m). Same results on each of the above suggested tests. All indications (OSD, /proc values, g-p-m output) are that the brightness is changing, but the actual screen does not change. (Haven't tried the reboot trick yet.)

Brad Herring (brad-bherville) wrote :

I can confirm this as well with the same system, Dell XPS l702x 3D NVidia GT 555m.
$ uname -a
Linux ubuntu-star-destroryer 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Stéphane (s-jacquemain) wrote :

I too can confirm this. Dell XPS l702x 3D NVidia GT 555m.

- ERROR: Method "GetBrightness" with signature "" on interface "org.freedesktop.UPower.KbdBacklight" doesn't exist

Olivier (olagache) wrote :

I can confirm this as well with the same system, Dell XPS l702x 3D NVidia GT 555m.
I'm using KDE and i've not OSD indications when using Fn Key

$ uname -a
Linux aragorn 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Olivier (olagache) wrote :

The value in files
  - /sys/class/backlight/acpi_video0/brightness
  - /sys/class/backlight/acpi_video0/actual_brightness

changes (from 0 to 15) when using Fn Keys but not the brightness of screen. The OSD appear only when value is equals to 15.

I can confirm the problem on a Dell XPS l702x with 3D NVidia GT 555m

I have solved the problem here by adding the following to xorg.conf:

Option "RegistryDwords" "EnableBrightnessControl=1"

Hope this helps,
Pierre

Additional note to my previous comment: this is on a Debian Unstable, with proprietary nvidia module (280.13-4). Not sure if this can work with nouveau.

Timo Vanwynsberghe (timovwb) wrote :

The solution from Pierre Chifflier appears to work on Ubuntu 11.04 with the proprietary nvidia drivers too.

Eduard Ereza Martínez (ereza) wrote :

I can confirm that this still happens on 12.04 LTS.

Adding the line to xorg.conf as suggested by Pierre Chifflier makes it work correctly. I'm using proprietary drivers too.

I can also confirm that the suggestion posted by "Pierre Chifflier" works. Though myself not being a computer geek I had problems implementing it. Below is the example of how it looks on my xorg.conf file and this works for me.

Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "TwinView" "1"
    Option "TwinViewXineramaInfoOrder" "DFP-2"
    Option "metamodes" "DFP-0: 1680x1050 +1920+15, DFP-2: 1920x1080 +0+0"
    Option "RegistryDwords" "EnableBrightnessControl=1"
    SubSection "Display"
        Depth 24
    EndSubSection
EndSection

Note: this is just an example for those who don't know where the following line appears

Look above for => Option "RegistryDwords" "EnableBrightnessControl=1"

Thanks everyone, Special Thanks to "Pierre Chifflier"

Cheers,
Hemant

For the non-tecnically minded could someone please explain exactly what to type or do to:

"add the following to xorg.conf:

Option "RegistryDwords" "EnableBrightnessControl=1"

I have no idea how to add this to the xorg.conf file.

This bug is extremely irritating. When the laptop enters power saving mode and you wake it up from a blank screen the screen is extremely bright and almost unusable even though the screen was dim and had a good screen brightness before powersaving mode.

There are a number of other very dissapointing bugs/ things that are wrong with Ubuntu 12.04 running on my Dell XPS L702X laptop.

Why does my xorg.conf file look like the following and not like Hemantkumar Gaswami's xorg.conf file?
This is what I have:

Section "Device"
 Identifier "Default Device"
 Option "NoLogo" "True"
EndSection

Daniel Woodworth (hdastwb) wrote :

I have fixed this by changing my xorg.conf file from this:

Section "Device"
 Identifier "Default Device"
 Option "NoLogo" "True"
EndSection

to this:

Section "Device"
 Identifier "Default Device"
 Option "NoLogo" "True"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection

Bjarne Kristensen (zeraxxus) wrote :

I have a DELL XPS L702X laptop with the nVidia GTX 555M 3GB RAM with the 120Hz 3D Screen.

I use Ubuntu 12.10 32-bit with the Experimental NVIDIA binary Xorg driver from nvidia-experimental-310(proprietary).

Thanks to all the comments, I got my Fn+F4/F5 brightness working aswell.

Though I did not have an /etc/X11/xorg.conf file to put the settings in, I created it manually using

sudo gedit /etc/X11/xorg.conf

and added only this:

Section "Screen"
 Identifier "Default Screen"
 Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection

and saved the file.

I rebooted the system, and now the keys work.

I hope the issue gets resolved at some point.

Thanks again from a new Ubuntu user.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments