Ubuntu

Battery indicator shows that laptop battery is fully charged when is not

Reported by Miguel on 2011-03-12
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Undecided
Unassigned
pm-utils (Ubuntu)
Undecided
Unassigned
upower (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-power-manager

When I have the laptop plugged to the AC power, the battery indicator shows me the real value of percentage of my battery level.

Nonetheless, when I unplug the AC power and use the battery of the laptop, the battery indicator tells me that the "laptop battery is charged" even though it is not fully charged. It happens always, till the laptop shuts down because there is no battery left.

In other words, the battery indicator works fine with AC power but it does not when working with the battery of the laptop.

I am using ubuntu 11.04 alpha 3 (64 bits) with an HP Pavilion dv6000 laptop. This very same problem happened to me already with the ubuntu 10.04 release (and report the problem in the bug 577557) but a solution was not found. I hope this time I arrive in time to be able to solve the problem.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gnome-power-manager 2.32.0-2ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
CurrentDmesg:
 [ 33.814850] EXT4-fs (sda5): re-mounted. Opts: errors=remount-ro,commit=0
 [ 39.940017] eth1: no IPv6 routers present
 [ 60.006953] exe (1846): /proc/1846/oom_adj is deprecated, please use /proc/1846/oom_score_adj instead.
 [ 271.237312] show_signal_msg: 18 callbacks suppressed
 [ 271.237318] unity-window-de[2779]: segfault at 318 ip 0000000000415bcf sp 00007fff530c8cc0 error 6 in unity-window-decorator[400000+1b000]
Date: Sat Mar 12 16:11:35 2011
GnomeSessionIdleInhibited: No
GnomeSessionInhibitors: None
GnomeSessionSuspendInhibited: No
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
MachineType: Hewlett-Packard HP Pavilion dv6700 Notebook PC
ProcEnviron:
 LANGUAGE=en
 LANG=es_ES.UTF-8
 LC_MESSAGES=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-5-generic root=UUID=7661a7c8-5f9f-4a12-9462-fa2e2902ca77 ro quiet splash vt.handoff=7
SourcePackage: gnome-power-manager
UpgradeStatus: Upgraded to natty on 2011-03-03 (8 days ago)
dmi.bios.date: 05/14/2008
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.56
dmi.board.name: 30CC
dmi.board.vendor: Quanta
dmi.board.version: 79.2E
dmi.chassis.type: 10
dmi.chassis.vendor: Quanta
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.56:bd05/14/2008:svnHewlett-Packard:pnHPPaviliondv6700NotebookPC:pvrRev1:rvnQuanta:rn30CC:rvr79.2E:cvnQuanta:ct10:cvrN/A:
dmi.product.name: HP Pavilion dv6700 Notebook PC
dmi.product.version: Rev 1
dmi.sys.vendor: Hewlett-Packard

Miguel (miguel-duran-sindreu) wrote :

Affects me! In windows 7 the battery works fine even when I keep it unplugged from the charger, but in Natty if I keep it unplugged for more than 15 seconds it shuts down... Windows reports 100%, Ubuntu reports 0% the second it's off the charger despite saying "battery is charged."

I may have figured it out. You'll have to calibrate the battery under ubuntu.

open gconf-editor from Terminal.

go to apps/gnome-power-manager/actions.

set critical_battery to "nothing".

unplug machine.

let it die.

plug it in.

KEEP IT ON THE CHARGER.

unplug.

seems to work for my HP dv6000 so far.

Ahmad Tarek (ahmadtarek) wrote :

I have ACER ASPIRE 5920G and I got the same problem after disconnecting the power. The message appear is always the battery is charged with no indicator.

Changed in gnome-power-manager (Ubuntu):
status: New → Confirmed

Alright, my trick doesn't seem to fare too well after an hour or two; the battery indicator just kind of stops at 38%. And now it shows a full battery icon and "Laptop battery is charged" despite being at 38% in the Power Statistics.

Ahmad Tarek (ahmadtarek) wrote :

I think this bug is fixed in Beta 2. I updated my distro and now it is working perfectly fine. What do you think?

Miguel (miguel-duran-sindreu) wrote :

I updated to the Beta 2 as well but the bug is still present in my case. Did you did any additional thing to solve it (apart from upgrading)? I also tried what Kyle Reynolds proposed but it didn't work out either. When the AC power is connected, it always says "estimating", whereas when unplugged, it says "Laptop battery is charged".

I hope it gets solved soon, thanks to those who tried to solve it anyway!

I'm still having the issue on Beta 2. Was this issue present on non-natty versions? This is my first time using Ubuntu as my main.

Also, two "Laptop battery is charged" items appear when I click the battery.

And Windows 7 Ultimate displays battery as 100% and discharges properly from what I gather, if that helps.

I'm about to try the BIOS update that apparently came out

Oh, nevermind -- Windows 7 has the same issue. Hopefully it's something wrong with the battery and not the whole computer itself.

Ahmad Tarek (ahmadtarek) on 2011-04-20
Changed in gnome-power-manager (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Confirmed
Miguel (miguel-duran-sindreu) wrote :

Hi,

In mi case I have both Windows 7 a Ubuntu on my laptop. On Windows 7 the battery indicator goes perfect with or without plugging. Nonetheless with Ubuntu, even with Beta 2, the problem that I reported is still happening. Hence, it is a problem with the operating system, not with the Hardware.

This issue is not new, years ago I also created the bug 577557 for the Ubuntu 10.04 but it was not solved. Before that version I do not know if that problem existed since at that time I only used Ubuntu on Personal Computers.

gv (gvossen2093) wrote :

This is a definite problem. Not only does it not read the battery information correctly but it ruins your battery so it never fully is able to reach it's full capacity again. I have gone through several batteries with my HP 6700t. I like linux but will not run it in a live machine anymore. I guess you get what you pay for. I am going to try an install of another distro in a last attempt to recover my batteries full capacity. Currently running Ubuntu 11.04

fringd (fringd) wrote :

affects me too, sandy bridge core i5, samsung series 9 2012

Marius B. Kotsbak (mariusko) wrote :

Has anyone seen this issue in Ubuntu 12.04 or 12.10?

On 12.04 it is still faulty. (I have not tried 12.10.) Shows fully
charged and still on power after being unplugged and allowed to run
flat. It works perfectly if unplugged before booting Ubuntu.

If put on charge while the indicator is working, and allowed to become
fully charged, then the indicator gets stuck again.

Windows XP running in Virtualbox does show the correct battery level
regardless of the charge history.

On Acer Aspire One.

On 30/10/2012 13:48, Marius Kotsbak wrote:
> Has anyone seen this issue in Ubuntu 12.04 or 12.10?
>

--
Norman Perelson

Would you be able to test a Ubuntu 12.10 live CD?

Changed in gnome-power-manager (Ubuntu):
status: Confirmed → Incomplete
tags: added: precise

Tested on 12.10: Same behaviour. (Battery status stays "charged" after
removing charging power.)

Discovered a work-around to get the is to unplug from charge for a
second or two, then plug in again for a second and then unplug it again
before the battery status has returned to fully charged.

I also found that suspending and waking the computer also gets the
battery indicator working again.

On 30/10/2012 23:42, Marius Kotsbak wrote:
> Would you be able to test a Ubuntu 12.10 live CD?
>
> ** Changed in: gnome-power-manager (Ubuntu)
> Status: Confirmed => Incomplete
>
> ** Tags added: precise
>

--
Norman Perelson
+27-87-151-1587

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → Confirmed
tags: added: quantal-unity running
removed: running-unity
summary: - Battery indicator shows "Laptop battery is charged" when is not
+ Battery indicator shows that laptop battery is fully charged when is not
Miguel (miguel-duran-sindreu) wrote :

I just upgraded to Ubuntu 12.10 and the battery indicator is still not working when unplugged from AC power. Nonetheless, I tried what Norman said about suspending and waking the computer and I could see my real battery status for a while (afterwards it went wrong again with an icon indicating as if it was charging when it is not). Thanks again to everyone and hope this hint leads to a solution!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pm-utils (Ubuntu):
status: New → Confirmed
Changed in upower (Ubuntu):
status: New → Confirmed
a_cardoso (apierre-cardoso) wrote :

This happend on Ubuntu 12.04, 12.10, Mint 14 and Mint debian edition to me. I'm on a samsung series 5.

When I'm charging my battery, if the charge hits 100%, the indicator got stuck on 100% (never decreases again), until I shutdown. After rebooting he works normally again.
If I stop the charge before hit 100% it works perfectly.

Julie (januaryj) wrote :

I also have a samsung series 5 with ubuntu 12.10 and this bug/problem affects me also. Have anyone found a solution yet?

Julie (januaryj) wrote :

This problem is still present in Ubuntu 13.04....

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers