Ubuntu

Idle timeout does not deal with simultanious logins

Reported by Onno Benschop on 2006-11-26
8
Affects Status Importance Assigned to Milestone
gnome-power
Confirmed
Medium
gnome-power-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-power-manager

If two users are logged in (on a laptop), then the idle timeout from the non-active user will affect the power use of the active user.

The way this manifests itself is that the screen brightness dims while the machine is in use.

Changing the brightness back and continuing to work will keep the brightness at the expected level.

Steps to reproduce this problem:
  1. Login as user 1.
  2. Login as user 2.
  3. Switch back to user 1.
  4. Continue to work.
  5. After the idle time-out for user 2 has been reached the screen dims.
  6. Set the brightness to full as user 1.
  7. Continue to work.

Riccardo Setti (giskard) wrote :

hello,

yes, you are right, i will report this to the upstream bugzilla.

Changed in gnome-power-manager:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Onno Benschop (onno-itmaze) wrote :

Assigned the remote watch to the original report.

Onno Benschop (onno-itmaze) wrote :

That bug shows this as a duplicate:
 http://bugzilla.gnome.org/show_bug.cgi?id=358483

Which in states: (Richard Hughes)
I know, this is known broken. When more distros start shipping PolicyKit (and maybe another project that Jon is working on) then this will be fixed properly (i.e. managed), but I'm not sure there is anyway we can bodge this on g-p-m's side. I think ubuntu use check-forground-console or something. That might be worth looking into as a temp fix.

Changed in gnome-power:
status: Unknown → Confirmed
Onno Benschop (onno-itmaze) wrote :

I have also noticed that this effect also happens if you have two window managers running on two screens. One screen will time-out, stealing the keyboard/mouse focus, even while there is activity on the second screen - with the same user.

I suppose it's in effect the same situation, that is, two window mangers running - though in the reported form both are on the same screen with different users, what I'm adding is that it also happens with different screens with the same user.

BTW, flicking the mouse across the timed-out screen solves the problem - but you still need to focus back to the window you were working on.

This comment was added just to document a different scenario with the same problem. No further action is required.

Changed in gnome-power-manager (Ubuntu):
status: Confirmed → Triaged
Scott Howard (showard314) wrote :

Hello, we haven't heard about this bug in some time, and policy-kit in now standard in Debian/Ubuntu. Has this bug been fixed or resolved? Thanks. (setting to incomplete so I know to check up on this, if it still exists, set back to "triaged")

Changed in gnome-power-manager (Ubuntu):
status: Triaged → Incomplete

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → Invalid
Changed in gnome-power:
importance: Unknown → Medium

Thank you for taking the time to report this bug and helping to make Ubuntu better. My apologies as I should not have marked this Invalid. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Maverick Meerkat. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in gnome-power-manager (Ubuntu):
status: Invalid → Incomplete

Thank you for reporting this bug. This bug is confirmed in Maverick Meerkat. My User 1 is the first profile created when installing Maverick native. In User 1 primary click System -> Preferences -> Power Management -> one may place the screen brightness as far down as possible. Then I created a User 2, locked screen of User 1, switched to User 2, default brightness was 100%, locked screen of User 2, went back to User 1, screen is at full brightness and cannot be changed despite User 1 prior preferences.

lsb_release -rd
Description: Ubuntu maverick (development branch)
Release: 10.10

apt-cache policy gnome-power-manager
gnome-power-manager:
  Installed: 2.32.0-0ubuntu1
  Candidate: 2.32.0-0ubuntu1
  Version table:
 *** 2.32.0-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.