Screen backlight adjustment stopped working on MacBook Pro 5,4 and other hardware

Bug #726692 reported by Mario Vukelic on 2011-02-28
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Low
Unassigned

Bug Description

The nvidia-current drivers that have recently become available in Natty (270.29) work for me in general, but screen backlight adjustment does not work anymore on my MacBook Pro. Other hardware seems also affected, e.g an Nvidia GT330M in this thread: http://ubuntuforums.org/showthread.php?p=10505235

Neither the keyboard keys nor the brightness applet slider works, the applet icon showing a stop sign as usual when brightness adjustment is not available.

Adding this to xorg.conf makes it somewhat work again after a reboot.
Option "RegistryDwords" "EnableBrightnessControl=1"

However, this makes only the adjustment work as such; I still don't get the notification bubble that appeared with previous drivers, and which still appears in Natty when I use the nouveau drivers.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: nvidia-current 270.29-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
NonfreeKernelModules: nvidia wl
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 270.29 Wed Feb 23 16:18:35 PST 2011
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-3ubuntu3)
Architecture: amd64
CompizPlugins: [core,bailer,detection,uTouch,composite,opengl,decor,move,place,regex,compiztoolbox,resize,grid,snap,vpswitch,mousepoll,wall,session,gnomecompat,animation,workarounds,expo,ezoom,staticswitcher,fade,scale]
CompositorRunning: compiz
Date: Mon Feb 28 19:03:50 2011
DistUpgraded: Yes, recently upgraded Log time: 2011-02-16 12:35:27.758238
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 270.29, 2.6.38-5-generic, x86_64: installed
 bcmwl, 5.100.82.38+bdcom, 2.6.38-5-generic, x86_64: installed
GraphicsCard:
 nVidia Corporation C79 [GeForce 9400M] [10de:0863] (rev b1) (prog-if 00 [VGA controller])
   Subsystem: Apple Computer Inc. Device [106b:00ba]
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100131)
MachineType: Apple Inc. MacBookPro5,4
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=de_DE.utf8
 LC_MESSAGES=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-5-generic root=UUID=8d2a8ff1-ec5f-4fdb-8d1d-803044f16759 ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: nvidia-graphics-drivers
dmi.bios.date: 06/15/09
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBP53.88Z.00AC.B03.0906151647
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-F22587A1
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBookPro5,4
dmi.chassis.asset.tag: Asset Tag#
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F22587A1
dmi.modalias: dmi:bvnAppleInc.:bvrMBP53.88Z.00AC.B03.0906151647:bd06/15/09:svnAppleInc.:pnMacBookPro5,4:pvr1.0:rvnAppleInc.:rnMac-F22587A1:rvrMacBookPro5,4:cvnAppleInc.:ct10:cvrMac-F22587A1:
dmi.product.name: MacBookPro5,4
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
version.compiz: compiz 1:0.9.4-0ubuntu1
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1~git20110215.cc1636b6-0ubuntu2
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu8
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu11
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu5

Mario Vukelic (mario-vukelic) wrote :
Mario Vukelic (mario-vukelic) wrote :

I verified the "can't change backlight (without the xorg.conf option) both in a Unity session and a Classic session with effects. The 'still don't get a notification bubble" was verified only in the Classic session so far, Unity will have to wait.

Mario Vukelic (mario-vukelic) wrote :

Even with "EnableBrightnessControl=1", the Brightness Applet shows the stop sign and the slider position cannot be changed. (As stated above, the keyboard keys work though)

summary: - Screen backlight stopped working on MacBook Pro 5,4 and other hardware
+ Screen backlight adjustment stopped working on MacBook Pro 5,4 and other
+ hardware
Bryce Harrington (bryce) wrote :

Maybe this is an -nvidia bug, but if so there's not much we can do about it at the distro level. So I think this would be better to be reviewed by the g-p-m guys first.

If it does turn out to be something to do with -nvidia particularly, it should be reported upstream - see http://www.nvnews.net/vbulletin/showthread.php?t=46678

affects: nvidia-graphics-drivers (Ubuntu) → gnome-power-manager (Ubuntu)
Mario Vukelic (mario-vukelic) wrote :

I can now confirm that the notification bubble does not appear under Unity either.

Chad A. Davis (chadadavis) wrote :

On the MacBookPro6.2 the keyboard controls do not work either. I have not yet found a way to adjust the backlight, manually or otherwise.

Steve Magoun (smagoun) wrote :

The keyboard backlight controls do work in Natty on my MacbookPro 3,1 [GeForce 8600M GT] using the nvidia-current (270.30-0ubuntu3) driver. The notifications work as expected too.

Daniel van Vugt (vanvugt) wrote :

There is a very similar bug here: #743352. However with bug #743352 the notification bubble appears to work and even /sys/class/backlight/mbp_backlight/* seems to function, but without correctly affecting the backlight.

Do sufferers of #726692 have the subtree /sys/class/backlight/mbp_backlight/* ?

Mario Vukelic (mario-vukelic) wrote :

I have /sys/class/backlight/ but nothing below it. Though as per my original comment my backlight adjustment still works with the keyboard keys, having 'Option "RegistryDwords" "EnableBrightnessControl=1"' set.

Mario Vukelic (mario-vukelic) wrote :

I'm the OP and adjustment and bubble started to work again for me after a new Natty install using yesterday's daily installer build, running nvidia-current. (The installer installed 173, but current was recommended in jockey. Anyway, the adjustment & bubble worked with 173 as well)

Mario Vukelic (mario-vukelic) wrote :

Sorry, my previous comment #10 was incorrect. What worked again after the reinstall was just the notification bubble, but it did not actually change the brightness. I had to add the EnableBrightnessControl option again, to the new xorg.conf that was created during installation. After an X restart I now have the bubble and it actually works:

Section "Device"
        Identifier "Default Device"
        Option "NoLogo" "True"
        Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection

Dmitry Kolesnikov (kastaneda) wrote :

This workaround (with "EnableBrightnessControl=1") does not work anymore with nVidia driver 270.41.06 (in 11.04).

I heard about a possible solution: just add "acpi_osi=Linux" to kernel options (in GRUB config or manually on boot). So far I have not tested it. I can check it out after a few hours (and report the results).

Mario Vukelic (mario-vukelic) wrote :

I'm the OP and Ubuntu 11.04 continues to work for me with:

aptitude show nvidia-current
Package: nvidia-current
State: installed
Automatically installed: no
Version: 270.41.06-0ubuntu1

cat /var/log/Xorg.0.log
(...)
[ 17.876] (II) NVIDIA(0): NVIDIA GPU GeForce 9400M (C79) at PCI:3:0:0 (GPU-0)
[ 17.876] (--) NVIDIA(0): Memory: 524288 kBytes
[ 17.876] (--) NVIDIA(0): VideoBIOS: 62.79.3e.00.0e
(...)

cat /etc/X11/xorg.conf
Section "Device"
 Identifier "Default Device"
 Option "NoLogo" "True"
 Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection

However, prompted by Dimitry's comment I had checked the drivers and had found that in this fresh Ubuntu 11.04 installation, Jockey had installed the nvidia-173 drivers by default. They worked fine, but I decided to try the nvidia-current (which I had used before with the previous install) and used Jockey to switch. This made Jockey install a new xorg.conf without the EnableBrightnessControl option. On reboot the keyboard brightness keys did therefore not work, I had to add the option to xorg.conf again and restart X.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the stable release - Oneiric Ocelot. It would help us greatly if you could test with it so we can work on getting it fixed. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in gnome-power-manager (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Chad A. Davis (chadadavis) wrote :

On my MacBookPro 6,2 the bug is not reproducible on Oneiric. The keyboard backlight controls work correctly out-of-the-box.

Mario Vukelic (mario-vukelic) wrote :

I'm the OP and it works again for me in Oneiric without the xorg.conf option. Same MacBook Pro 5.3.

Mario Vukelic (mario-vukelic) wrote :

Damn, sorry, it's not fixed for me after all. Once again I got fooled by the bubble appearing - but without the option, the brightness does not change. This is all in an installed Oneiric by the way, I will try to test with a live CD.

Launchpad Janitor (janitor) wrote :

[Expired for gnome-power-manager (Ubuntu) because there has been no activity for 60 days.]

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → Expired
Mario Vukelic (mario-vukelic) wrote :

This is still the same in a new install of Quantal (and IIRC it also was the same in Precise. However, I had not made a reinstall of Precise, but upgraded from Oneiric, so I didn't have to actually do anything to make it work, and therefore I am not sure)

tags: added: quantal
Changed in gnome-power-manager (Ubuntu):
status: Expired → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers