apport-package hook calls gnome-power-bugreport which wants lshal

Bug #721592 reported by Brian Murray on 2011-02-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Low
Martin Pitt

Bug Description

Binary package hint: gnome-power-manager

lshal isn't installed on new systems any more (well except for Xubuntu) so gnome-power-manager bug reports will be somewhat less informative as gnome-power-bugreport will be incomplete.

Brian Murray (brian-murray) wrote :

/usr/share/apport/package-hooks/source_gnome-power-manager.py:

def add_info(report):
    report['DevkitPower'] = command_output(['upower', '-d'])
    report['gnome-power-bugreport'] = command_output('/usr/share/gnome-power-manager/gnome-power-bugreport')

Charlie Kravetz (charlie-tca) wrote :

I am confirming this issue. Without lshal, gnome-power-manager bug reports will be less informative, since the information given from lshal will be missing.

Changed in gnome-power-manager (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Martin Pitt (pitti) on 2011-05-18
Changed in gnome-power-manager (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :
Changed in gnome-power-manager (Ubuntu):
status: In Progress → Fix Committed
tags: added: apport-hook
Changed in gnome-power-manager (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers