Screen brightness adjustment does not change at all on my Acer Aspire Timeline 5810TZ

Bug #660917 reported by Daniel Clem on 2010-10-15
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Low
Unassigned
Nominated for Maverick by babca
Nominated for Natty by babca

Bug Description

  I have tried both going into the system preferences and using the hardware adjustment ( function key + the left or right arrow key ) It used to work on the older Ubuntu 9.10 version. Please stop dropping the drivers for hardware. Especially for hardware that is barely older than 1 year. I am currently on 10.10 if that is not in the report. If Linux is to gain ground hardware support is crucial. And things like screen brightness is basic, much less printers, webcams, and other peripherals. I am not a advanced user at all. I am just a previous basic windows user trying to both switch to and support Linux.

   Thank you and God Bless,
       Daniel Clem

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xorg 1:7.5+6ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
DRM.card0.DisplayPort.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
DRM.card0.DisplayPort.2:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
DRM.card0.HDMI_Type_A.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768
 edid-base64: AP///////wAw5AICAAAAAAATAQOAIxN4Cihll1lUjiceUFQAAAABAQEBAQEBAQEBAQEBAQEBVh1WxlAAIDAwIDUAWcIQAAAZAAAAAAAAAAAAAAAAAAAAAAAAAAAA/gBMRyBEaXNwbGF5CiAgAAAA/ABMUDE1NldIMy1UTEExADk=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
Date: Thu Oct 14 22:34:57 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
MachineType: Acer Aspire 5810T
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-22-generic root=UUID=a5d2f3c8-1aee-4bae-a1e7-ae42e177b1d8 ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xorg
Symptom: display
dmi.bios.date: 04/06/2009
dmi.bios.vendor: INSYDE
dmi.bios.version: V1.06.
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Aspire 5810T
dmi.board.vendor: Acer
dmi.board.version: Base Board Version
dmi.chassis.type: 1
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvrV1.06.:bd04/06/2009:svnAcer:pnAspire5810T:pvrV1.06.:rvnAcer:rnAspire5810T:rvrBaseBoardVersion:cvnChassisManufacturer:ct1:cvrChassisVersion:
dmi.product.name: Aspire 5810T
dmi.product.version: V1.06.
dmi.sys.vendor: Acer
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: maverick
 architecture: i686
 kernel: 2.6.35-22-generic

Daniel Clem (clem11388) wrote :
Robert Roth (evfool) on 2010-10-15
affects: ubuntu → gnome-power-manager (Ubuntu)
babca (babca) wrote :

This is also happening to Acer Aspire Timeline 5810T and 4810T on Ubuntu 9.10, 10.04, and 10.10.

A similar bug post:
https://bugs.launchpad.net/ubuntu/+bug/573373

I tried "Step-by-step Troubleshooting" from https://wiki.ubuntu.com/Hotkeys/Troubleshooting
The Fn+Right/FN+Left (brightness down/up) keystrokes appears in Terminal (step 2 from link above) so the buttons work, system recognizes them.

*** But after pressing Fn+Right/FN+Left Ubuntu 10.10 completely freezes and I have to hard reset. ***

Pressing touchpad button stops operate touchpad, yes, but until next restart you cannot re-enable it. Same behavior is under Windows, this seems to be a BIOS bug.

babca (babca) wrote :

Silly, I can adjust the brightness, but can't use Ubuntu any more till next restart.
Ubuntu completely freezes right after pressing Fn+Right/FN+Left (brightness up/down).

Andreas Bulling (spam-hierher) wrote :

Same on my Acer Aspire 1810TZ running Kubuntu 11.04 (Natty).
Buttons are recognised and configured properly in system settings but screen brightness can't be changed.
Also, every time the screen is dimmed to save power the screen brightness reduces further
until it's completely dark.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the stable release - Oneiric Ocelot. It would help us greatly if you could test with it so we can work on getting it fixed. You can find out more about it at http://www.ubuntu.com/download . Thanks again and we appreciate your help.

Changed in gnome-power-manager (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Daniel Clem (clem11388) wrote :

I just installed Oneiric Ocelot and this issue is still present. NOTHING I do changes the brightness. (I don't know how find a conf file and change the brightness variable, because I shouldn't have to)

This has been the same ever since 10.04. Back in 9.10 I could change the brightness using the function keys, so you drop support for hardware that was less than a year old at the time? WHY???

Even installing Ubuntu Tweak on every release and trying to adjust the brightness in there for charching and battary modes. NOTHING changes it.

I am not a programmer or a tech kind of guy. I wish I could help find and fix the issue. But I only started using Ubuntu 9.10 cause I was googling for a way to fix an old machine that stopped recognizing the DVD drive (under Windows) . Installing Ubuntu fixed this issue completely and no matter what machine I put Ubuntu 9.10 on it worked beautifully with full support and everything just worked. So not only is Ubuntu's releases getting uglier (HATE purple) Its dropping support for hardware??

Launchpad Janitor (janitor) wrote :

[Expired for gnome-power-manager (Ubuntu) because there has been no activity for 60 days.]

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers