Network becomes sluggish when running on battery

Bug #657508 reported by apvieira on 2010-10-10
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Low
Unassigned

Bug Description

Since I upgraded from Lucid to Maverick beta (and now Maverick RC), when connecting to my home wireless network with my Dell Mini 9, network works just fine when running on AC power, but becomes extremely slow as soon as the netbook begins to run on battery. I suspect this is a driver problem (bcmwl?), as there is no option in Power Management relating to network performance. Things worked just fine with Lucid.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: bcmwl-kernel-source 5.60.48.36+bdcom-0ubuntu5
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
NonfreeKernelModules: wl
Architecture: i386
CheckboxSubmission: 91f4c43abae522e45c330c1107c8c514
CheckboxSystem: d00f84de8a555815fa1c4660280da308
Date: Sat Oct 9 21:30:16 2010
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: bcmwl
---
Architecture: i386
CheckboxSubmission: 91f4c43abae522e45c330c1107c8c514
CheckboxSystem: d00f84de8a555815fa1c4660280da308
DistroRelease: Ubuntu 10.10
GnomeSessionIdleInhibited: No
GnomeSessionInhibitors: None
GnomeSessionSuspendInhibited: No
MachineType: Dell Inc. Inspiron 910
NonfreeKernelModules: wl
Package: gnome-power-manager 2.32.0-0ubuntu1
PackageArchitecture: i386
ProcCmdLine: root=UUID=bd578485-0aeb-4ef8-9c21-dcf18556dc97 ro quiet splash intel_iommu=off
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Tags: ubuntu-une maverick
Uname: Linux 2.6.35-22-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 12/29/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A04
dmi.board.name: BR0F29
dmi.board.vendor: Dell Inc.
dmi.board.version: A04
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A04
dmi.modalias: dmi:bvnDellInc.:bvrA04:bd12/29/2008:svnDellInc.:pnInspiron910:pvrA04:rvnDellInc.:rnBR0F29:rvrA04:cvnDellInc.:ct8:cvrA04:
dmi.product.name: Inspiron 910
dmi.product.version: A04
dmi.sys.vendor: Dell Inc.

apvieira (andredepinhovieira) wrote :
Fabio Marconi (fabiomarconi) wrote :

Hello
Cano you run in a terminal
aport-collect -p gnome-power-manager 657508
Thanks
Fabio

affects: ubuntu → gnome-power-manager (Ubuntu)
Changed in gnome-power-manager (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Done.

Thank you!
Andre.

On Sun, Oct 10, 2010 at 7:05 AM, Fabio Marconi <email address hidden>wrote:

> Hello
> Cano you run in a terminal
> aport-collect -p gnome-power-manager 657508
> Thanks
> Fabio
>
> ** Package changed: ubuntu => gnome-power-manager (Ubuntu)
>
> ** Changed in: gnome-power-manager (Ubuntu)
> Status: New => Incomplete
>
> --
> Network becomes sluggish when running on battery
> https://bugs.launchpad.net/bugs/657508
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “gnome-power-manager” package in Ubuntu: Incomplete
>
> Bug description:
> Since I upgraded from Lucid to Maverick beta (and now Maverick RC), when
> connecting to my home wireless network with my Dell Mini 9, network works
> just fine when running on AC power, but becomes extremely slow as soon as
> the netbook begins to run on battery. I suspect this is a driver problem
> (bcmwl?), as there is no option in Power Management relating to network
> performance. Things worked just fine with Lucid.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: bcmwl-kernel-source 5.60.48.36+bdcom-0ubuntu5
> ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
> Uname: Linux 2.6.35-22-generic i686
> NonfreeKernelModules: wl
> Architecture: i386
> CheckboxSubmission: 91f4c43abae522e45c330c1107c8c514
> CheckboxSystem: d00f84de8a555815fa1c4660280da308
> Date: Sat Oct 9 21:30:16 2010
> ProcEnviron:
> LANG=en_US.utf8
> SHELL=/bin/bash
> SourcePackage: bcmwl
>
> To unsubscribe from this bug, go to:
>
> https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/657508/+subscribe
>

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → New
Joe (joesbunker) wrote :

Not sure if this is proper place to report, but I'm having a similar issue on Acer Aspire 5515; except when I unplug AC, I lose wireless network altogether. I get disconnected and can't get signed back in at all. If I go back on AC and restart, it's fine. I just updated today from 10.04 to 10.10, and had no problems before that at all. Advice?

Phillip Salzman (phill-sysctl) wrote :

I'm having the same issue with the Dell 1520.

Fabio Marconi (fabiomarconi) wrote :

@Phillip Salzman
please mark this bug a s affecting you too.

tags: added: dell-1520 dell-mini9
Jeff Dean (jdean10-satx) wrote :

Same problem on an ASUS Eee PC. I noticed that when I run iwconfig while on AC power my bit rate was 5.5 Mb/s, and on battery it would change to 54 Mb/s. When I go back to AC power, the rate drops back to 5.5 Mb/s. Perhaps the problem is that the driver is selecting a speed that is not compatible with the current signal to noise ratio when on battery power.

You might try running iwconfig while on AC power to note the bit rate, and when on battery power use iwconfig to set the rate correctly. This might fix the problem.

dorpm (dorpmueller) wrote :

There is a bug report concerning this issue: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/651008

Since it awaits fixing a workaround is to edit /usr/lib/pm-utils/power.d/wireless due to the desired behaviour.

Cheers,
Florian

Pedro Villavicencio (pedro) wrote :

Thanks for the report, it has been some time without any response or feedback in this bug report and we are wondering if this is still an issue for you with the latest release of Ubuntu the Natty Narwhal, May you please test with that version and comment back if you're still having or not the issue? Please have a look at http://www.ubuntu.com/download to know how to install that version. Thanks in advance and sorry for the late response.

Changed in gnome-power-manager (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Download full text (3.3 KiB)

Thank you for your e-mail. The problem seems to be solved in Natty!

Cheers,
Andre.

2011/7/8 Pedro Villavicencio <email address hidden>:
> Thanks for the report, it has been some time without any response or
> feedback in this bug report and we are wondering if this is still an
> issue for you with the latest release of Ubuntu the Natty Narwhal, May
> you please test with that version and comment back if you're still
> having or not the issue? Please have a look at
> http://www.ubuntu.com/download to know how to install that version.
> Thanks in advance and sorry for the late response.
>
> ** Changed in: gnome-power-manager (Ubuntu)
>   Importance: Undecided => Low
>
> ** Changed in: gnome-power-manager (Ubuntu)
>       Status: New => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/657508
>
> Title:
>  Network becomes sluggish when running on battery
>
> Status in “gnome-power-manager” package in Ubuntu:
>  Incomplete
>
> Bug description:
>  Since I upgraded from Lucid to Maverick beta (and now Maverick RC),
>  when connecting to my home wireless network with my Dell Mini 9,
>  network works just fine when running on AC power, but becomes
>  extremely slow as soon as the netbook begins to run on battery. I
>  suspect this is a driver problem (bcmwl?), as there is no option in
>  Power Management relating to network performance. Things worked just
>  fine with Lucid.
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 10.10
>  Package: bcmwl-kernel-source 5.60.48.36+bdcom-0ubuntu5
>  ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
>  Uname: Linux 2.6.35-22-generic i686
>  NonfreeKernelModules: wl
>  Architecture: i386
>  CheckboxSubmission: 91f4c43abae522e45c330c1107c8c514
>  CheckboxSystem: d00f84de8a555815fa1c4660280da308
>  Date: Sat Oct  9 21:30:16 2010
>  ProcEnviron:
>   LANG=en_US.utf8
>   SHELL=/bin/bash
>  SourcePackage: bcmwl
>  ---
>  Architecture: i386
>  CheckboxSubmission: 91f4c43abae522e45c330c1107c8c514
>  CheckboxSystem: d00f84de8a555815fa1c4660280da308
>  DistroRelease: Ubuntu 10.10
>  GnomeSessionIdleInhibited: No
>  GnomeSessionInhibitors: None
>  GnomeSessionSuspendInhibited: No
>  MachineType: Dell Inc. Inspiron 910
>  NonfreeKernelModules: wl
>  Package: gnome-power-manager 2.32.0-0ubuntu1
>  PackageArchitecture: i386
>  ProcCmdLine: root=UUID=bd578485-0aeb-4ef8-9c21-dcf18556dc97 ro quiet splash intel_iommu=off
>  ProcEnviron:
>   LANG=en_US.utf8
>   SHELL=/bin/bash
>  ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
>  Tags:  ubuntu-une maverick
>  Uname: Linux 2.6.35-22-generic i686
>  UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>  dmi.bios.date: 12/29/2008
>  dmi.bios.vendor: Dell Inc.
>  dmi.bios.version: A04
>  dmi.board.name: BR0F29
>  dmi.board.vendor: Dell Inc.
>  dmi.board.version: A04
>  dmi.chassis.type: 8
>  dmi.chassis.vendor: Dell Inc.
>  dmi.chassis.version: A04
>  dmi.modalias: dmi:bvnDellInc.:bvrA04:bd12/29/2008:svnDellInc.:pnInspiron910:pvrA04:rvnDellInc.:rnBR0F29:rvrA04:cvnDellInc.:ct8:cvrA04:
>  dmi.product.name: Inspiron 910
>  dmi.product.version: A04
>  dmi.sys.vendor: Dell Inc.
...

Read more...

Joe (joesbunker) wrote :

Thanks. The problem is also solved for me.

On Jul 8, 2011 8:15 PM, "apvieira" <email address hidden> wrote:

Thank you for your e-mail. The problem seems to be solved in Natty!

Cheers,
Andre.

2011/7/8 Pedro Villavicencio <email address hidden>:

> Thanks for the report, it has been some time without any response or >
feedback in this bug report...

Fabio Marconi (fabiomarconi) wrote :

Hello guys
Thanks for the replies.
I close this report as Fix released.
Thanks
Fabio

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers