Compaq Laptop Screen flickers with Ubuntu 10.04, when on battery power

Bug #648588 reported by Bishnu Mishra on 2010-09-27
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,
I have just installed Ubuntu 10.04 LTS 32 Bit on my Compaq Presario CQ40 616TU laptop. My screen flickers (Horizontal Line flicks) in few second interval when running on battery power or when I lower screen brightness. This is really annoying and hard to work.

Here are the details:
1. Issue occurs when running on battery power or low screen brightness and is reduced(with a little flickering at bottom of the screen) or almost gone when connected to AC power adapter.

2. The screen also flickers while booting. However it is maximum on battery power.
3. I use Compaq CQ40 616-TU laptop with Intel Graphics Media Accelerator 4500 graphics.
4. I tried Mandrive One Spring 10 and also experienced the same problem.
5. My graphics is "Intel Graphics Media Accelerator 4500M".
The bellow link is the specification for my laptop.
http://h10025.www1.hp.com/ewfrf/wc/document?docname=c01869756&tmp_task=prodinfoCategory&lc=en&dlc=en&cc=in&lang=en&product=4033201

I was using windows& before but never notice this problem.

I changed the Grub file and added i915.powersaver=0 but it did not work. However if I use the laptop with high brightness the problem is reduced (with a little flickering at bottom of the screen) or gone.

I think it is a bug in linux kernel.

Thanks
Bishnu
---
Architecture: i386
DistroRelease: Ubuntu 10.04
GnomeSessionIdleInhibited: No
GnomeSessionInhibitors: None
GnomeSessionSuspendInhibited: No
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
MachineType: Hewlett-Packard Compaq Presario CQ40 Notebook PC
NonfreeKernelModules: wl
Package: gnome-power-manager 2.30.0-0ubuntu1
PackageArchitecture: i386
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-25-generic root=UUID=ed1d8294-4017-4abf-8489-b49233812fa5 ro i915.powersave=1 quiet splash
ProcEnviron:
 LANG=en_IN
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-25.44-generic 2.6.32.21+drm33.7
Tags: lucid
Uname: Linux 2.6.32-25-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 05/18/2010
dmi.bios.vendor: Insyde
dmi.bios.version: F.66
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3607
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 99.C3
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnInsyde:bvrF.66:bd05/18/2010:svnHewlett-Packard:pnCompaqPresarioCQ40NotebookPC:pvr0395120000000D10000000000:rvnHewlett-Packard:rn3607:rvr99.C3:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: Compaq Presario CQ40 Notebook PC
dmi.product.version: 0395120000000D10000000000
dmi.sys.vendor: Hewlett-Packard

Fabio Marconi (fabiomarconi) wrote :

Hello
Can you please run in a terminal
apport-collect -p gnome-power-manager 648588
Thanks
Fabio

affects: ubuntu → gnome-power-manager (Ubuntu)
Changed in gnome-power-manager (Ubuntu):
status: New → Incomplete
tags: added: lucid
Changed in gnome-power-manager (Ubuntu):
status: Incomplete → New
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Hi,
I did apport-collect -p gnome-power-manager 648588 and the information is now available.

Thanks
Bishnu

Fabio Marconi (fabiomarconi) wrote :

Thanks for the report
Fabio

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → New

Is there any progress on this defect ?

Fabio Marconi (fabiomarconi) wrote :

Now this is reported to developers.
Fabio

pwds (pwds-mail) wrote :

On my Asus K50IJ Laptop the same problem :)

Changed in gnome-power-manager (Ubuntu):
status: New → Confirmed

Actually this was due my LCD problem. I replaced the LCD and the issue is gone. There is nothing to do with the software.
I have changed the bug status to invalid.

Thanks
Bishnu

Changed in gnome-power-manager (Ubuntu):
status: Confirmed → Fix Released
status: Fix Released → Invalid
gabriel (gabriel-leske-n) wrote :

same problem at HP nc6220

Changed in gnome-power-manager (Ubuntu):
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers