In systray, battery state stay as "estimating..."

Bug #633552 reported by ®om on 2010-09-08
56
This bug affects 10 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Undecided
Karl Lattimer

Bug Description

Binary package hint: gnome-power-manager

In systray, when I click on the battery icon, it stays as "estimating..." instead of "25%", "40%"…
When I click on the menu item, it opens statistic, and in "History" I can check the battery state, so it "knows" the current battery state. It should display it in the menu item instead of "estimating…".

It worked correctly in Ubuntu 10.04.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gnome-power-manager 2.31.91-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Wed Sep 8 23:07:16 2010
EcryptfsInUse: Yes
GnomeSessionIdleInhibited: Yes
GnomeSessionInhibitors: 1: AppId = Lecteur vidéo Totem, Flags = 8, Reason = Lecture d'un film
GnomeSessionSuspendInhibited: No
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta amd64 (20100901.1)
Lsusb:
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 002: ID 147e:2016 Upek Biometric Touchchip/Touchstrip Fingerprint Sensor
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 004: ID 5986:0200 Acer, Inc OrbiCam
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: clevo M7X0SU
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-19-generic root=UUID=10b7834d-ce1a-4e53-9dd2-5d0702792ad5 ro quiet splash nomodeset video=uvesafb:mode_option=1680x1050-24,mtrr=3,scroll=ywrap
ProcEnviron:
 LANG=fr_FR.utf8
 SHELL=/bin/bash
SourcePackage: gnome-power-manager
dmi.bios.date: 11/07/0892
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: 6.00
dmi.board.asset.tag: 1234567890
dmi.board.name: M7X0SU
dmi.board.vendor: clevo
dmi.board.version: Bottom
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: SiS
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvr6.00:bd11/07/0892:svnclevo:pnM7X0SU:pvrRev.A1:rvnclevo:rnM7X0SU:rvrBottom:cvnSiS:ct1:cvrN/A:
dmi.product.name: M7X0SU
dmi.product.version: Rev. A1
dmi.sys.vendor: clevo

®om (rom1v) wrote :
Maxim Levitsky (maximlevitsky) wrote :

I confirm this.
Moreover when I plug the battery, it shows battery information twice.

Also this happens while AC is plugged only.
Without AC it shows time left (although in annoying hr:min format)

Karl Lattimer (karl-qdh) on 2010-09-24
Changed in gnome-power-manager (Ubuntu):
assignee: nobody → Karl Lattimer (karl-qdh)
Karl Lattimer (karl-qdh) wrote :

I tried matching the heuristics up with this properly, there are conditions where there's no time remaining and only a percentage, gnome power manager is supposed to take data of the percentage over time and estimate the time remaining, so in theory the time remaining would eventually be updated, hence why it says estimating.

The problem seems to be that some laptops don't make the estimation easy somewhere deeper inside of the code.

I'll try and improve the situation somehow

®om (rom1v) wrote :

I would prefer to have the percentage instead of "estimated time", at least as an option.

Karl Lattimer (karl-qdh) wrote :

I'm considering this as a safe default, the problem is that for most people it will be estimating during that period. This makes me think that there's something not quite right internally in gpm or that certain batteries are just a little unpredictable.

Switching it to the percentage is a quick fix, I'll propose a new patch when I get a moment to work on it.

Karl Lattimer (karl-qdh) wrote :

i've attached an updated patch to https://bugs.launchpad.net/ayatana-ubuntu/+bug/619816

this should fix the problem, some discussion still necessary around that patch

Nathaniel Wilson (dubrict) wrote :

I've been having this problem since switching to maverick back when it was in alpha. I've noticed a lot of people posting this bug, and as far as I've seen it's been HP laptops. I have a HP G61-511WM laptop, and when I bring up the power graphs, there is no data on discharge rate, time to full, or time to empty. However, every graph under "statistics" has data.

Malhar Trivedi (trivedimalhar) wrote :

I have same problem. I have HP dv6516tx(dv6000 series), Intel 1.5 Core 2 duo, 2GB RAM.
It worked perfectly in previous Ubuntu(9.10).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers