gnome-power-manager reports BadAtom, crashes on launch

Bug #618967 reported by Nick Melnick on 2010-08-16
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-power-manager

Running latest updated gnome-power-manager (2.31.6-0ubuntu1) on maverick, my laptop doesn't show battery info in the power management configuration, doesn't sleep correctly, and has reduced runtime. Turns out gnome-power-management isn't running, and will not launch manually. Attempting to launch on command line:

Gdk-ERROR **: The program 'gnome-power-manager' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAtom (invalid Atom parameter)'.
  (Details: serial 161 error_code 5 request_code 150 minor_code 15)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...
Trace/breakpoint trap (core dumped)

gnome-power-manager will not start on boot, from Alt-F2, or from command line. Not sure if this has anything to do with the fact that I'm stuck using the radeon driver instead of fglrx due to the Xorg upgrade.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gnome-power-manager 2.31.6-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-15.21-generic 2.6.35.1
Uname: Linux 2.6.35-15-generic x86_64
Architecture: amd64
Date: Mon Aug 16 18:44:50 2010
GnomeSessionIdleInhibited: No
GnomeSessionInhibitors: None
GnomeSessionSuspendInhibited: No
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
MachineType: LENOVO 3508CTO
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-15-generic root=UUID=5229bbc6-5e63-492e-b3ae-4ae2876ec0b0 ro crashkernel=384M-2G:64M,2G-:128M quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-power-manager
dmi.bios.date: 07/21/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6XET44WW (1.27 )
dmi.board.name: 3508CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6XET44WW(1.27):bd07/21/2010:svnLENOVO:pn3508CTO:pvrThinkPadX100e:rvnLENOVO:rn3508CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 3508CTO
dmi.product.version: ThinkPad X100e
dmi.sys.vendor: LENOVO

Nick Melnick (nmelnick) wrote :
M0ses (m0ses) wrote :

exactly same problem here (also x100e)

PeterPall (peterpall) wrote :

This might be related to Bug #615812 and Bug #614248 even if the other problems seem to occour later than at launchtime.

Changed in gnome-power-manager (Ubuntu):
status: New → Confirmed
PeterPall (peterpall) wrote :

On my system the last update to gnome-power-manager seems to have fixed the crashes. Can anybody confirm this?

PeterPall (peterpall) on 2011-01-24
Changed in gnome-power-manager (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers