gnome-power-manager panel menu has redundant information (remaining time twice) when on battery

Bug #616443 reported by Björn Schließmann on 2010-08-11
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-power-manager

Since gnome-power-manager 2.31.1-0ubuntu1, the panel menu shows a redundant line of "remaining time" information, only when on battery. Menus are the same whether using notification area applet or indicator applet. Examples for menus:

on AC:
- Laptop battery 35 minutes until charged (80%)
- Preferences

on Battery:
- 5 hours 6 minutes remaining
- Laptop battery 5 hours 5 minutes remaining (80%)
- Preferences

Also note: On battery, first and second lines practically always differ (often several minutes).

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gnome-power-manager 2.31.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-14.20-generic 2.6.35
Uname: Linux 2.6.35-14-generic i686
Architecture: i386
Date: Wed Aug 11 19:44:48 2010
GnomeSessionIdleInhibited: No
GnomeSessionInhibitors: None
GnomeSessionSuspendInhibited: No
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: IBM 2373A91
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-14-generic root=UUID=4d015652-6ae1-4e87-acc6-e8c43a344ba5 ro
ProcEnviron:
 LANGUAGE=en_GB:en_US:en
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: gnome-power-manager
dmi.bios.date: 06/18/2007
dmi.bios.vendor: IBM
dmi.bios.version: 1RETDRWW (3.23 )
dmi.board.name: 2373A91
dmi.board.vendor: IBM
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: IBM
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnIBM:bvr1RETDRWW(3.23):bd06/18/2007:svnIBM:pn2373A91:pvrThinkPadT41:rvnIBM:rn2373A91:rvrNotAvailable:cvnIBM:ct10:cvrNotAvailable:
dmi.product.name: 2373A91
dmi.product.version: ThinkPad T41
dmi.sys.vendor: IBM

Micheal Harker (mh0) wrote :
Changed in gnome-power-manager (Ubuntu):
status: New → Confirmed
Charlie Kravetz (charlie-tca) wrote :

 Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in gnome-power-manager (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged

Apparently fixed in version 2.31.6-0ubuntu1. Marking "Fix released".

Changed in gnome-power-manager (Ubuntu):
status: Triaged → Fix Released
Maxim Levitsky (maximlevitsky) wrote :

Not fixed.
A fully updated maveric as of today.
g-pm: 2.31.92-0ubunntu1

Menu shows the exact battery status twice, and when I remove the battery one line disappers
while other not, so that it still shows I use battery.

Changed in gnome-power-manager (Ubuntu):
status: Fix Released → New
John (fiostvuser1) wrote :

I have the same problem within Ubuntu 11.04 Beta 2. I am using Asus Eee netbook and the battery information is displaying twice.

Maxim Levitsky (maximlevitsky) wrote :

Any update, whole version passed, this is still broken?

Maxim Levitsky (maximlevitsky) wrote :

Ok, I got the message.
Unless you fix it yourself, nobody will, although for developer its much easier to fix because he knows the code.
Maybe I should have reported that upstream.
Anyway, here the patch.

Please spare me from doing the administrative work such as correcting something in changelog, etc.

It tuns out that libupower-glib adds the battery to an array, but gpm adds it there too.

tags: added: patch
Maxim Levitsky (maximlevitsky) wrote :

So I provide a patch, and you mark that as a duplicate? Nice isn't it?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers