[Maverick Alpha] asks for root permission to do: gnome-power-backlight-helper --get-max-brightness

Bug #615047 reported by dummy9010 on 2010-08-08
40
This bug affects 14 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Low
Chris Coulson

Bug Description

Binary package hint: policykit-1

After booting Ubuntu an authentication window pops up for /usr/sbin/gnome-power-backlight-helper --get-max-brightness.

This hasn't happened before. The "hardware" is a Virtualbox machine.

Part of "ps axu"-output:
----------------------------------------------------------------------------------------------------

root 857 0.0 0.5 19828 2988 ? Sl 17:50 0:00 /usr/lib/gdm/gdm-session-worker
root 858 0.0 0.3 6768 2028 ? Ss 17:50 0:00 /usr/sbin/cupsd -C /etc/cups/cupsd.conf
user 903 0.2 1.3 26848 6624 ? Ssl 17:50 0:00 gnome-session
user 1009 0.0 0.0 3368 200 ? Ss 17:50 0:00 /usr/bin/ssh-agent /usr/bin/dbus-launch --exit-with-session gnome-session
user 1014 0.0 0.1 3456 560 ? S 17:50 0:00 /usr/bin/dbus-launch --exit-with-session gnome-session
user 1028 0.2 0.2 3268 1264 ? Ss 17:50 0:00 /bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
user 1045 0.2 0.8 9252 4168 ? S 17:50 0:00 /usr/lib/libgconf2-4/gconfd-2
user 1066 0.0 1.2 20116 6228 ? S 17:50 0:00 gnome-power-manager
user 1072 0.0 0.4 24960 2280 ? Sl 17:50 0:00 /usr/bin/gnome-keyring-daemon --start --components=secrets
user 1074 0.2 1.8 90460 9232 ? Ss 17:50 0:00 /usr/lib/gnome-settings-daemon/gnome-settings-daemon
root 1090 0.0 0.6 8392 3164 ? S 17:50 0:00 /usr/lib/upower/upowerd
root 1092 0.0 0.1 1856 552 tty1 Ss+ 17:50 0:00 /sbin/getty -8 38400 tty1
user 1094 0.0 0.4 7376 2208 ? S 17:50 0:00 /usr/lib/gvfs/gvfsd
user 1120 0.0 0.3 30612 2024 ? Ssl 17:50 0:00 /usr/lib/gvfs//gvfs-fuse-daemon /home/user/.gvfs
user 1121 0.1 1.6 30524 8588 ? S 17:51 0:00 /usr/lib/evolution/2.30/evolution-alarm-notify
user 1124 0.1 2.2 91212 11296 ? S 17:51 0:00 nm-applet --sm-disable
user 1125 0.8 2.0 21644 10368 ? S 17:51 0:01 metacity --replace
user 1143 0.5 0.9 95456 4628 ? S<sl 17:51 0:00 /usr/bin/pulseaudio --start --log-target=syslog
rtkit 1147 0.0 0.2 22980 1172 ? SNl 17:51 0:00 /usr/lib/rtkit/rtkit-daemon
user 1153 0.8 3.5 91044 18276 ? S 17:51 0:01 nautilus
user 1155 0.7 2.8 61764 14340 ? S 17:51 0:01 gnome-panel
user 1158 0.5 2.2 65232 11368 ? Sl 17:51 0:00 /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
user 1162 0.0 1.5 20336 7640 ? S 17:51 0:00 bluetooth-applet
root 1163 0.2 0.7 8644 3952 ? S 17:51 0:00 /usr/lib/policykit-1/polkitd
root 1229 0.0 0.4 5856 2348 ? S 17:51 0:00 pkexec /usr/sbin/gnome-power-backlight-helper --get-max-brightness
user 1234 0.0 0.5 7748 2892 ? S 17:51 0:00 /usr/lib/gvfs/gvfsd-trash --spawner :1.9 /org/gtk/gvfs/exec_spaw/0
user 1235 0.0 0.6 12548 3076 ? S 17:51 0:00 /usr/lib/pulseaudio/pulse/gconf-helper
user 1241 0.0 0.6 42572 3156 ? Ssl 17:51 0:00 /usr/lib/bonobo-activation/bonobo-activation-server --ac-activate --ior-out
user 1249 0.0 0.7 33336 3608 ? S 17:51 0:00 /usr/lib/gvfs/gvfs-gdu-volume-monitor
root 1250 0.0 0.2 5804 1368 ? S 17:51 0:00 /usr/lib/policykit-1/polkit-agent-helper-1 user cookie0
root 1253 0.0 0.6 16264 3140 ? Sl 17:51 0:00 /usr/lib/udisks/udisks-daemon
user 1261 0.4 2.5 60932 12956 ? S 17:51 0:00 /usr/lib/gnome-panel/wnck-applet --oaf-activate-iid=OAFIID:GNOME_Wncklet_Fa
user 1263 0.1 2.0 59108 10676 ? S 17:51 0:00 /usr/lib/gnome-applets/trashapplet --oaf-activate-iid=OAFIID:GNOME_Panel_Tr
root 1265 0.0 0.1 5584 728 ? S 17:51 0:00 udisks-daemon: polling /dev/sr0
user 1267 1.9 3.7 33844 18952 ? Sl 17:51 0:02 /usr/bin/python /usr/lib/ubuntuone-client/ubuntuone-syncdaemon
user 1269 0.0 0.4 17960 2232 ? Sl 17:51 0:00 /usr/lib/gvfs/gvfs-afc-volume-monitor
user 1275 0.0 0.5 18712 2544 ? Ss 17:51 0:00 gnome-screensaver
user 1278 0.0 0.4 8148 2108 ? S 17:51 0:00 /usr/lib/gvfs/gvfs-gphoto2-volume-monitor
user 1288 0.1 2.4 68496 12520 ? S 17:51 0:00 /usr/lib/indicator-applet/indicator-applet --oaf-activate-iid=OAFIID:GNOME_
user 1289 0.1 1.7 24032 8724 ? S 17:51 0:00 /usr/lib/gnome-panel/notification-area-applet --oaf-activate-iid=OAFIID:GNO
user 1290 0.1 2.6 32620 13300 ? S 17:51 0:00 /usr/lib/gnome-panel/clock-applet --oaf-activate-iid=OAFIID:GNOME_ClockAppl
user 1291 0.2 2.5 68612 12976 ? S 17:51 0:00 /usr/lib/indicator-applet/indicator-applet-session --oaf-activate-iid=OAFII
user 1310 0.0 0.4 7404 2384 ? S 17:51 0:00 /usr/lib/gvfs/gvfsd-burn --spawner :1.9 /org/gtk/gvfs/exec_spaw/1
user 1321 0.0 1.3 19772 6920 ? S 17:51 0:00 /usr/lib/gnome-disk-utility/gdu-notification-daemon
user 1326 0.0 0.3 7176 1916 ? S 17:51 0:00 /usr/lib/gvfs/gvfsd-metadata
user 1328 0.0 0.8 19860 4540 ? S 17:51 0:00 /usr/lib/indicator-me/indicator-me-service
user 1330 0.0 0.8 18844 4568 ? S 17:51 0:00 /usr/lib/indicator-session/indicator-session-service
user 1333 0.0 0.7 24488 3924 ? S 17:51 0:00 /usr/lib/indicator-application/indicator-application-service
user 1335 0.0 0.7 18332 4016 ? S 17:51 0:00 /usr/lib/indicator-messages/indicator-messages-service
user 1337 0.0 0.9 87012 4728 ? S 17:51 0:00 /usr/lib/indicator-sound/indicator-sound-service
user 1368 0.3 2.9 31696 15144 ? S 17:51 0:00 python /usr/share/system-config-printer/applet.py
user 1370 0.4 2.2 56828 11540 ? S 17:52 0:00 update-notifier
root 1374 0.5 2.3 17188 11748 ? S 17:52 0:00 /usr/bin/python /usr/sbin/aptd
user 1383 3.1 2.5 66572 12892 ? Sl 17:53 0:00 gnome-terminal
user 1384 0.0 0.1 2056 700 ? S 17:53 0:00 gnome-pty-helper
user 1385 1.8 0.6 6720 3352 pts/0 Ss 17:53 0:00 bash
user 1405 0.0 0.2 4588 1076 pts/0 R+ 17:53 0:00 ps axu

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: policykit-1 0.96-2
ProcVersionSignature: Ubuntu 2.6.35-14.20-generic 2.6.35
Uname: Linux 2.6.35-14-generic i686
Architecture: i386
Date: Sun Aug 8 17:54:46 2010
ExecutablePath: /usr/lib/policykit-1/polkitd
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100731)
ProcEnviron:

SourcePackage: policykit-1

dummy9010 (aperto1973) wrote :
dazza5000 (darran-kelinske) wrote :

This just started happening thursday/friday with a new round of updates on maverick. Happens upon login. I experience this on non-virtualized install on a studio xps 13

Changed in policykit-1 (Ubuntu):
status: New → Confirmed
dazza5000 (darran-kelinske) wrote :

one more comment - im running amd64

Chris Orlando (chrsorlando) wrote :

This bug affects me as well. Just started happening upon login with a round of updates. Also running amd64.

Gil Seward (sewardg) wrote :

Me too, Running 32-bit Alpha 3 on AMD64 notebook. Slightly different message.
"Authentication is required to run '/
usr/bin/gnome-power-backlight-
helper' as super user"

Goh Lip (gohlip) wrote :

Lubuntu Maverick alpha 3 exhibits same problem, I renamed "gnome-power-backlight-helper" to "gnome-power-backlight-helper_somethingelse" and problem disappeared.

affects: policykit-1 (Ubuntu) → gnome-power-manager (Ubuntu)
Changed in gnome-power-manager (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in gnome-power-manager (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-power-manager - 2.31.90-0ubuntu4

---------------
gnome-power-manager (2.31.90-0ubuntu4) maverick; urgency=low

  * Fix LP: #615047 - asks for root permission to do
    gnome-power-backlight-helper --get-max-brightness. Clean the distributed
    policy file from the source tree before building so we install a policy
    file with the correct pkexec path
    - add debian/patches/15_distclean.patch
    - update debian/patches/series
 -- Chris Coulson <email address hidden> Tue, 24 Aug 2010 10:59:30 +0100

Changed in gnome-power-manager (Ubuntu):
status: Triaged → Fix Released
John Mylchreest (jmylchreest) wrote :

Since this change yesterday (and the corresponding fix in #614039 which I also suffered), I'm now being prompted constantly (repetitively) when either clicking on the brightness applet, or changing brightness via the applet. This continues until I kill gnome-power-manager.

Should polkit be caching the authentication request?

meisterplanlos (meisterplanlos) wrote :

It's working again without any "raise privileges dialogs". At least for me. Thanks guys :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers