Laptop goes to sleep right after plugging/unplugging power cord

Bug #601709 reported by Dane Mutters on 2010-07-04
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-power-manager

I'm using a Dell Inspiron 700m laptop. Whenever I plug in the power cord, and whenever I unplug the power cord, the computer immediately goes to sleep. (I'm pretty sure it's sleep, and not hibernate.) I tried debugging the problem by monitoring the output of the following commands, but nothing appeared to change during the plug/unplug event.

upower --monitor=detail > upower.log

dbus-monitor --session "type='signal',interface='org.freedesktop.PowerManagement'" > dbus-monitor.log

These commands were recommended for debugging gnome-power-manager on the g-p-m web site.

Here is the output of those commands:

upower:
Monitoring activity from the power daemon. Press Ctrl+C to cancel.
[14:41:20.290] daemon changed:
[14:41:29.566] daemon changed:
[14:41:52.508] daemon changed:

dbus-monitor:
signal sender=org.freedesktop.DBus -> dest=:1.57 serial=2 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=NameAcquired
   string ":1.57"

It may also be worth noting that in order to get this version of Ubuntu (10.04) to work at all on this laptop, it was necessary to create the file, /etc/modprobe.d/i915-kms.conf, and insert the following text:

options i915 modeset=1

Without that workaround, the laptop boots up to a blank, unresponsive screen. Ubuntu 8.04 had none of the above problems.

Thanks for looking at this bug! You folks are great!

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gnome-power-manager 2.30.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-23.37-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-23-generic i686
Architecture: i386
Date: Sun Jul 4 15:41:22 2010
GnomeSessionIdleInhibited: Unknown
GnomeSessionInhibitors: Failed to acquire
GnomeSessionSuspendInhibited: Unknown
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100427.1)
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. Inspiron 700m
PccardctlIdent:
 Socket 0:
   no product info available
 Socket 1:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
 Socket 1:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-23-generic root=UUID=96a3f5d5-408d-4a32-ae85-4b799e2ec056 ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-power-manager
dmi.bios.date: 02/01/05
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: A02
dmi.board.name: Inspiron 700m
dmi.board.vendor: DELL SYSTEM
dmi.board.version: Rev.A
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrA02:bd02/01/05:svnDellInc.:pnInspiron700m:pvr-1:rvnDELLSYSTEM:rnInspiron700m:rvrRev.A:cvnDellInc.:ct8:cvrN/A:
dmi.product.name: Inspiron 700m
dmi.product.version: -1
dmi.sys.vendor: Dell Inc.

Dane Mutters (dmutters) wrote :
Dane Mutters (dmutters) wrote :

While looking for a fix, I ran into this thread that seems to confirm the problem in Ubuntu 9.10:

http://ubuntuforums.org/showthread.php?t=1339572&page=2

urbandk (evans33) wrote :

The problem seems linked to the lid close behavior. Unplugging the laptop or plugging it in seems to trigger a lid close. I've changed the lid close behavior to blank screen in the power manager, so now when I unplug or plug in, the screen goes blank, but I can brink it back before it locks up. I also have a 700m, and this issue has always been a problem with every Ubuntu release...

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. A new version of Gnome Power Manager is available on Maverick and we are wondering if this bug is still an issue for you with that version? Could you please test and comment back? Thanks in advance.

Changed in gnome-power-manager (Ubuntu):
status: New → Incomplete
Dane Mutters (dmutters) wrote :

Thanks for the continued interest in this bug. The computer that I'm writing about is my wife's school laptop; as such, I can't reload a new operating system on it during the semester (which ends in late December). Do you think it would be sufficient/helpful for me to test it using a live CD or USB drive? It took some tweaking to get Ubuntu to load on this laptop (after Karmic), including some kernel/boot options to make the video not lock up on boot (black screen). I'm pretty sure I can get it to boot and run a test, but I'd first like to know if this method of testing would be helpful. Thanks!

Launchpad Janitor (janitor) wrote :

[Expired for gnome-power-manager (Ubuntu) because there has been no activity for 60 days.]

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → Expired
darkonc (samuel-bcgreen) wrote :

I have a Toshiba Satellite A70 with the same problem -- running 11.04 - Natty.

Dane Mutters (dmutters) wrote :

Sorry for the long delay. After school got out for the semester, my wife got fed-up with it before I could try 11.04, and insisted on re-installing Windows XP. (ugh...) Hopefully darconc will be able to help you with diagnostics. Good luck!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers