gnome-power-manager hibernates instead of suspending on idle

Bug #576698 reported by Michael Reiger on 2010-05-06
This bug affects 11 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)

Bug Description

Binary package hint: gnome-power-manager

On my system, 10.04 UNE upgraded from 9.10, putting the machine to sleep on idle does not work as expected:

Instead of being suspended, the machine is put into hibernation. On 9.10 (and 9.04 before it) the machine was suspended, as I expected. I do prefer the suspend to the hibernation too.
Manually suspending the machine works.

This is a Dell Inspiron 1011 (Mini 10v).

The behaviour is both there with my regular user that went through the upgrade (old config files) and with a newly created test user (fresh config from a template, I assume).

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gnome-power-manager 2.30.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic
Uname: Linux 2.6.32-22-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Fri May 7 00:47:54 2010
ExecutablePath: /usr/bin/gnome-power-manager
GnomeSessionIdleInhibited: No
GnomeSessionInhibitors: None
GnomeSessionSuspendInhibited: No
MachineType: Dell Inc. Inspiron 1011
ProcCmdLine: root=UUID=7baaac9c-870e-4ea6-bfbc-83d788eb57f4 ro quiet splash
 PATH=(custom, user)
SourcePackage: gnome-power-manager 07/06/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A05 CN0Y53
dmi.board.vendor: Dell Inc.
dmi.board.version: A05
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A05
dmi.modalias: dmi:bvnDellInc.:bvrA05:bd07/06/2009:svnDellInc.:pnInspiron1011:pvrA05:rvnDellInc.:rnCN0Y53:rvrA05:cvnDellInc.:ct8:cvrA05: Inspiron 1011
dmi.product.version: A05
dmi.sys.vendor: Dell Inc.

Michael Reiger (mighyflea) wrote :
mks99 (launchpad-schoenhaber) wrote :

Same for me. Fresh install of Lucid netbook on an Asus Eee PC 1005PE.

Changed in gnome-power-manager (Ubuntu):
status: New → Confirmed
James Adney (jfadney) wrote :

I had this same problem but I fixed it by changing this key in the configuration editor from "hibernate" to "suspend"


Michael Reiger (mighyflea) wrote :

That worked for me too. :-)

I would call this a workaround, not a fix, though:

The setting is not available from the Power Management Preferences, making it hard to find.

In my opinion, either the setting should be made availalbe in these preferences, or the default reverted to suspend. "Put the computer to sleep" sounds much more like suspend than hibernate, so I think people would expect that; also it was the default before Lucid.
At least put it in the release notes?

gdi2k (gdi2k) wrote :

Thanks for the workaround, this was annoying me as my laptop takes forever to struggle out of hibernation!

I agree that the language is ambiguous. In the rest of the dialog box, suspend or hibernate are used explicitly - "sleep" is more of a Windows word I think. I don't mind which terminology is used, but it should be consistent throughout.

It would also be nice if it were possible to choose whether to suspend or hibernate, as well as the period of idleness.

But in any case, even if the box is left unmodified, it should suspend by default, not hibernate.

Chris Lasher (chris.lasher) wrote :

Thanks James! That helped a lot.

David D. (daviddarts) wrote :

Thanks James! This solved the issue with my Asus UL30VT running Lucid 64-bit (kernel with the Nvidia card activated.

MrMacman2u (mrmacman2u-gmail) wrote :

Confirming this same bug on Maverick 10.10 on a T42 Thinkpad, I'm not sure if/what other information might be needed, but I will add it on demand.

Manual suspend works correctly.

This is a very frustrating bug as hibernate is incredibly slow on this system and despite the GPM setting to suspend when idle, it hibernates.

MrMacman2u (mrmacman2u-gmail) wrote :

Just a note here, I hadn't noticed previously, but when on AC power the system properly suspends to RAM when the idle timer has expired. On battery power the laptop suspends to disk (hibernates) after the time is up.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers