critically low battery dialog "cancel" button is meaningless

Bug #533652 reported by Alex Launi on 2010-03-07
108
This bug affects 19 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Chris Coulson
gnome-power
Unknown
Low
gnome-power-manager (Ubuntu)
Medium
Chris Coulson

Bug Description

Binary package hint: gnome-power-manager

Ubuntu 10.04 Lucid Lynx, fully updated as of tonight
gnome-power-manager 2.29.91-0ubuntu5

The dialog (attached) has an "ok" and a "cancel" button. This is a case where
there's no need for an option, and the presentation of one is confusing.
Whether I hit cancel or ok, my battery is still critically low, and my laptop
is still going to hibernate momentarily.

Alex Launi (alexlauni) on 2010-03-07
tags: added: usability
Alex Launi (alexlauni) wrote :
Chris Coulson (chrisccoulson) wrote :

Hmmm, I thought I'd reverted this upstream change already

Changed in gnome-power-manager (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Undecided → Medium
status: New → Triaged
Chris Coulson (chrisccoulson) wrote :

This is Ubuntu specific by the way. notify-osd shows this notification as a fallback alert because it uses a non-expiring message

Alex Launi (alexlauni) wrote :

So this should be retarged to notify-osd then? Do any non-expiring messages require an ok and a cancel?

Chris Coulson (chrisccoulson) wrote :

Non-expiring notifications are not supported in notify-osd, due to the design of the notification bubble (you would never be able to dismiss a non-expiring notification). That's by design though and not a bug in notify-osd. Closing the notify-osd task

affects: notify-osd → null
Changed in null:
status: New → Invalid

If I understand correctly notify-osd is issuing the fallback. If
notify-osd's fallback mechanism presents a usability hurdle, then there's a
bug to be fixed in notify-osd, albeit a low priority one.

Changed in gnome-power-manager (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-power-manager - 2.29.91-0ubuntu6

---------------
gnome-power-manager (2.29.91-0ubuntu6) lucid; urgency=low

  [ Chris Coulson ]
  * Updated patch tag information
  * debian/local/source_gnome-power-manager.py
    - Fetch inhibitors from gnome-session and add them to the submitted bug
      report (under the 'GnomeSessionInhibitors' key). Also provide an overall
      summary indicating if the session has been inhibited from going idle
      (the 'GnomeSessionIdleInhibited' key) or if the session has been
      inhibited from suspending (the 'GnomeSessionSuspendInhibited' key).
      This is copied from the gnome-screensaver apport hook, and can be
      useful when debugging issues where a users display doesn't blank or
      the machine doesn't sleep.
  * debian/patches/14-critical-message-timeout.patch:
    - Update to revert another upstream change to use a non-expiring
      notification. This prevents it being displayed as a fallback alert
      box with notify-osd (LP: #533652)

  [ Jan Arne Petersen ]
  * debian/patches/12-add-appindicators.patch:
    - Fix icon theme include path (LP: #529911)

  [ Scott Howard ]
  * Adds hardware information to apport hook (LP: #522972)
 -- Chris Coulson <email address hidden> Fri, 12 Mar 2010 09:47:41 +0000

Changed in gnome-power-manager (Ubuntu):
status: Fix Committed → Fix Released
zzz (oldman-deactivatedaccount) wrote :

Is this truly fixed? I just saw the same problem in gnome-power-manager 2.30.0-0ubuntu1 on my laptop.

zzz (oldman-deactivatedaccount) wrote :

(running lucid with all updates applied)

fain182 (fain182) wrote :

i have gnome-power-manager version 2.30.0-0ubuntu1 and the problem still remain.

Changed in gnome-power-manager (Ubuntu):
status: Fix Released → Confirmed
Sense Egbert Hofstede (sense) wrote :

Accepting this as a papercut as this is a pretty disturbing abuse of dialogues. :) Go away!

I'm not touching the other tasks as I'm not sure whether this should be fixed in Notify OSD or in GNOME Power Manager.

Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Triaged
Chris Coulson (chrisccoulson) wrote :

This should be fixed in gnome-power-manager

Changed in gnome-power-manager (Ubuntu):
status: Confirmed → Triaged
Sense Egbert Hofstede (sense) wrote :

Chris Coulson: What version should contain the fix?

Matthew Paul Thomas (mpt) wrote :

I think Chris meant "Someone should fix this in gnome-power-manager".

Chris Coulson (chrisccoulson) wrote :

Yes, that's what I meant. That someone will probably be me, but at the moment I am completely tied up with the Firefox 3.6.4 rollout, so I don't have time to look at anything else.

Somebody else is more than welcome to step up in the meantime :)

Paul Sladen (sladen) wrote :

So, just to confirm; there's two separate issues here:

  1. a _bug_, in notify-osd, in issuing drawing a dialogue with [Cancel] and [OK] buttons, when there should just be a single [Dismiss] button
  2. gnome-power-manager, in requesting a non-expiring notification.

Which are exasperated by two further issues:

  a. g-p-m willing resends the (non-expiring) notification, thereby DoS'ing the user's desktop. (bug #579245)
  b. g-p-m will issue the OMG CIRTICAL!! notification even when the battery is at 100% (bug #516023)

Matthew Paul Thomas (mpt) wrote :

The reason I specified that Notify OSD fallback alerts <https://wiki.ubuntu.com/NotifyOSD#alert> should have at least two buttons, instead of at least one, is to cater for applications that distinguish between no action (closing the bubble in notification-daemon == "Cancel" in Notify OSD) and the default action (clicking the bubble's main area in notification-daemon == "OK" button or equivalent in Notify OSD).

In the notification design guidelines we provided mockups of what gnome-power-manager should do instead. <https://wiki.ubuntu.com/NotificationDesignGuidelines#morphing>

Bilal Akhtar (bilalakhtar) wrote :

Please mark assigned bugs as 'In Progress'.

Changed in gnome-power-manager (Ubuntu):
status: Triaged → In Progress
Changed in hundredpapercuts:
status: Triaged → In Progress
assignee: nobody → Chris Coulson (chrisccoulson)
Chris Coulson (chrisccoulson) wrote :

I'll change it to in progress when I'm actually working on it thanks

Changed in gnome-power-manager (Ubuntu):
status: In Progress → Triaged
Changed in hundredpapercuts:
status: In Progress → Confirmed
Vish (vish) on 2010-08-12
Changed in hundredpapercuts:
status: Confirmed → Triaged
Changed in gnome-power:
importance: Unknown → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-power-manager - 2.32.0-0ubuntu2

---------------
gnome-power-manager (2.32.0-0ubuntu2) natty; urgency=low

  * Fix LP: #533652 - re-add debian/patches/14-critical-message-timeout.patch,
    as this wasn't committed upstream
 -- Chris Coulson <email address hidden> Tue, 02 Nov 2010 15:17:33 +0000

Changed in gnome-power-manager (Ubuntu):
status: Triaged → Fix Released
Changed in hundredpapercuts:
status: Triaged → Fix Released
Vish (vish) on 2010-11-27
Changed in hundredpapercuts:
milestone: none → nt7-potpourri

This one is happening in oneiric.

gnome-power-manager-3.2.0-0ubuntu1 btw

Curtis Hovey (sinzui) on 2011-11-11
no longer affects: null
Matthew Paul Thomas (mpt) wrote :

This bug regressed as bug 883857.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.