gnome-power-manager doesn't show icon as non-root user

Bug #532005 reported by Robert B on 2010-03-04
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Low
komputes

Bug Description

Binary package hint: gnome-power-manager

The battery icon only seems to show if I do

$ sudo gnome-power-manager

That is, if gnome-power-manager is run as root, the battery icon in the notification area in the taskbar shows. If I run as a normal user, it doesn't.

I assume that there is some permission issue.

I did an strace and it looks like a normal user gets stuck at

 poll([{fd=5, events=POLLIN}, {fd=3, events=POLLIN}, {fd=11, events=POLLIN|POLLPRI}, {fd=13, events=POLLIN|POLLPRI}, {fd=14, events=POLLIN|POLLPRI}, {fd=15, events=POLLIN|POLLPRI}, {fd=8, events=POLLIN}, {fd=7, events=POLLIN}], 8, 9995 <unfinished ...>

whereas the root user gets past this and starts opening up files in /usr/share/gnome-power-manager/icons . I tried looking at the various associated files and sockets. Some are /tmp/orbit-XXXX and others are dbus-related, but I can't tell which is the sticking point.

$ lsb_release -rd
Description: Ubuntu lucid (development branch)
Release: 10.04
$ apt-cache policy gnome-power-manager
gnome-power-manager:
  Installed: 2.29.91-0ubuntu3
  Candidate: 2.29.91-0ubuntu3
  Version table:
 *** 2.29.91-0ubuntu3 0
        100 /var/lib/dpkg/status

ProblemType: Bug
Architecture: i386
Date: Thu Mar 4 08:01:28 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100213)
Package: gnome-power-manager 2.29.91-0ubuntu3
ProcEnviron:
 PATH=(custom, no user)
 LANG=C
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-15.22-generic-pae
SourcePackage: gnome-power-manager
Uname: Linux 2.6.32-15-generic-pae i686

Robert B (robertbub) wrote :
Robert B (robertbub) wrote :

BTW, this may be related to bug 529911, but I'm not sure.

Michael Milligan (milli) wrote :

I'm seeing similar behavior where the icon appears and disappears in the Notification area. Attached is a full strace from running it for less than a minute and disconnecting and reconnecting power. Each time there is an event or a poll, the icon disappears and reappears often expanding the size taken up in the notification area. Sometimes the icon disappears for a long time, but over an extended period, this causes extra space to be used in the notification area entire the entire panel is taken up by this "empty" space. I'm using the Human-Clearlooks theme.

gnome-power-manager: 2.29.91-0ubuntu5
upower: 0.9.1-1
dbus: 1.2.16-2ubuntu3

@Michael Milligan: I have the same issue, it's there sometimes but sometimes not, even though I have configured it to be always showing. Doesn't sound like the reporters bug though, I opened up a new bug, #541085.

Chris Coulson (chrisccoulson) wrote :

Do people experiencing this have the indicator-applet on their panel? Does this happen in the guest session too? Could you please run "killall gnome-power-manager && gnome-power-manager --verbose 2>&1 | tee gpm.log" and attach the log file to this bug report. Thanks

Changed in gnome-power-manager (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Christian (tschanzc) wrote :

For me it seems to work in a way. The problem is, the icon shows up but disappears randomly and then reappears again.

Chris Coulson (chrisccoulson) wrote :

Your issue is bug 529052

krzlew (krz-lewandowski) wrote :

The same thing happend to me. Battery icon disappeared. I had it earlier, but now it is gone and restart doesn't help. When running `sudo gnome-power-manager ` it works correctly. I attach requested log file.

krzlew (krz-lewandowski) wrote :

Yesterday when I did 'sudo gnome-power-manager' I got icon, but now it shows when I'm on battery, but it disappears on AC. I attach another gdm.log file. I started it on AC and then I unplugged AC (I marked it in log with text: "HERE I UNPLUGGED AC"). And somewhere later I plugged in AC again.

krzlew (krz-lewandowski) wrote :

I found solution to my problem. I'm using vertical panel and there was a bug in indicator-applet which was showing only one icon (at least on my panel only one icon fit) and all other icons were outside the panel.

ahmedito (ahmedito) wrote :

Same problem

$ lsb_release -rd
Description: Ubuntu 10.04 LTS
Release: 10.04

$ apt-cache policy gnome-power-manager
gnome-power-manager:
  Installed: 2.30.0-0ubuntu1
  Candidate: 2.30.0-0ubuntu1
  Version table:
 *** 2.30.0-0ubuntu1 0
        500 cdrom://Ubuntu 10.04 _Lucid Lynx_ - Release Candidate i386 (20100419.1)/ lucid/main Packages
        500 http://ie.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
     2.24.0-0ubuntu8 0
        500 http://nl.archive.ubuntu.com/ubuntu/ intrepid/main Packages

captwiggum (captwiggum) wrote :

Posted is the output of:
killall gnome-power-manager && gnome-power-manager --verbose 2>&1 | tee gpm.log

Launchpad Janitor (janitor) wrote :

[Expired for gnome-power-manager (Ubuntu) because there has been no activity for 60 days.]

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → Expired
komputes (komputes) wrote :

I am reopening this bug as Robert B's issue was confirmed by krzlew's gpm.log as was requested by Chris Coulson.

Robert B, krzlew: Could you confirm that this is still an issue?

Chris, does this have enough information to be assigned? Please let me know if you require anything additional.

Changed in gnome-power-manager (Ubuntu):
status: Expired → Confirmed
komputes (komputes) on 2011-07-05
Changed in gnome-power-manager (Ubuntu):
assignee: nobody → David Bensimon (davidbensimon)
komputes (komputes) wrote :

Marked invalid as we have not received a response and 10.04 is reaching EOL in April 2013.

Changed in gnome-power-manager (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers