g-p-m brightness not applied anymore after rebooting

Bug #503577 reported by mikewhatever on 2010-01-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-power-manager

Release: Karmic i686
Package version: gnome-power-manager 2.28.1-0ubuntu1

I am on a Dell mini 10, running a clean install of Karmic i686, fully updated.
After startup, the screen brightness is at 100%, no matter what it is set to under Gnome-power-manager.

The brightness buttons didn't work at all after the installation, so that there was no way to change the screen brightness. Adding 'apci_brightness=vendor' to boot options made the brightness buttons work, but the settings are still ignored. In other words, the screen is always at 100% brightness after startup, although it's set to be at 60%

ProblemType: Bug
Architecture: i386
Date: Tue Jan 5 23:43:15 2010
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: wl
Package: gnome-power-manager 2.28.1-0ubuntu1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-16.53-generic
SourcePackage: gnome-power-manager
Uname: Linux 2.6.31-16-generic i686

mikewhatever (mikewhatever) wrote :
description: updated
Paul Dufresne (paulduf) wrote :

Well, in http://ubuntuforums.org/showpost.php?p=8612908&postcount=828 suggest that: "adding nolapic allows to use dell smbios for changing backlight (brightness) in grub."

Although I have not used gnome-power-manager brightness feature, I believe it is not a bug.
If I read: http://library.gnome.org/users/gnome-power-manager/stable/applets-general.html.en I understand this is a temporary brightness level.

So, I'll mark this bug as invalid. Please feel free to reopen if you think I misunderstood.

Changed in gnome-power-manager (Ubuntu):
status: New → Invalid
Paul Dufresne (paulduf) on 2010-01-15
summary: - Gnome power manager ignores screen settings
+ g-p-m brightness not applied anymore after rebooting
Paul Dufresne (paulduf) wrote :

Could it be:
 acpi_backlight= [HW,ACPI]
   acpi_backlight=vendor
   acpi_backlight=video
   If set to vendor, prefer vendor specific driver
   (e.g. thinkpad_acpi, sony_acpi, etc.) instead
   of the ACPI video.ko driver.
rather than acpi_brightness ?
which I don't find in: http://www.kernel.org/doc/Documentation/kernel-parameters.txt

Also, is it the brightness control you were using from http://library.gnome.org/users/gnome-power-manager/stable/applets-general.html.en ?

Changed in gnome-power-manager (Ubuntu):
status: Invalid → Incomplete
mikewhatever (mikewhatever) wrote :

Could you elaborate a bit more on why it isn't a bug. I think it definitely is, and I don't see how gnome power manager documentation is relevant. This, so called, 'not a bug' made this netbook barely usable without sunglasses on.
Just to repeat, brightness keys were non-functional, and brightness was always at 100%, permanently, and without a way of changing.
I have tried adding noapic and nolapic, but they did nothing whatsoever in my case, yet acpi_brightness did as mentioned.
Lastly, I don't use any brightness applets. The settings are applied with gnome power manager found under System->Preferences->Power Management.

mikewhatever (mikewhatever) wrote :

I am going to write out a workaround for this bug, mostly for my own amusement, and possibly for a stray soul wanting to use Karmic on a Dell mini 10, and searching here in desperation. Apparently, Ubuntu devs have to much on their hands to look bugs, let alone fixing them. It's a little sad, but understandable, besides, the bug is probably not that important, after all, who doesn't have sunglasses these days. Obviously, wearing sunglasses would be a workaround in and by itself, but that's too obvious, and I wouldn't bother suggesting it, had it not come to mind right now. You know, stray thought. Anyway, before this turns into a novel, here comes the workaround.

Step one.
You have to add the following boot option: acpi_backlight=vendor. More info on how to do it can be found on ubuntuforums.org, specifically -> http://ubuntuforums.org/showthread.php?t=1313390&page=3&highlight=brightness.

Step two.
Now, you can adjust the default screen brightness, still ignored after step one, by adding the following line to /etc/rc.local:

echo 2 > /sys/class/backlight/compal-laptop/brightness

2 is my personal preference, but you can adjust it using any value from 0 to 7, where 7 = 100% brightness.

Paul Dufresne (paulduf) on 2010-02-22
Changed in gnome-power-manager (Ubuntu):
status: Incomplete → Confirmed
Chris Coulson (chrisccoulson) wrote :

The real issue here is that when pressing the brightness keys, the brightness value in gconf is not updated so the new state is never saved between sessions. That should be fixed properly rather than advising users to try unsupported workarounds

Changed in gnome-power-manager (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Paul Dufresne (paulduf) wrote :

"The real issue here is that when pressing the brightness keys, the brightness value in gconf is not updated"
I think you are oversimplifying this bug.
Well you do have much more experience than me but for me, there seems to be 3 sub-bugs in this bug:

1) Normal drivers are unable to update the brightness of the LCD, that seems to explain why step two of the workaround does not work until step one is done. Also bug description suggest that there is no way to change brightness even with mouse in gnome-power-manager, until the acpi_backlight=vendor is passed to the kernel.

2) Brightness keys are not recognized with normal drivers (I suspect scancodes could be different with vendor drivers than normal ones, but this is just my hypothesis). Still, it need vendor drivers to work, as explain in initial description. But it is also possible that vendor drivers do direct brightness adjustments directly, that would explain why gconf never see the changes.

3) Gnome-power-manager settings (set by mouse) is not saved, but is temporarily value. According to documentation, that would be normal, but documentation seems to fail to explain how to set a saved 'normal' value for the brightness. I don't know.

Searching 'brightness' for bugs result in lots of bugs, that seems to confirm that this is not only happenning on Dell mini 10. (Well, I did about one month ago, but I expect things have not changed much since).

Paul Dufresne (paulduf) wrote :

I am trying to summarise some info take from other bugs here.

In bug #230421, we learn that the following changed in the acpi-support package in Ubuntu 9.10:
  * Drop events/video_brightness{down,up}, video_brightness{up,down}.sh: at
    least some platforms that use these ACPI sequences are seeing them
    correctly translated to input events, so those users will see duplicate
    events unless we drop them. LP: #178860.

Mike, can you please run the 'acpi_listen' command, and report here any output produced when you press the brightness keys?

This bug also suggest to look at the https://wiki.ubuntu.com/Hotkeys/Troubleshooting page.

Bug #385723 seems the general missing backlight control for Linux kernel.

Bug #320874, is very interesting, and was fixed in kernel 2.6.29:
http://bugzilla.kernel.org/show_bug.cgi?id=12249 (reading fast, could be BIOS related).

Bug #388216 (because KMS)
What I call sub-bug 3, (brightness not saved) is in bug #35223, and they did fill a bug directly to gnome project:
https://bugzilla.gnome.org/show_bug.cgi?id=335673

Bug #131650, brightness keys not working on Vaio SZ-140p.
Sony Vaio have LOTS of bug reports...

Bug #223954 (brightness controls still has major bugs) (mostly about going back to 100% when opening lid), asked to do:
Thanks for your report but we need more information about your bug. Please, run gnome-power-bugreport.sh and gconftool -a /apps/gnome-power-manager/backlight.

Bug #406515, for Lenovo, but showing how to determine keycodes, also link to Lnux kernel bugs.

Ok, I'll stop there for now, just to show that there is many kernel issues going on around this.

Victor Vargas (kamus) wrote :

Please could somebody check if this behaviour is still occurring in latest release included in Ubuntu Maverick? Thanks in advance

Changed in gnome-power-manager (Ubuntu):
status: Confirmed → Incomplete
mikewhatever (mikewhatever) wrote :

Hi Kamus, just tested Maverick on the very same Dell mini 10 using live usb, and, unfortunately, it's still the same. When booting without the 'acpi_backlight=vendor' option, the brightness keys don't work, the default brightness is set to 100% and there is no apparent way to change it. Running on AC and battery doesn't change screen brightness as it should according to the settings in Gnome Power Manager (read from gconf).
As mentioned earlier, adding 'acpi_backlight=vendor' as a boot option fixes it.
I'd be happy to do more testing if needed.
Regards.

mikewhatever (mikewhatever) wrote :

In 12.04, the brightness is set to 50% by default, and is adjustable with the brightness keys.

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.