Gnome-power-manager ignores its settings

Bug #460565 reported by ullix on 2009-10-25
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Low
Unassigned

Bug Description

... or it is not working at all.

I have a desktop based on Intel D945GCLF2 on AC power (no battery) and set the gnome-power-manager v2.28.1 preferences to :Put comuter to sleep in '10 min', and put display to sleep 'never'.

What happens reproducibly is that the display is blackend at 5min (backlight remains on) and the computer is suspended in 15min.

If it's not gnome-power-manager doing it, what other software is responsible?

Christos Sintoris (sintoris) wrote :

Same issue, on an HP Elitebook 2730p (specs: http://h10010.www1.hp.com/wwpc/us/en/sm/WF06a/321957-321957-64295-3740645-3955549-3784558.html with Core2 Duo LV Processor SL9400). Whatever the settings set on the Power Management, the display is black after 5 min, regardless if running with battery or on AC. Running Ubuntu 9.10 RC.

Christos Sintoris (sintoris) wrote :

Nevermind, it was the blank screen screensaver.

Changed in ubuntu:
status: New → Invalid
ullix (ullix) wrote :

if it is invalid in your case doesn't imply it is invalid in my case. First I don't know where to set any blank screen screensaver, and second why would it suspend my computer at 15 min, when I had asked to suspend it in 10min?

Is there even a third program fiddling with screen and shutdown?

Changed in ubuntu:
status: Invalid → New
affects: ubuntu → gnome-power-manager (Ubuntu)
Bene18 (bene-riehm) wrote :

"Nevermind, it was the blank screen screensaver."

I've experienced the same: my laptop display turned off after 1 minute idle status. I also removed the screen saver that brought up a black screen and now it is working correctly.

Raymundo Vásquez Ruiz (zoet13) wrote :

I had the same issue.
Running sudo gnome-power-preferences I've seen that the configuration assigned at this level was being listened by the application instead of the user's settings. Change the configuration here and ya está.
Now it seems that the problem is with user preferences

Pedro Villavicencio (pedro) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please open a terminal and execute: apport-collect 460565 ? It will attach the necessary information to this report. Also you can submit more information for it by looking to https://wiki.ubuntu.com/DebuggingGNOMEPowerManager , Thanks in advance.

Changed in gnome-power-manager (Ubuntu):
status: New → Incomplete
importance: Undecided → Low

Architecture: i386
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: gnome-power-manager 2.28.1-0ubuntu1.3
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 LANG=de_DE.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-18.55-generic
Uname: Linux 2.6.31-18-generic i686
UserGroups: adm admin cdrom dialout dip lpadmin mythtv netdev plugdev sambashare

ullix (ullix) wrote : DevkitPower.txt
Changed in gnome-power-manager (Ubuntu):
status: Incomplete → New
tags: added: apport-collected

I've experienced similar behavior since the installation of a fresh 10.04. The behavior I experience is when I set both "Put computer to sleep", and "Put display to sleep" to "Never", and upon a new login, the display will sleep after 10 minutes.

However, if I click "Make Default" the behavior is not seen until a new login.

maxim (maximn) wrote :

I opened a new bug as recommended by apport-collect, and because mine is just a little different.

https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/609810

papukaija (papukaija) on 2010-09-11
summary: - [ubuntu karmic] gnome-power-manager ignores its settings
+ Gnome-power-manager ignores its settings
tags: added: karmic
papukaija (papukaija) wrote :

This bug report is being marked as confirmed because is is affecting more than one person. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status . Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in gnome-power-manager (Ubuntu):
status: New → Confirmed
Fabio Marconi (fabiomarconi) wrote :

display is blacked at 5min -->screensaver start with default settings
comuter to sleep in '10 min' --> after last activity (screesaver start)
total= 15 min.
Please adjust screesaver settings to solve this issue.
i close this report as is not a bug
For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in gnome-power-manager (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers