Hardware button no longer suspends laptop when locked

Bug #428119 reported by Andrew Aylett on 2009-09-11
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Medium
Unassigned
Karmic
Medium
Unassigned

Bug Description

Binary package hint: gnome-power-manager

I have the power button on my laptop set to suspend the laptop. When the laptop is open and unlocked, it works fine. When the screensaver is active or the lid closed (I have lock on lid-close, but see #428115) the button doesn't appear to do anything. This works in Jaunty and worked in Karmic up until the last week or so.

Expected behaviour is that triggering the hardware button should always suspend the computer. It's quite handy for when I've shut the lid because I paused my work and then want to suspend to move elsewhere.

ProblemType: Bug
Architecture: i386
Date: Fri Sep 11 22:19:14 2009
DistroRelease: Ubuntu 9.10
Package: gnome-power-manager 2.27.92-0ubuntu1
ProcEnviron:
 LANGUAGE=en_GB.utf8
 LC_COLLATE=C
 PATH=(custom, user)
 LANG=en_GB.UTF8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.31-generic
SourcePackage: gnome-power-manager
Uname: Linux 2.6.31-10-generic i686

Andrew Aylett (andrew-aylett) wrote :
tags: added: regression-potential
Changed in gnome-power-manager (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
jabastien (jabastien) wrote :

MSI U100 netbook with 9.10-netbook-remix

when power button activate GUI shutdown selection. Only shutdown works. selection Hibernate or suspend does not do anything. Also, when closing lid system does not suspend nor does it hibernate even if actions are selected in gnome-power-manage.

Jim Padel (jim-1-6regulars) wrote :

Also using MSI U100. Power features worked fine under UNR 9.04 Suspend/HIbernate does not work under UNR 9.10

Steve Beattie (sbeattie) on 2009-12-02
tags: added: karmic regression-release
removed: regression-potential
tags: added: lucid
Andrew Aylett (andrew-aylett) wrote :

This is still an issue in Maverick.

tags: added: maverick
JC Hulce (soaringsky) wrote :

Is this still an issue in the latest versions of Ubuntu?

I am closing the Karmic bugtask because Karmic is EOL. The main bug is still open.

Changed in gnome-power-manager (Ubuntu):
status: Triaged → Incomplete
Changed in gnome-power-manager (Ubuntu Karmic):
status: Triaged → Invalid
Andrew Aylett (andrew-aylett) wrote :

Yes, it's still affecting me in natty.

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → Confirmed
Ryan Press (ryan-nryiuoo) wrote :

With quantal I still have problems, like jabastien above. Pressing the power button pops up a dialog where only the shutdown button works. The suspend button does nothing. When I pick suspend from the menu in the top right corner the computer will enter suspend mode. Ideally I could set the power button to immediately suspend but there doesn't seem to be an option for this.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers