g-p-m does not turn off the display after specified time-out

Bug #415589 reported by anagor on 2009-08-18
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-power-manager

Hi all,
I'm on a fully updated (for 2009-08-18) Karmic x86_64,
gnome-power-manager does not turn the monitor off after the specified 10 minutes period.
However if I kill g-p-m using
$ killall gnome-power-manager
and then start the g-p-m again it works fine, so I'm unable to produce the output of: gnome-power-manager --verbose,
since it's acts just fine. Another thing is that, if I don't login at all and leave the system in the GDM greeting screen, the display does turns off as expected.
So, to summarize, the g-p-m does not turn off the display only after login and only if it is not restarted after login.

Architecture: amd64
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: gnome-power-manager 2.27.5-0ubuntu2
PackageArchitecture: amd64
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-6.25-generic
Uname: Linux 2.6.31-6-generic x86_64
UserGroups: adm admin audio cdrom dialout fuse lpadmin netdev plugdev pulse pulse-access sambashare vboxusers video

anagor (anagor) wrote :
anagor (anagor) wrote :
anagor (anagor) wrote :
anagor (anagor) wrote :
tags: added: apport-collected
anagor (anagor) wrote :

Just a small update,
If the g-p-m autosarted, then it doesn't work. But if I remove it from autostart in gnome-session-properties and start it manually after the login, it works just fine on the first run.

anagor (anagor) wrote :

Yet another update,
Not starting gnome-power-manager at all after the login, still the display will turn off after specified timeout, just not completely, i.e. the backlight is active, but this is another bug, which is already reported.
So the devkit-power-daemon probably works ok, it's just the fact that auto starting g-p-m somehow prevents it from working.

P.S. I feel like I talk to myself here :)

Vish (vish) on 2009-08-20
Changed in gnome-power-manager (Ubuntu):
status: New → Confirmed
tags: added: regression-potential
Aliaksei Sapach (dreamsonic) wrote :

This bug is still reproducible with gnome-power-manager 2.27.92-0ubuntu1.

Robert Mahoney (mahoneyr) wrote :

KDE turns screen off as expected; gnome-power-manager 2.27.92 does not on same machine.

Alex Murray (alexmurray) wrote :

I've uploaded a patched version of xorg-server to my PPA which should fix this:

https://launchpad.net/~alexmurray/+archive/ppa

anagor (anagor) wrote :

The latest upgrade of xorg 2:1.6.3-1ubuntu7 with the patch from upstream fixed this issue for me.
I will mark this bug as a duplicate of #413168 , which seems to aggregate all duplicates.

Changed in gnome-power-manager (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers