Brightness notification does not work

Bug #392533 reported by moomex on 2009-06-26
48
This bug affects 10 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Wishlist
Mirco Müller

Bug Description

Binary package hint: notify-osd

Distribution: Ubuntu 9.10 amd64

moomex@moomex-PC:~$ apt-cache policy notify-osd
notify-osd:
  Installed: 0.9.14.1-0ubuntu1

When changing the display’s backlight’s brightness using keyboard hotkeys, the change in brightness should be shown in a confirmation bubble using notify-osd. Instead, notify-osd does not show anything when changing the brightness of the screen. Everything works fine (volume, network, IM, etc ) except for brightness.

The laptop I'm using is HP Pavilion dv2000 with nvidia graphic card. I'm not sure if this bug is under notify-osd or gnome-power-manager; however, changing the brightness using keyboard hotkeys does work but without notification bubble.

P.S. Same behaviour is also observed in Ubuntu Jaunty.

Pedro Villavicencio (pedro) wrote :

gpm is the responsible to send the notification to notify-osd in order to display the bubble if it doesn't do it, it's a gpm issue.

affects: notify-osd (Ubuntu) → gnome-power-manager (Ubuntu)
Scott Howard (showard314) wrote :

Thanks for the report, we are currently undergoing some large notify-osd changes for GPM in Karmic. You can follow the status here:

bug 399492
bug 406396
bug 344886

Thank you for testing Karmic, and if you could, follow the above reports to see how they are progressing.

Changed in gnome-power-manager (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Yunkwan (chanyunkwan0217) wrote :

I have a very similar issue affect me too.
The notify-osd works fine (volume, network, IM, etc ) except for brightness~
When I am changing the brightness the original gnome notification show up instead.
I didn't have this problem when I was testing on Karmic Alpha3 and Jaunty.

Could you test the newest version of GPM (2.27.5-0ubuntu3)? The notify
OSD work has been completed. On the liveCD you can choose to upgrade
gnome-power-manager through synaptic in the Administration menu.

On Sat, Aug 15, 2009 at 3:25 PM, Yunkwan<email address hidden> wrote:
> I have a very similar issue affect me too.
> The notify-osd works fine (volume, network, IM, etc ) except for brightness~
> When I am changing the brightness the original gnome notification show up instead.
> I didn't have this problem when I was testing on Karmic Alpha3 and Jaunty.
>
> --
> Brightness notification does not work
> https://bugs.launchpad.net/bugs/392533
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “gnome-power-manager” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: notify-osd
>
> Distribution: Ubuntu 9.10 amd64
>
> moomex@moomex-PC:~$ apt-cache policy notify-osd
> notify-osd:
>  Installed: 0.9.14.1-0ubuntu1
>
> When changing the display’s backlight’s brightness using keyboard hotkeys, the change in brightness should be shown in a confirmation bubble using notify-osd. Instead, notify-osd does not show anything when changing the brightness of the screen. Everything works fine (volume, network, IM, etc ) except for brightness.
>
> The laptop I'm using is HP Pavilion dv2000 with nvidia graphic card. I'm  not sure if this bug is under notify-osd or gnome-power-manager; however, changing the brightness using keyboard hotkeys does work but without notification bubble.
>
> P.S. Same behaviour is also observed in Ubuntu Jaunty.
>

moomex (moomex) wrote :

the brightness notification bubbles still doesn't work after upgrading GPM (2.27.5-0ubuntu3)

Mirco Müller (macslow) wrote :

As of gnome-power-manager 2.28.0-0ubuntu1 screen-brightness changes via the special keys on my keyboard, do correctly trigger notifications displayed as bubbles rendered by notify-osd.

Changed in gnome-power-manager (Ubuntu):
milestone: none → ubuntu-9.10
status: Triaged → Fix Released
assignee: nobody → Mirco Müller (macslow)
moomex (moomex) wrote :

This bug still exist in my karmic beta install, that is changing the brightness using keyboard hotkeys does not trigger notifications displayed as bubbles rendered by notify-osd though i have gnome-power-manager 2.28.0-0ubuntu1 :(

Mirco Müller (macslow) wrote :

moomex, what kind of hardware and brand (laptop, desktop, netbook) do you have? It could be that your system does short-circuit something in lower parts of the library stack, not exposing brightness changes to HAL, which gnome-power-manager uses to obtain info about any changes you make via these special keys. Thus causing no notification-bubbles to show up, because they are simply not issued by gnome-power-manager.

moomex (moomex) wrote :

The laptop I'm using is HP Pavilion dv2196ea with nvidia graphic card GeForce Go 7200.

btw, what causes the short-circuit in the lower part of the library stack ?

Same problem here with Acer Aspire One 120L (first series) and Intel Graphics.
I'm using 9.10, just upgraded from 9.04 (where the problem originated, I think sometime in august),

gigaforce1111 (gigaforce1111) wrote :

Same here on Dell 1555 Intel Graphics.
Also upgraded from 9.04 to 9.10.

Changed in gnome-power-manager (Ubuntu):
status: Fix Released → Confirmed
John Swing (john-swing) wrote :

This problem reappeared with Raring.

mehmet.nural (zxcq14) wrote :

same on ubuntu 12.10 with ati radeon 7470m
i can change brightness fn keys but no notification appears

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers