[karmic] display doesn't go to DPMS sleep

Bug #385633 reported by Asif Youssuff on 2009-06-10
102
This bug affects 15 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-power-manager

Acer Aspire 4530, display does not go to DPMS sleep after the selected timeout in gnome-power-preferences.

The display seems to "blank" instead of actually sleeping. On AC power, have not tried on battery yet.

Saw bug #203513 which seems similar, but I'm running a development ubuntu, so I figured it'd be better to separate it.

This bug did not appear in Jaunty as far as I remember; I'll try a LiveCD to check.

ProblemType: Bug
Architecture: i386
Date: Wed Jun 10 12:48:23 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: gnome-power-manager 2.27.1-0ubuntu2
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.30-8.9-generic
SourcePackage: gnome-power-manager
Uname: Linux 2.6.30-8-generic i686

Asif Youssuff (yoasif) wrote :
Asif Youssuff (yoasif) wrote :

gnome-power-manager --no-daemon --verbose gives me no output, and I was unable to find gnome-power-bugreport.sh on my system.

Asif Youssuff (yoasif) wrote :

xset dpms force off

works with no issues, as well, so the display is capable of going to sleep.

anagor (anagor) wrote :

me too :)

using updated karmic development 64bit on MSI EX600 laptop with binary nvidia drivers.

$xset dpms force off - works as intended, the Xorg log shows that the DPMS module was loaded succesfully.

yet the screen never goes to sleep, only blank. And if the screensaver activated, then, after a set period of time the screen saver activated, after a few more minutes the screen goes blank (but not turns off), and after a few more minutes screen saver reappears and stays on.

anagor (anagor) wrote :

Well, I think that this bug can be closed since for a few days now the monitor does go to DPMS sleep.

Scott Howard (showard314) wrote :

This bug report is being closed due to your last comment regarding this being fixed. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in gnome-power-manager (Ubuntu):
status: New → Invalid
Asif Youssuff (yoasif) wrote :

Scott, this is clearly not an invalid bug, please *triple check* before you mark bugs invalid. It's in the link that you copied and pasted into this report.

Anyway, this bug is NOT resolved for me (and I am the original reporter) -- I updated a few minutes ago, but am not using the .31 kernel because the nvidia kernel module does not load yet.

I will be sure to update further on this issue once I am running the new kernel.

Changed in gnome-power-manager (Ubuntu):
status: Invalid → Confirmed
Scott Howard (showard314) wrote :

Sorry about that, thanks for reopening this bug and testing this in Karmic.

You probably have already seen:
http://projects.gnome.org/gnome-power-manager/bugs.html
and
https://wiki.ubuntu.com/DebuggingGNOMEPowerManager

Those links have some helpful tips for debugging GPM. In your case, specifically, the following command may be helpful:
cat /var/log/message | grep gnome-power-manager

(since verbose gnome-power-manager doesn't give an output).

The complete path for gnome-power-bugreport is:
/usr/share/gnome-power-manager/gnome-power-bugreport

Which gives similar information as to the:
http://launchpadlibrarian.net/27738076/DevkitPower.txt attachment

Thanks for trying with the new kernel. If your Karmic distribution is from an upgrade, it might be worth using a liveCD (or follow the instructions at https://wiki.ubuntu.com/DebuggingGNOMEPowerManager#Getting%20GConf%20values) to make sure there is no configuration errors.

James Schriver (dashua) wrote :

Karmic 64 2.6.31-1-generic here with a patched Nvidia driver (185.18.14) and the DKMS issus still exists here. I will continue testing to see if the issue mitigates itself.

some other bugs with similar symptoms:
bug #231397
bug #193192

in addition to the reporter's comment about bug #203513

from bug #231397 (this may or may not help):
Tony Houghton (h-realh: 0) wrote on 2008-10-14: (permalink)

I've discovered that this behaviour is deliberate and
gnome-power-manager (gpm) relies on gnome-screensaver (gss) to
implement the blanking and DPMS instead of X. It behaves correctly
when gnome-screensaver is running.

It would have been nice to be able to use gpm without gss, because for
most people there's no point in a screensaver that does anything
except save power. However, gss does provide a way of suspending
blanking for video players etc:- gnome-screensaver-command --poke -
which is better than temporarily changing the X settings, so it's got
its uses after all.

Although I think it might be preferable for gpm to handle DPMS for gss
instead of the other way round, I don't mind if this bug is closed
without anything being changed.

Asif Youssuff (yoasif) wrote :

This is still an issue for me with both the latest Karmic kernel and the mainline kernel (2.6.31-020631rc3-generic).

Luís Silva (luis) wrote :

This is happening to me too...

$ cat /var/log/messages | grep gnome-power-manager
Jul 31 00:10:33 luis-eeepc kernel: [ 2908.840445] gnome-power-man[6114]: segfault at 8 ip 0806de43 sp bfd933f0 error 4 in gnome-power-manager (deleted)[8048000+50000]

$ uname -a
Linux luis-eeepc 2.6.31-4-generic #23-Ubuntu SMP Mon Jul 27 18:39:51 UTC 2009 i686 GNU/Linux

$ cat /etc/issue
Ubuntu karmic (development branch) \n \l

This box is updated to the latest pakages.

anagor (anagor) wrote :

Since this bug reappeared on my system, this may help;
running gnome-power-manager --verbose
shows this line during the initialization:

TI:00:36:19 TH:0xd42df0 FI:gpm-brightness-xrandr.c FN:gpm_brightness_xrandr_setup_display,170
 - No outputs have backlight property

Maybe the g-p-m just doesn't detect that the screen is lcd with backlight, and because of that it doesn't turn the backlight off?
Also I've noticed that after the initial display blanking by g-p-m, it will try to turn the monitor completely off every 10 minutes, which is the time out set in my g-p-m settings, and then after a split second the backlight turns on again.

Vish (vish) wrote :

I'm starting to have serious screen burn-ins due to this!

My laptop is ON most of the time and i didnt realize this was happening and now the LCD screen has burn-ins!
I had problems with the screensaver not being activated and i was just closing the Lid , didnt realize the problem until my screen started having spots :(

using gnome-power-manager 2.27.5-0ubuntu2

Luís Silva (luis) wrote :

Closing the lid should (it does that in my current laptop and did that in my previous ones too) be disabling the backlight, so maybe the burn-ins where already there...

From what I could find online, this problem with the screensaver should be due to the elimination process hal is suffering from and migration for udev/devicekit/whatever... Can anyone confirm this?

Vish (vish) wrote :

@Luís Silva :
Closing the lid should turn off the display completely. not just the backlight [at present it just turns off the backlight] ...

To check if your laptop is actually turning off the display and not just the backlight :
1: Play a video , [easiest to identify if the LCD is off]
2: try to *gently* press the lid switch. [be gentle, if you press too hard the pin *will* break]

now if the LCD turns off completely and you dont see any videos playing , your setup is working fine.

if you have trouble differentiating use > $ xset dpms force off
you will notice that there is no vide playing when you run the above command.

For me , i can see the videos playing when i use the lid switch. the lid switch only turns off the backlight. this was not how it was earlier.

And the burn-ins werent there earlier , its only after i had left a recent video file on the desktop in karmic , the thumbnail image got stuck!
similar happened to a window frame! the line of an open window got clearly marked!
[as i said, i keep this laptop running 24/7 ! which is a contributing factor]

James Cole (intangi) wrote :
anagor (anagor) wrote :

I think that James' comment 17 is right on spot with this problem and a few others files for gnome-power-manager.
Judging by the description of the problems in those comments.
Now it's up to ubuntu devs to pick up those patches and apply them :)

Scott Howard (showard314) wrote :

The blanking bug is being worked out here: bug 397839. It's 1/3 of the way done. Could you please monitor that bugs progress and report here if it fixes your bug? Thanks!

Steve Beattie (sbeattie) on 2009-08-28
Changed in gnome-power-manager (Ubuntu):
importance: Undecided → Medium
Tim Lunn (darkxst) wrote :

I am also having this problem, on a fresh Karmic alpha 6 install, desktop system with Nvidia 9600GT card. I have 2 monitors in a Twinview configuration.

screens will blank, but never sleep.

'xset dpms force off' does not cause the monitors to sleep, they just blank (this command doesnt work in my jaunty installation either, but dpms sleep is working on that).

'xset dpms 0 0 60' does cause the monitors to go to sleep.

also noticed that grub2 broke dpms on my jaunty installation.

Alex Murray (alexmurray) wrote :

I've uploaded a patched version of xorg-server to my PPA which should fix this if you want to test it:

https://launchpad.net/~alexmurray/+archive/ppa

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers