System shutdown on 0% for 1 of 2 batteries.

Bug #379599 reported by tippettm on 2009-05-23
74
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
Upower
New
Undecided
Unassigned
gnome-power
Expired
Medium
gnome-power-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-power-manager

With two batteries, when the first battery hits low levels gnome-power-manager alerts the user of low/critical and then takes the "critcially" low action, even thow the other battery is still at 100%. gnome-power-manager detects and can interact with either battery.

This affects at least karmic, but is believed to affect jaunty as well.

gnome-power-manager version 2.26.1-0ubuntu3

I would expect that gnome-power-manager should warn, but then continue to move through the second battery.

Loïc Minier (lool) wrote :

I see this too

Changed in gnome-power-manager (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in gnome-power:
status: Unknown → In Progress
Changed in linux:
status: Unknown → Fix Released
Loïc Minier (lool) wrote :

I believe the latest version of devicekit-power fixes this, but it needs testing.

Loïc Minier (lool) wrote :

Blah still got the bubbles today; probably we need a new GPM still.

Scott Howard (showard314) wrote :

Could someone test this with the most recent Karmic GPM (2.27.5-0ubuntu1)? Upstream has put some bug fixes in that should have fixed this in their latest versions.

Thomas Waldmann (tw-public) wrote :

I just have seen this on Jaunty (as of today, with all updates installed).

I had one battery at about 99%, the other at 0%. Usually this works without problems - if you use 2 batteries, you have that state rather often.

But today I plugged in the power supply with the batteries being in that charge state. Then some hint appeared at the top right of the screen "battery is critically low" and it immediately began to shut down my machine, killing all running applications...

That of course is completely nuts, because:
a) one battery was full
b) it was running on AC power (just plugged in)

Thomas Waldmann (tw-public) wrote :

In case it matters: my laptop is a Lenovo Thinkpad X300, 3cell bay battery + 6cell main battery.

Hi,

Sorry for my tardiness, I missed this thread. I'll let Karmic have a
go today.

I believe it is fixed, since I did a Karmic re-install and the default
behaviour of suspend on low battery.

I believe I have seen some quirks - like hibernate immediately after
resume from suspend... But I'll be more attentive now.

Regards... Matthew

On 8/3/09, Scott Howard <email address hidden> wrote:
> Could someone test this with the most recent Karmic GPM
> (2.27.5-0ubuntu1)? Upstream has put some bug fixes in that should have
> fixed this in their latest versions.
>
> --
> System shutdown on 0% for 1 of 2 batteries.
> https://bugs.launchpad.net/bugs/379599
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Sent from my mobile device

Hello,

I can confirm this bug is also present in Lucid (g-p-m 2.29.1-0ubuntu2).

My setup is a Lenovo Thinkpad x61 and T61. I tested both of them with the UltraBay battery.
First the UltraBay Battery discharges. Then GPM presents a warning and shutdown the system when the ultrabay battery is empty. I charged them again and tested again.

Still one battery is recognized but when manually do a cat /proc/acpi/battery/BAT0/status and cat /proc/acpi/battery/BAT1/status g-p-m recognizes the second battery and everything works fine.

Changed in gnome-power:
importance: Unknown → Medium
Changed in linux:
importance: Unknown → Medium

I can confirm I'm still seeing this on a fresh install of Natty. I've got the ThinkPad x220 and the additional "slice" battery. At the moment the primary battery is fully charged and the secondary is discharging.

cat /proc/acpi/battery/BAT0/state:

present: yes
capacity state: ok
charging state: charged
present rate: 0 mA
remaining capacity: 6618 mAh
present voltage: 12852 mV

cat /proc/acpi/battery/BAT1/state:

present: yes
capacity state: ok
charging state: discharging
present rate: 953 mA
remaining capacity: 4722 mAh
present voltage: 11823 mV

So from acpi's perspective both are detected correctly. Opening up the "Power Statistics" also shows them detected correctly. But the Power Management panel widget shows two batteries, both with the same time remaining. This always stays in sync as if it's only pulling data from one battery, and since it's dropping it must be the secondary.

When the secondary battery gets down into the critical range, Power Management will erroneously see that condition on both batteries and shut the laptop down. Which is annoying enough, but there's also no option to "do nothing" when battery power is critically low. I'm forced to choose between suspend, hibernate or shut down. So if I don't happen to be watching the laptop when the secondary battery is about to run out I might as well not have it at all - any processes I have running get interrupted.

Russ Dill (russ-dill) wrote :

I'm seeing this under precise with gpm 3.2.1-1

MNLipp (mnl) wrote :

I'm still seeing this with my HP 6730b and 11.10. The laptop has an additional removable battery. When I issue
> cat /proc/acpi/battery/BAT1/state

I get

> present: no

So it shouldn't be a problem to simply "leave that one out" when making descisions concerning the battery state.

When I suspend my laptop, unplug the power and then resume again, it will in about one of two cases shutdown because of low battery, although the built-in battery is almost at 100% (obviously).

If I remember right, that behaviour started with Natty. Maverick was still OK.

Christopher (captain-c) wrote :

I am having issues here too with my Dell Latitude E6520. Resuming from suspend results in critical battery warning (when that should not be the case), and a shut down. I only have one battery, but two icons show up in the notification area.
> cat /proc/acpi/battery/BAT0/state
results in valid information

> /proc/acpi/battery/BAT1/state
> /proc/acpi/battery/BAT2/state
result in
> present: no

Oleg German (oleg-german) wrote :

same problem with VAIO VPC-SA

Aleksandr Panzin (jalexoid) wrote :

ThinkPad T430s.
This is not "Medium" Since the system goes into shut-down without any interaction and causes loss of data in the process.

Let alone this is one of the dumbest oversights of g-p-m, even the acpitool can detect the total battery left.

Aleksandr Panzin (jalexoid) wrote :

In fact, I've checked this is an issue with any model that has more than one battery. This is a general issue, not a laptop model specific one.

Andreas Oberritter (obi++) wrote :

This bug is still present in raring.

Changed in gnome-power:
status: In Progress → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.