"Battery low" notification displays wrong icon, when Human theme is selected

Bug #344886 reported by Mat Tomaszewski on 2009-03-18
This bug report is a duplicate of:  Bug #383274: missing icons for gnome-power-manager. Edit Remove
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Medium
David Barth
Jaunty
Undecided
Unassigned
Karmic
Medium
David Barth

Bug Description

Binary package hint: notify-osd

For the Human theme, a new steel icon should be displayed.

Mat Tomaszewski (mat.t.) on 2009-03-18
Changed in notify-osd (Ubuntu):
assignee: nobody → dbarth
Kenneth Wimer (kwwii) wrote :

the icon exists in the theme as notification-battery-low.svg

Changed in notify-osd (Ubuntu):
importance: Undecided → Medium
Cody Russell (bratsche) wrote :
Changed in notify-osd (Ubuntu):
status: New → Triaged
Sebastien Bacher (seb128) wrote :

icon = "notification-battery-low";
...
g_free(icon)

isn't that going to crash?

Cody Russell (bratsche) wrote :

Eek, you're right. I believe this corrects the problem though.

Cody Russell (bratsche) wrote :

I forgot to diff with -p1

Cody Russell (bratsche) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-power-manager - 2.24.2-2ubuntu8

---------------
gnome-power-manager (2.24.2-2ubuntu8) jaunty; urgency=low

  [ Cody Russell ]
  * debian/patches/04-battery-low-icon-change.patch:
    - use correct icon on the battery low notification (lp: #344886)
  * debian/patches/97_remove-discharging-notify.patch:
    - don't display a notification about battery discharging (lp: #355877)

 -- Sebastien Bacher <email address hidden> Wed, 08 Apr 2009 16:46:06 +0200

Changed in gnome-power-manager (Ubuntu):
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

I reopen this for karmic. The patch applied to 2.24 does not apply at all to 2.26.1, which I'm currently merging. Can you please recreate this against 2.26.1 (bzr get lp:~ubuntu-desktop/gnome-power/devkit-power/, I'll merge it to the ubuntu branch soon) and also forward this upstream?

I guess there might be some more work on icons required anyway, or introduce some general themeability, since the icons in 2.26 changed quite a lot.

Thank you!

Changed in gnome-power-manager (Ubuntu Jaunty):
status: New → Fix Released
Changed in gnome-power-manager (Ubuntu Karmic):
status: Fix Released → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers