Improve Audio Notification When Plugged In

Bug #328946 reported by arky on 2009-02-13
14
Affects Status Importance Assigned to Milestone
gnome-power
Invalid
Wishlist
gnome-power-manager (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-power-manager

Its a good idea to have a audio notification with system beeps when the power adapter is plugged in or out or when the battery is charging/draining.

This is a feature that would be of great help to the blind / low-vision computer users.

Changed in gnome-power-manager (Ubuntu):
importance: Undecided → Wishlist
Scott Howard (showard314) wrote :

Thanks for the report and working to make Ubuntu better. I believe this is implemented. I'm running Karmic on an IBM T21 thinkpad, and there is a system beep when the power adapter state changes. If this isn't the case, please re-set this bug to new.

Changed in gnome-power-manager (Ubuntu):
status: New → Fix Released
arky (arky) wrote :

Thanks Scott. I am running a karmic laptop running version 2.27.2-0ubuntu2 but I don't yet hear a system beep. Am I missing something?

Scott Howard (showard314) wrote :

Thanks for checking on this - someone else reported the same thing, so I'll mark as confirmed.

Thanks for the report, the feature request should be send directly to the upstream authors at bugzilla.gnome.org, for forwarding instructions please have a look to http://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you forward the bug, please post a link to the upstream bug report here. Thanks in advance.

summary: - Audio Notification When Plugged In
+ Improve Audio Notification When Plugged In
Changed in gnome-power-manager (Ubuntu):
status: Fix Released → Confirmed
arky (arky) on 2009-07-13
tags: added: accessibility
Changed in gnome-power:
status: Unknown → Invalid
arky (arky) wrote :

Upstream points out that it might be some issue with ubuntu. Checked Jaunty gnome-power-manager version 2.24.2-2ubuntu8, it doesn't do this. Let me check with karmic.

Thanks for checking. Try with a live-cd
(http://cdimage.ubuntu.com/daily-live/current/) both with your sound
on and muted. We also have Ubuntu only patches which modify
notifications settings. If it doesn't work with Karmic, we should
build some PPAs without the notification patches to test this.

On Fri, Jul 17, 2009 at 12:48 PM, Bug Watch
Updater<email address hidden> wrote:
> ** Changed in: gnome-power
>       Status: Unknown => Invalid
>
> --
> Improve Audio Notification When Plugged In
> https://bugs.launchpad.net/bugs/328946
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Gnome Powermanager: Invalid
> Status in “gnome-power-manager” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: gnome-power-manager
>
> Its a good idea to have a audio notification with system beeps when the power adapter is plugged in or out or when the battery is charging/draining.
>
> This is a feature that would be of great help to the blind / low-vision computer users.
>

arky (arky) wrote :

Scott, couldn't able to get this working with Karmic .

arky (arky) wrote :

Scott, I built a package without notification patches to test for this bug. But it didn't help.

arky (arky) on 2009-09-05
tags: added: a11y
Chris Coulson (chrisccoulson) wrote :

There will be no system beep in Ubuntu, as we disable that by default in libgnome. g-p-m uses canberra to play sounds through your speakers, and the availability of these sounds os theme dependent.

In gnome-volume-control, please check:
- You have a sound theme enabled.
- You have "Enable window and button sounds" enabled
- You have the alert volume turned up.

Also specify the theme you have selected. It seems that the Ubuntu sound theme misses some sounds required by g-p-m

Changed in gnome-power-manager (Ubuntu):
status: Confirmed → Incomplete
arky (arky) wrote :

Hi Chris, all the above mentioned settings are turned on. The theme is 'ubuntu' default theme, beep type is default. The system used for testing is ubuntu lucid.

Roy Jamison (xteejx) wrote :

Thank you for taking the time to make Ubuntu better. Since what you submitted is not really a bug, or a problem, but rather an idea to improve Ubuntu, you are invited to post your idea in Ubuntu Brainstorm at http://brainstorm.ubuntu.com/ where it can be discussed, voted by the community and reviewed by developers. Thanks for taking the time to share your opinion!

Changed in gnome-power-manager (Ubuntu):
importance: Wishlist → Undecided
status: Incomplete → Invalid
arky (arky) wrote :

Teej, this is very ubuntu specific problem. This feature is working on other distros. I request that this bug be reopened.

arky (arky) wrote :

Response from upstream : It already does. It uses canberra to do the system sound. I don't know if this feature is disabled in the ubuntu version, or your system is not setup to play events. Please use the launchpad bug to debug this. Thanks.

Changed in gnome-power:
importance: Unknown → Wishlist
Charlie Kravetz (charlie-tca) wrote :

This is still an issue for visually impaired users. It is caused by changes made by Ubuntu and should not be closed as a requested improvement. It is very valid for those users who can not see the screen.

Changed in gnome-power-manager (Ubuntu):
importance: Undecided → Low
status: Invalid → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.