Ubuntu

When backlighting is set off, it becomes impossible to raise the light again

Reported by Aurélien Paulus on 2009-01-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Hi there,

I've noticed a new bug that is interesting. I use exclusively Ubuntu 8.10 on my macbook 3,1 and when I reduce the luminosity of my screen (touch F1 on my Mac) at a moment it becomes completely dark (no light anymore). Then, I can press F2 to raise the light. Ok.
Now the problem. If I press on F1 too long, I can't get my light again by pressing F2. In fact, I tried 5 times in row. The 2 first time I reboot, then I tried successfully only restarting Xorg (ctrl+alt+backspace). So I tried and tried and finally press on F1 quickly, step by step and analysed the behaviour.
First, the screen becomes black before reaching the extreme left of the luminosity's progress bar that appears in the center of the screen. So, when it becomes black I stop, then try F2 and get my light (low) again and everything works fine. So I press again F1, it's dark, again F1, it's still black, and then pressing twice F2 is OK, light is back. I tried pressing 3 times F1 (1st it's black, 2nd and 3rd it remains black) but I still can get my light again by pressing 3 times F2. Next try: pressing 4 times F1. Then, it's too much. I can't raise the luminosity anymore. I have to restart X and the whole session. I hope that these details will help you.
In general, we press the button to darken the screen some time till it's ok. i. e. to cut temporarily the light. So it goes directly at the extreme point where there is no light and after, when you want your light again by pressing F2, there is no result...

Except of that, everything works perfectly (screen off when I close my Macbook, hibernating, and so on). I have a Intel GMA graphic chipset. Even Compiz Fusion work perfeclty. I think the problem should come from Gnome or Xorg. I haven't a clue.

PS : sorry for my horrendous English and this looooong story, I wanted to be accurate...

description: updated
description: updated
description: updated
Lupine (thelupine) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in gnome-power-manager.

For future reference you might be interested to know that a lot of applications have bug reporting functionality built in to them. This can be accessed via the Report a Problem option in the Help menu for the application with which you are having an issue. You can learn more about this feature at https://wiki.ubuntu.com/ReportingBugs.

Could you please attach the resulting log file of:

gnome-power-bugreport.sh &> gpm.log

to the report? You might also want to take a look to the Debugging instructions located at https://wiki.ubuntu.com/DebuggingGNOMEPowerManager for submit any other logs related to your problem. Thanks in advance.

Aurélien Paulus (paupoo) wrote :

Hi, thanks again for your advice Lupine.

I did what you asked me, I hope so because I'm not an expert !

Here is gpm.log ;-)

Kamus (kamus) wrote :

Since this report have a long time without activity, could you check (if is possible) in latest version included in Karmic if this issue is still happening? Thanks in advance.

Roy Jamison (xteejx) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments