Intrepid regression: XF86Battery hotkey doesn't work

Bug #281134 reported by Gert Kulyk on 2008-10-10
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-power
Confirmed
Medium
xkeyboard-config
Fix Released
Medium
gnome-power-manager (Ubuntu)
Undecided
Unassigned
Intrepid
Undecided
Unassigned
libx11 (Ubuntu)
Undecided
Unassigned
Intrepid
Undecided
Unassigned
x11proto-core (Ubuntu)
Undecided
Unassigned
Intrepid
Undecided
Unassigned
xkeyboard-config (Ubuntu)
Undecided
Unassigned
Intrepid
Undecided
Unassigned

Bug Description

IMPACT:
On Hardy, the XF86Battery hotkey worked properly. It stopped working on all laptops for Intrepid.
This is a low impact problem, but a regression from Hardy

ADDRESSING:
This has been addressed in the following projects:
 - Fixed in gnome power manager trunk
 - Fixed in x11proto-core 7.0.14
 - Fixed in libx11 head
 - A bug has been filed against x11keyboard-config upstream with a patch

TEST CASE:
Any laptop that contains a key that normally emits XF86Battery can be used to reproduce this bug. Open up "xev" and watch the output when pressing XF86Battery. Keycode 244 is emitted, but no Keysym is associated with it.

REGRESSION POTENTIAL:
Very low. Most of the changes here are just adding in additional key symbols that were commented out or not included for some reason or another at Intrepid's release.

Peter Kerekfy (kerekfyp) wrote :

Hi,

I have the same issue with my hp compaq nc6400.

In Hardy xev showed keycode 241 for Fn+F8 while in Intrepid the keycode changed to 244 and it is no longer working.

Bryce Harrington (bryce) wrote :

Hi gkulyk,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

Changed in xserver-xorg-input-evdev:
status: New → Incomplete
Peter Kerekfy (kerekfyp) wrote :

Hi Bryce,

I think I can provide you with the required information. However I am using the live cd since I do not want to upgrade to Intrepid until this hotkey issue is resolved.

Steps to reproduce:
1. Boot into live cd
2. Open gnome-terminal and launch xev
3. Press Fn+F8 and observe xev output: (battery info is not shown)

KeyPress event, serial 31, synthetic NO, window 0x3200001,
    root 0x7c, subw 0x0, time 426798, (-200,363), root:(474,414),
    state 0x0, keycode 244 (keysym 0x0, NoSymbol), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyRelease event, serial 34, synthetic NO, window 0x3200001,
    root 0x7c, subw 0x0, time 426899, (-200,363), root:(474,414),
    state 0x0, keycode 244 (keysym 0x0, NoSymbol), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

4. Kill xev and try Fn+F8 again -> still nothing happens
5. Switch to console (Ctrl+Alt+F1)
6. Press Fn+F8
7. Switch back to X (Ctrl+Alt+F7) and observe that the battery info is shown
8. Save and attach the output of lspci and Xorg log

Peter Kerekfy (kerekfyp) wrote :

Created an attachment (id=20749)
Patch to add missing syms

Several keysyms were recently added to libx11 and x11proto-core. The attached patch gets xkeyboard-config caught up.

Changed in xserver-xorg-input-evdev:
status: Incomplete → Confirmed
description: updated
Changed in x11proto-core:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libx11 - 2:1.1.5-2ubuntu2

---------------
libx11 (2:1.1.5-2ubuntu2) jaunty; urgency=low

  * 023_missing_keysyms.diff:
    - Update to XKeySymDB to git head to enable XF86Battery hotkey (LP: #281134)
      Any other keysyms that were missing come for free via this too.

 -- Mario Limonciello <email address hidden> Tue, 02 Dec 2008 10:44:54 -0600

Changed in libx11:
status: New → Fix Released
Changed in xkeyboard-config:
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-power-manager - 2.24.0-0ubuntu12

---------------
gnome-power-manager (2.24.0-0ubuntu12) jaunty; urgency=low

  * 79-enable-battery-hotkey.patch: Enable hotkey that got disabled
    at 2.24.0's release. (LP: #281134)

 -- Mario Limonciello <email address hidden> Tue, 02 Dec 2008 13:54:53 -0600

Changed in gnome-power-manager:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xkeyboard-config - 1.3-2ubuntu5

---------------
xkeyboard-config (1.3-2ubuntu5) jaunty; urgency=low

   * 003_missing_inet_keys.diff: Add missing KeySyms to enable
     missing XF86Battery hotkey. (LP: #281134)

 -- Mario Limonciello <email address hidden> Tue, 02 Dec 2008 14:47:56 -0600

Changed in xkeyboard-config:
status: New → Fix Released
description: updated

When were these symbols added? I would not like to apply that patch immediately after the symbols were made available. May be, after next xk-c release so that distros would have some time...

Very new stuff. Will apply after January release then...

Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gnome-power-manager:
status: New → Fix Committed
Changed in libx11:
status: New → Fix Committed
Changed in x11proto-core:
status: New → Fix Committed
Changed in xkeyboard-config:
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Stalling g-p-m until the lib has built (build-dep was not actually bumped; I suspect debian/control.in)

Changed in gnome-power-manager:
status: Fix Committed → In Progress
Martin Pitt (pitti) wrote :

Accepted gnome-power-manager into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gnome-power-manager:
status: In Progress → Fix Committed
Ciso (cisoprogressivo) wrote :

Solved for me with Intrepid on XPS M1330

Gert Kulyk (gkulyk) wrote :

Works for me, too. Thank you for fixing this.

Peter Kerekfy (kerekfyp) wrote :

+1

The propsed update fixed for me too!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libx11 - 2:1.1.5-2ubuntu1.1

---------------
libx11 (2:1.1.5-2ubuntu1.1) intrepid-proposed; urgency=low

  * 023_missing_keysyms.diff:
    - Update to XKeySymDB to git head to enable XF86Battery hotkey (LP: #281134)
      Any other keysyms that were missing come for free via this too.

 -- Mario Limonciello <email address hidden> Tue, 02 Dec 2008 10:44:54 -0600

Changed in libx11:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package x11proto-core - 7.0.12-1ubuntu0.1

---------------
x11proto-core (7.0.12-1ubuntu0.1) intrepid-proposed; urgency=low

  * Merge missing keys from 7.0.14 release of x11proto-core so that
    applications that depend on them dont' FTBFS. (LP: #281134)

 -- Mario Limonciello <email address hidden> Tue, 02 Dec 2008 11:57:22 -0600

Changed in x11proto-core:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xkeyboard-config - 1.3-2ubuntu4.4

---------------
xkeyboard-config (1.3-2ubuntu4.4) intrepid-proposed; urgency=low

  * 003_missing_inet_keys.diff: Add missing KeySyms to enable
    missing XF86Battery hotkey. (LP: #281134)

 -- Mario Limonciello <email address hidden> Tue, 02 Dec 2008 14:45:24 -0600

Changed in xkeyboard-config:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-power-manager - 2.24.0-0ubuntu8.1

---------------
gnome-power-manager (2.24.0-0ubuntu8.1) intrepid-proposed; urgency=low

  * Add following patches from 2.24 stable svn branch (LP: #304187)
    - 77-hal-brightness-in-hardware.patch: Don't fail to show the OSD
      when brightness changing is supported in hardware.
    - 78-xrandr-hal-fallback.patch: Fall back to HAL if xrandr calls
      do fail or will be failing.
  * 79-enable-battery-hotkey.patch:
    - Enable hotkey that got disabled at 2.24.0's release. (LP: #281134)
  * debian/control:
    - Build depend on newer x11proto-core for providing XF86Battery
      hotkey keysm.

 -- Mario Limonciello <email address hidden> Tue, 02 Dec 2008 10:21:55 -0600

Changed in gnome-power-manager:
status: Fix Committed → Fix Released
Andy Whitcroft (apw) wrote :

I can see the battery and suspend keysyms under xev on my Dell Studio 15 with these proposed updates installed. They arn't connected to anything but they do produce proper keys as expected.

Hi Andy:

After you restart gnome-power-manager, the XF86Battery keysym should be sucked up by it. XF86Suspend is another story, and I'm not sure it's current status.

Mario Limonciello
Dell | Linux Engineering
<email address hidden>

-----Original Message-----
From: <email address hidden> on behalf of Andy Whitcroft
Sent: Wed 12/17/2008 5:08 AM
To: <email address hidden>
Subject: [Bug 281134] Re: Intrepid regression: XF86Battery hotkey doesn't work

I can see the battery and suspend keysyms under xev on my Dell Studio 15
with these proposed updates installed. They arn't connected to anything
but they do produce proper keys as expected.

--
Intrepid regression: XF86Battery hotkey doesn't work
https://bugs.launchpad.net/bugs/281134
You received this bug notification because you are a member of The Dell
Team, which is a subscriber of a duplicate bug.

On Thu, Dec 18, 2008 at 03:55:57AM -0000, Mario Limonciello wrote:
> After you restart gnome-power-manager, the XF86Battery keysym should be
> sucked up by it. XF86Suspend is another story, and I'm not sure it's
> current status.

Confirmed, I now get a nice little notification of my battery state when
I press the button. Suspend does nothing as yet.

Changed in gnome-power:
status: Unknown → New

Heya suv, just following up on getting this merged in. We're still carrying the patch in ubuntu. Thanks.

Actually, one key was already mapped. Just committed the rest. Thanks!

Changed in xkeyboard-config:
status: Confirmed → Fix Released
Changed in gnome-power:
status: New → Confirmed
Changed in xkeyboard-config:
importance: Unknown → Medium
Changed in gnome-power:
importance: Unknown → Medium
Changed in xkeyboard-config:
importance: Medium → Unknown
Changed in xkeyboard-config:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.