"Starting Power Manager" shouldn't show up on taskbar during login

Bug #278089 reported by Chris Coulson on 2008-10-04
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Low
Ted Gould
Intrepid
Low
Ted Gould

Bug Description

Binary package hint: gnome-power-manager

When logging in to a freshly installed Intrepid Beta, I get a "Starting Power Manager" notification in the taskbar. This is because StartupNotify is set to true in /etc/xdg/autostart/gnome-power-manager.desktop.

I don't think most users are that bothered about knowing if the power management daemon is starting or not.

It seems StartupNotify has been set to true for several releases now, but this notification has only started to be visible in Intrepid.

Changed in gnome-power-manager:
importance: Undecided → Low
yourpalal (alexsleeps) wrote :

I agree, this is also inconsistent with other utilities eg. network manager etc. and should be changed.

Thierry Carrez (ttx) wrote :

I agree it doesn't look very good when you log in.

Apparently StartupNotify=true has been there for some time (since 2.14.3-3), and is set explicitely so that a busy cursor is displayed...

What seems new in recent upgrades is that the "Starting Power Manager" taskbar item remains active for quite some time, even on speedy hardware... must be slower to start than it used to ? Or maybe it didn't display a taskbar item before ?

Chris: if you agree that StartupNotify wasn't false in pre Intrepid releases, could you update the bug title (I'd propose : "Starting Power Manager" shouldn't show up on login) ? My feeling is that the problem lies elsewhere, and setting StartupNotify=false just works around it.

Chris Coulson (chrisccoulson) wrote :

Thierry - I agree. It was true in previous releases. I'll edit bug title/description accordingly.

Thanks

description: updated
mihai.ile (mihai.ile) wrote :

I can confirm this bug and is really annoying...
This release startup looks more like a windows startup :)

Ted Gould (ted) wrote :

Could you please try version:

    2.24.0-0ubuntu8~ppa1

In my PPA:

   http://launchpad.net/~ted-gould/+archive

I believe that it'll fix this issue. Thanks.

Changed in gnome-power-manager:
assignee: nobody → ted-gould
mihai.ile (mihai.ile) wrote :

Hello.
I don't have the 8.10 installed here at home, only at the office so what I did was boot a live CD here on my laptop and confirmed the bug, logged out and in 3 times and confirmed the bug.
Then I installed 2.24.0-0ubuntu8~ppa1 and loged out/in and it worked perfect!
Just to make sure I reverted in synaptic to the repositories version and after another log out/in the bug reapeared.

So the conclusion is that during my tests here on a live CD on my laptop your version worked just perfect!

Tormod Volden (tormodvolden) wrote :

I can confirm that Ted's 2.24.0-0ubuntu8~ppa1 fixed the issue. Please upload, this is first impression when logging in to Intrepid and it looks so unpolished.

Changed in gnome-power-manager:
status: New → Confirmed
Tormod Volden (tormodvolden) wrote :
Thierry Carrez (ttx) wrote :

Ted:
I can confirm the version in your PPA fixes this.
This is a cosmetic fix but definitely one that should make it to release :)

Changed in gnome-power-manager:
milestone: none → ubuntu-8.10
Steve Langasek (vorlon) wrote :

approved for intrepid, but I don't see an upload-ready bzr branch anywhere; Ted, I'm sponsoring this with Tormold's debdiff, to get this included in our last pre-RC package accept batch.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-power-manager - 2.24.0-0ubuntu8

---------------
gnome-power-manager (2.24.0-0ubuntu8) intrepid; urgency=low

  * Removing 02_gnome-power-manager.desktop.in.in.patch as it shouldn't be
    needed and is causing user feedback with the new GNOME Session in
    Intrepid. Fixes LP: #278089

 -- Ted Gould <email address hidden> Fri, 17 Oct 2008 08:45:41 -0500

Changed in gnome-power-manager:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers