a second gnome-power-manager gets launched as root, without reason

Bug #267109 reported by Olivier Cortès on 2008-09-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,
after having applyed a 2 lines patch to resolve bug LP#260314 (https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/260314/comments/8), my GPM works normally. But sometimes, without any reason or manual intervention from me, another daemon is started, as root.

I can see this because a second g-p-m notification icon appears in the systray, and my backlight is resetted to 100% (I've configured it to 40% in my GPM preferences). If I sudo kill the root gpm, my session does not seem to be affected (nothing crashes, nothing changes). Some times later (say, 10 to 30 minutes), another daemons starts again as root, and same player shoots again (sudo kill).

I'm on up-to-date Intrepid. Hardware info @ http://deep-ocean.net/files/sony/

Olivier Cortès (olive) on 2008-09-06
description: updated
Olivier Cortès (olive) wrote :

I should add that this root-gpm can appear at any time, even when my gpm has not crashed at all. I notice this second daemon coming in because my backlight suddently starts to increase until 100%.

When I kill the root-daemon, my back light does not come back to my gpm settings (currently 35%).

I attach the script that I must launch at every session start, to prevent the root gpm to appear.

This behaviour exists under GNOME, and under XFCE (i recently switched to xfce, my gnome session taking nearly one minute to completely start…)

Søren Vind (sorenvind) wrote :

I can confirm that this happens for me in Jaunty amd64. I have not yet discovered when it happens, though.

Scott Howard (showard314) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Jaunty Jackalope. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/. Thanks again and we appreciate your help.

Changed in gnome-power-manager (Ubuntu):
status: New → Incomplete
Olivier Cortès (olive) wrote :

Hi,

I couldn't reproduce this bug on Jaunty, everything is fine.
It's a shame we have to wait for the next release for a fix, because it introduces other bugs and the overall quality doesn't raise, but anyway this bug can be closed.

regards,

Olivier

Thanks for checking. I'm marking this closed as per your last comment.
Also, see: https://wiki.ubuntu.com/StableReleaseUpdates for
information as to why we debug alpha and beta releases to get bugs
fixed in future versions. The upstream developers of
gnome-power-manager are currently working on version 2.27+ (the
version in Karmic) and Ubuntu generally will only update security
fixes in stable releases. Please report any additional bugs that you
find, and if you have the desire - check out Karmic alphas.

status invalid

On Wed, Jul 1, 2009 at 3:39 AM, Olivier Cortès<email address hidden> wrote:
> Hi,
>
> I couldn't reproduce this bug on Jaunty, everything is fine.
> It's a shame we have to wait for the next release for a fix, because it introduces other bugs and the overall quality doesn't raise, but anyway this bug can be closed.
>
> regards,
>
> Olivier
>
> --
> a second gnome-power-manager gets launched as root, without reason
> https://bugs.launchpad.net/bugs/267109
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “gnome-power-manager” package in Ubuntu: Incomplete
>
> Bug description:
> Hi,
> after having applyed a 2 lines patch to resolve bug LP#260314 (https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/260314/comments/8), my GPM works normally. But sometimes, without any reason or manual intervention from me, another daemon is started, as root.
>
> I can see this because a second g-p-m notification icon appears in the systray, and my backlight is resetted to 100% (I've configured it to 40% in my GPM preferences). If I sudo kill the root gpm, my session does not seem to be affected (nothing crashes, nothing changes). Some times later (say, 10 to 30 minutes), another daemons starts again as root, and same player shoots again (sudo kill).
>
> I'm on up-to-date Intrepid. Hardware info @ http://deep-ocean.net/files/sony/
>

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers