Ubuntu

Brightness OSD doesn't stop adjusting

Reported by William Grant on 2008-08-27
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Medium
Ted Gould

Bug Description

Binary package hint: gnome-power-manager

As of this morning's upgrades (I hadn't restarted in perhaps the week before), pressing either hardware brightness adjustment button causes the OSD to go to quickly (but gradually) adjust to extreme. The actual brightness is adjusted fine.

Pedro Villavicencio (pedro) wrote :

Thanks for the report, Which version of Ubuntu and GNOME Power Manager are you running?

Changed in gnome-power-manager:
importance: Undecided → Low
status: New → Incomplete
William Grant (wgrant) wrote :

Intrepid, 2.23.6-0ubuntu1.

Changed in gnome-power-manager:
status: Incomplete → New
William Grant (wgrant) wrote :

Similar symptoms occur on (un)plugging AC power; an invisible box appears in about the right spot for the brightness indicator (one can only notice its presence by a different cursor), and g-p-m's notification icon freezes for a couple of minutes.

Changed in gnome-power-manager:
importance: Low → Medium

What hardware do you have?

There is this line in the changelog for 2.23.1-0ubuntu1, which could be related:

  * 04_brightness_events.patch: Removing. The code upstream has change
    significantly and logic is roughly the same now. May require some
    additional patching, but will wait on user feedback.

William Grant (wgrant) wrote :

It's a Dell Inspiron 630m. i915.

William Grant (wgrant) wrote :

It looks like it is receiving an awful lot (many thousands) of brightness key events for a single press.

As for the strangeness on plugging/unplugging:
TI:13:36:43 TH:0x8d80640 FI:gpm-brightness-xrandr.c FN:gpm_brightness_xrandr_foreach_screen,414
 - using resource 0x8e0e718
TI:13:36:43 TH:0x8d80640 FI:gpm-brightness-xrandr.c FN:gpm_brightness_xrandr_foreach_resource,375
 - resource 1 of 3
TI:13:36:43 TH:0x8d80640 FI:gpm-brightness-xrandr.c FN:gpm_brightness_xrandr_foreach_resource,375
 - resource 2 of 3
TI:13:36:43 TH:0x8d80640 FI:gpm-brightness-xrandr.c FN:gpm_brightness_xrandr_output_set,322
 - percent=50, absolute=7563
TI:13:36:43 TH:0x8d80640 FI:gpm-brightness-xrandr.c FN:gpm_brightness_xrandr_output_set,324
 - hard value=15125, min=0, max=15125

[predictable ~42.5 second hang]

TI:13:37:26 TH:0x8d80640 FI:gpm-brightness-xrandr.c FN:gpm_brightness_xrandr_foreach_resource,375
 - resource 3 of 3
TI:13:37:26 TH:0x8d80640 FI:gpm-backlight.c FN:gpm_backlight_brightness_evaluate_and_set,456
 - emitting brightness-changed : 50
TI:13:37:26 TH:0x8d80640 FI:gpm-profile.c FN:ac_adaptor_changed_cb,635
 - on battery
TI:13:37:26 TH:0x8d80640 FI:gpm-info.c FN:gpm_info_event_log,579
 - Adding 1 to the event log

William Grant (wgrant) wrote :

I suspect it was the removal of 04_brightness_events.patch; the logs indicate something brightness-related and the timeframe is perfect.

William Grant (wgrant) wrote :

The AC state change hang is due to more than 7000 5ms sleeps caused by g-p-m trusting backlight values from XRandR (https://bugs.freedesktop.org/show_bug.cgi?id=15421).

Ted Gould (ted) wrote :

I believe that this might be a duplicate of LP: #261084 I've introducted some code to hopefully fix the repeated keypresses in both situations. Please look at gnome-power-manager_2.24.0-0ubuntu4~ppa2 in my PPA:

http://launchpad.net/~ted-gould/+archive

Changed in gnome-power-manager:
assignee: nobody → ted-gould
Steve Beattie (sbeattie) wrote :

William, are you still having this issue? Has this been addressed by the updated g-p-m package referred to in bug 261084?

William Grant (wgrant) wrote :

Yes, this is fixed in both intrepid and jaunty now, it seems.

Changed in gnome-power-manager:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.