Ubuntu

gnome-power-manager frequently crashes with SIGSEGV in IA__g_closure_invoke() or g_closure_invoke()

Reported by Chris Halse Rogers on 2008-08-22
448
This bug affects 37 people
Affects Status Importance Assigned to Milestone
gnome-power
Fix Released
Critical
gnome-power-manager (Ubuntu)
High
Unassigned
Intrepid
High
Unassigned

Bug Description

Binary package hint: gnome-power-manager

gnome-power-manager has been crashing fairly regularly for me. It seems to crash with this error everytime I start the laptop unplugged, but after starting it up again it seems to crash while plugged in, as well, just in ordinary use.

Looking at it, it seems like it might be crashing each time the percentage-charge of the battery changes.

ProblemType: Crash
Architecture: amd64
CrashCounter: 1
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/gnome-power-manager
Package: gnome-power-manager 2.23.6-0ubuntu1
ProcAttrCurrent: unconfined
ProcCmdline: gnome-power-manager
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_AU.UTF-8
 SHELL=/bin/zsh
Signal: 11
SourcePackage: gnome-power-manager
StacktraceTop:
 ?? ()
 ?? ()
 IA__g_closure_invoke (closure=0x24d4ad0,
 signal_emit_unlocked_R (node=0x24d4800, detail=0,
 IA__g_signal_emit_valist (instance=0x22c2810,
Title: gnome-power-manager crashed with SIGSEGV in IA__g_closure_invoke()
Uname: Linux 2.6.27-1-generic x86_64
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev pulse-rt sambashare video

Chris Halse Rogers (raof) wrote :
description: updated
Chris Halse Rogers (raof) wrote :

Hm. It seems that sometimes, but not always, it spits some debug output before crashing.

┌─(raof@CowboyLaputopu:pts/0)─────────────────────────────────────────────(~)─┐
└─(19:15:%)── gnome-power-manager --no-daemon ──(Fri,Aug22)─┘
zsh: segmentation fault (core dumped) gnome-power-manager --no-daemon
┌─(raof@CowboyLaputopu:pts/0)─────────────────────────────────────────────(~)─┐
└─(139:19:18:%)── gnome-power-manager --no-daemon ──(Fri,Aug22)─┘

** (gnome-power-manager:8551): CRITICAL **: gpm_cell_array_get_cell: assertion `GPM_IS_CELL_ARRAY (cell_array)' failed

** (gnome-power-manager:8551): CRITICAL **: gpm_cell_get_unit: assertion `cell != NULL' failed
zsh: segmentation fault (core dumped) gnome-power-manager --no-daemon

Matt Zimmerman (mdz) wrote :

I see the same thing; gnome-power-manager segfaults after a few minutes of runtime, even when the system is completely idle. I see the following output with --no-daemon --verbose before the crash:

** (gnome-power-manager:26090): CRITICAL **: gpm_cell_array_get_cell: assertion `GPM_IS_CELL_ARRAY (cell_array)' failed

** (gnome-power-manager:26090): CRITICAL **: gpm_cell_get_unit: assertion `cell != NULL' failed
TI:10:54:13 FI:gpm-cell.c FN:hal_device_property_modified_cb,325
 - ** EMIT: percent-changed: 37314672
zsh: segmentation fault (core dumped) gnome-power-manager --no-daemon --verbose |

and am attaching a complete --verbose log.

Changed in gnome-power-manager:
importance: Undecided → High
status: New → Triaged

This may be a duplicate of bug 149746, but that bug is much older and had no further reports until this big spike in reports in Intrepid, so I suspect it's a different issue.

Tobias Pflug (tobias-pflug) wrote :

identical behavior here. SamsungQ45/64bit

Albert Damen (albrt) wrote :

Debugging manually with dbgsym packages installed gives a stacktrace with all symbols resolved.
#0 gpm_cell_array_update (cell_array=0x16d9380) at gpm-cell-array.c:288
#1 0x0000000000411d30 in gpm_cell_percent_changed_cb (cell=<value optimized out>, percent=85084016, cell_array=0x20)

In frame #0 length seems to indicate the number of batteries. That would mean length = 23939424 is wrong. My system has 2 batteries, as properly detected by hal:
$ hal-find-by-capability --capability "battery"
/org/freedesktop/Hal/devices/computer_power_supply_battery_BAT1 (main battery)
/org/freedesktop/Hal/devices/usb_device_46d_c50e_noserial (wireless mouse)

Albert Damen (albrt) wrote :

This bug is fixed in gnome-power-manager svn revision 2882:

* src/gpm-cell-array.c: (gpm_cell_percent_changed_cb):
The callback passes a gfloat, not a guint.

I applied the patch and gpm does not crash anymore.

Changed in gnome-power:
status: Unknown → Fix Released
Steve Langasek (vorlon) on 2008-09-03
Changed in gnome-power-manager:
milestone: none → intrepid-alpha-6
Olivier Cortès (olive) wrote :

Hi, manually applyed the SVN rev 2881 (not 2882 !) 2-lines patch, and GPM is stable again. cool !!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-power-manager - 2.23.6-0ubuntu2

---------------
gnome-power-manager (2.23.6-0ubuntu2) intrepid; urgency=low

  * debian/patches/50-r2882-fix-547766.patch: upstream fix for crash in
    gpm_cell_array_update gpm-cell-array.c:273 (LP: #260314)

 -- Matt Zimmerman <email address hidden> Mon, 08 Sep 2008 09:43:04 +0100

Changed in gnome-power-manager:
status: Triaged → Fix Released

i recently reported the bug 269083 that seems related to this bug, it crashed at the version 2.23.91-0ubuntu2, battery had less than 15%

Alexander Rødseth (alexanro) wrote :

Crashes here too.

~% LC_ALL=C apt-cache policy gnome-power-manager
gnome-power-manager:
  Installed: 2.24.0-0ubuntu2
  Candidate: 2.24.0-0ubuntu2
  Version table:
 *** 2.24.0-0ubuntu2 0
        500 http://ftp.uninett.no intrepid/main Packages
        100 /var/lib/dpkg/status

~% LC_ALL=C uname -r
2.6.27-4-generic

~% cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.10
DISTRIB_CODENAME=intrepid
DISTRIB_DESCRIPTION="Ubuntu intrepid (development branch)"

wtgee (wtgee) wrote :

Mine crashed on lid closure while not plugged in.

Wouter Geraedts (w-geraedts) wrote :

Just happened to me on low power, I was doing nothing; laptop's unplugged. I'm on Intrepid Ibex AMD64.

~$ dmesg
gnome-power-man[6697] general protection ip:40cb40 sp:7fffd965d090 error:0 in gnome-power-manager[400000+4c000]

~$ LC_ALL=C apt-cache policy gnome-power-manager
gnome-power-manager:
  Installed: 2.24.0-0ubuntu3
  Candidate: 2.24.0-0ubuntu3
  Version table:
 *** 2.24.0-0ubuntu3 0
        500 http://nl.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

~$ LC_ALL=C uname -r
2.6.27-5-generic

Rich (rincebrain) wrote :

Not fixed for me, or apparently other people. Reopening.

Changed in gnome-power-manager:
status: Fix Released → Confirmed
Rich (rincebrain) wrote :

My apologies, a different bug is being encountered by everyone.

Changed in gnome-power-manager:
status: Confirmed → Fix Released

Rich how is this a new problem?
to me it has the exact same symptoms of the original bug.
It was fixed, and it restarted 2 days ago.
its even worse now, since running gnome-power-manager will not fix the power management or bright applet.
And since https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/242665 isnt fix either, i have to manually set my power setting by hand every time I change from battery to AC or vice-versa, inducing more crashes.

yep, my problem is more or less the same.

On Wed, Oct 8, 2008 at 9:16 AM, BUGabundo <email address hidden> wrote:

> Rich how is this a new problem?
> to me it has the exact same symptoms of the original bug.
> It was fixed, and it restarted 2 days ago.
> its even worse now, since running gnome-power-manager will not fix the
> power management or bright applet.
> And since
> https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/242665isnt fix either, i have to manually set my power setting by hand every time
> I change from battery to AC or vice-versa, inducing more crashes.
>
> --
> gnome-power-manager frequently crashes with SIGSEGV in
> IA__g_closure_invoke() or g_closure_invoke()
> https://bugs.launchpad.net/bugs/260314
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in Gnome Powermanager: Fix Released
> Status in "gnome-power-manager" source package in Ubuntu: Fix Released
> Status in gnome-power-manager in Ubuntu Intrepid: Fix Released
>
> Bug description:
> Binary package hint: gnome-power-manager
>
> gnome-power-manager has been crashing fairly regularly for me. It seems to
> crash with this error everytime I start the laptop unplugged, but after
> starting it up again it seems to crash while plugged in, as well, just in
> ordinary use.
>
> Looking at it, it seems like it might be crashing each time the
> percentage-charge of the battery changes.
>
> ProblemType: Crash
> Architecture: amd64
> CrashCounter: 1
> DistroRelease: Ubuntu 8.10
> ExecutablePath: /usr/bin/gnome-power-manager
> Package: gnome-power-manager 2.23.6-0ubuntu1
> ProcAttrCurrent: unconfined
> ProcCmdline: gnome-power-manager
> ProcEnviron:
>
> PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
> LANG=en_AU.UTF-8
> SHELL=/bin/zsh
> Signal: 11
> SourcePackage: gnome-power-manager
> StacktraceTop:
> ?? ()
> ?? ()
> IA__g_closure_invoke (closure=0x24d4ad0,
> signal_emit_unlocked_R (node=0x24d4800, detail=0,
> IA__g_signal_emit_valist (instance=0x22c2810,
> Title: gnome-power-manager crashed with SIGSEGV in IA__g_closure_invoke()
> Uname: Linux 2.6.27-1-generic x86_64
> UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev
> pulse-rt sambashare video
>

--
Ahmed Mahfouz

Mike Lundy (novas0x2a) wrote :

I can second this (gpm 2.24.0-0ubuntu3). Valgrind says:

==19505== Invalid read of size 8
==19505== at 0x40CB40: gpm_cell_array_charge_low_cb (gpm-engine.c:799)
==19505== by 0xCE2425C: g_closure_invoke (in /usr/lib/libgobject-2.0.so.0.1800.1)
==19505== by 0xCE39F5C: (within /usr/lib/libgobject-2.0.so.0.1800.1)
==19505== by 0xCE3B607: g_signal_emit_valist (in /usr/lib/libgobject-2.0.so.0.1800.1)
==19505== by 0xCE3BB32: g_signal_emit (in /usr/lib/libgobject-2.0.so.0.1800.1)
==19505== by 0x411AA4: gpm_cell_array_collection_changed (gpm-cell-array.c:784)
==19505== by 0x411F22: gpm_cell_array_add_device_id (gpm-cell-array.c:839)
==19505== by 0x412092: gpm_cell_array_coldplug (gpm-cell-array.c:877)
==19505== by 0x41217F: gpm_cell_array_refresh (gpm-cell-array.c:943)
==19505== by 0xCE2425C: g_closure_invoke (in /usr/lib/libgobject-2.0.so.0.1800.1)
==19505== by 0xCE39F5C: (within /usr/lib/libgobject-2.0.so.0.1800.1)
==19505== by 0xCE3B607: g_signal_emit_valist (in /usr/lib/libgobject-2.0.so.0.1800.1)
==19505== Address 0x3a54494d45202a2a is not stack'd, malloc'd or (recently) free'd

ERROR: Caught a segmentation fault while loading plugin file:
/usr/lib/gstreamer-0.10/libgstaudioresample.so

Mike Lundy (novas0x2a) wrote :

Sorry, on further reading, my backtrace definitely refers to bug 269083. Moving myself over there.

shirokuro (ccampbell1) wrote :

The problem described initially on this thread is happening to me consistently on a clean-install of the released version of Ubuntu 8.10 (CD from .iso).

I am a newbie and don't have Linux debugging experience to know if the process/app crashes are the same phenomenon or cause, however the user-visible symptoms seem identical or very close.

 - on AC power, no problems.
 - on battery power, the below multitude of problems:
 - battery icon initially appears on menubar, but after some short time, becomes unresponsive
 - after the battery icon becomes unresponsive, try to launch Power Management from menus
 - power management app takes some time (sometimes a minute or two) to launch
 - when it launches, ALL mention of battery anywhere is missing (no battery tab, nor any other battery related options)
 - The screen brightness will sometimes dim. I have no way to control it.
 - Closing the laptop lid while the problem is occurring will not suspend the machine.
 - The problem will frequently recover automatically after some time (I haven't attempted to find the pattern)
 - By recover, I mean that the battery icon becomes responsive again, and the
 - Once the problem recovers, after some time, it will occur again (again, I don't know the pattern)
 - This goes on repeatedly (problem occurs, recovers, recurs)
 - The WORST symptom is, when the problem has recovered (battery icon responding, battery tab in control panel) if I suspend the machine (close lid) it goes into suspend fine. However, when I try to wake from suspend, the hard disk seems to go, it seems to wake up, however the screen remains completely off. I cannot get the screen to wake up and I have to force power-off the machine.

My machine is a Japanese Panasonic Let's Note CF-R3. These power symptoms do NOT happen on Ubuntu 8.04. Battery meter, control panel, suspend/resume all work perfectly on 8.04.

I tested both an 8.04->8.10 upgrade, and a clean 8.10 install. The power issues happen either way, although with the upgrade, the problem never seems to recover - once it happens once, it never recovers.

As I mentioned, I am an Ubuntu newbie, so I dont know how to gather the necessary data for people to work on this problem. If someone could let me know what data I need to provide, and how to get it, I would really appreciate it. These power issues are so critical for me, I cannot really consider Ubuntu 8.10 for serious use until it can be fixed.

Thanks a lot!

Craig

Gert van Dijk (gertvdijk) wrote :

I've got the exact same problems on my Thinkpad T61p as Craig.

It's fairly reproducible for me. Every time I plug or unplug the power cord I get the following message in syslog:
> acpid: client has disconnected
and gnome-power-manager becomes unresponsive. This also results in not being able to shutdown/suspend/hibernate from gdm and not being able to control the brightness of my laptop display from GDM (but works with function keys).

Sometimes even stranger things happen, like at this very time of writing, I get a second (identical) battery in Gnome Power Manger...

In Hardy I wasn't experiencing these problems.

Don't know to what extent this is related to the original bug report (I can make a new bug report if needed).

Jared Johnson (jaredj-nmgi) wrote :

getting this on current karmic beta. the automagical bug stuff led me here.

Pedro Côrte-Real (pedrocr) wrote :

Hit what appears to be this bug on latest lucid by unplugging the power chord. Hardware is a Lenovo X61 laptop. Anything else I can gather that can help here? Does apport even attach the crash info it collected to this bug report?

basejumper9 (basejumper9) wrote :

Same deal on a Lenovo X61 Tablet. Let me know if I can help out.

Changed in gnome-power:
importance: Unknown → Critical
Ilan (ilan) wrote :

Seems to be occurring in Natty after waking from sleep.

Stefan (sbossb) wrote :

Got this error today after removing the power cord from my laptop. Running Natty Beta 1.

Cristobal Tapia (crtapia) wrote :

I'm having problems with when removing the charger using ubuntu 12.04 and gnome-shell. It is very annoying, because the computer don't respond anymore.

Any solution for this?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.