pressing the "Power" button shows a logout dialog

Bug #252795 reported by Սահակ on 2008-07-29
82
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-power
Fix Released
Wishlist
gnome-session
Invalid
Undecided
Unassigned
Fedora
Invalid
Undecided
Unassigned
gnome-power-manager (Ubuntu)
Low
Ted Gould
Nominated for Intrepid by Wouter Stomp
gnome-session (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by Wouter Stomp

Bug Description

Pressing the "Power" buttons brings up GNOME logout dialog which offers to log out current user, or to switch user. It should bring the shutdown/suspend/hibernate dialog instead.

Michael Rooney (mrooney) wrote :

Hi Ani, thanks for using Ubuntu and thanks for taking the time to file this bug report! As far as I am aware, these dialogs you speak of are the same. Below the gnome session options (Logout, Switch User, etc) you should have Suspend/Hibernate/Shutdown/Restart, something like http://www.parsix.org/html/images/gnome-logout.png. Is that not what you see?

Սահակ (petrosyan) wrote :

I am using Ubuntu Intrepid.
This is the dialog I see when I press the physical "power" button.

Michael Rooney (mrooney) wrote :

Thanks Ani. It says you are a live session user; is this happening from the LiveCD, or on an installed system? By the way when you supply information, you should (if at all) set the bug to the original status (in this case New, not Confirmed). A person can't Confirm their own bug, that doesn't make any sense and defeats the point :)

Kjell Braden (afflux) wrote :

This happens on an installed system, and presumably on a live session too.

Nick Russell (thatnick) wrote :

This happens on my intrepid install as well when 'When the power button is pressed" is set to "Ask me".

Alexander Jones (alex-weej) wrote :

Still affecting Intrepid.

Funny that the options are "Ask me", "Suspend", "Hibernate" and "Shutdown", yet when it actually does "ask me", it offers to "Log Out" or "Switch User".

Mik3 (mc4100) wrote :

Confirmed, this is easily reproducible on an up-to-date Intrepid:

System -> Preferences -> Power Management
                     --General Tab ---
When power button is pressed: Ask me
*Press power button*
Log-out dialog comes up -- NOT EXPECTED, the correct behavior should be to bring up the shutdown options.
I believe this is an issue with the command for bringing up the old Shutdown (Dark-screen) window, it's now the same that brings up the logout-dialog...

Also confirmed in post alpha 6 Intrepid. Very frustrating when you're used to getting the shutdown options!

Keithamus (keithamus) wrote :

Can confirm - upgraded from 8.04 to Intrepid Alpha 6. In 8.04 it worked fine, now in Alpha 6 presents the Log out dialogue, not the shut down one. (see attachment, running gnome not kde!).

I filed a bug report which turned out to be a duplicate of this, here: https://bugs.launchpad.net/ubuntu/+bug/274420

Changed in gnome-session:
status: New → Confirmed
Hew (hew) wrote :

I believe this affects gnome-power-manager and not gnome-session. Triaging and closing respectively.

Changed in gnome-power-manager:
importance: Undecided → Low
status: Confirmed → Triaged
Changed in gnome-session:
status: Confirmed → Invalid
Scott Wegner (swegner) wrote :

I can also confirm this in Intrepid Beta. Rather annoying, as I am used to pressing the power button to select shutdown option.

Pedro Villavicencio (pedro) wrote :

There's also a bug upstream about this at : http://bugzilla.gnome.org/show_bug.cgi?id=507393 , linking the report.

Changed in gnome-power-manager:
assignee: nobody → ted-gould

> There's also a bug upstream about this at :
> http://bugzilla.gnome.org/show_bug.cgi?id=507393 , linking the report.

Thanks Pedro! But if the upstream bug is in gnome-session, is the
gnome-session (Ubuntu) aspect still Invalid (and is the g-p-m one
correct) as Hew swapped them?

Hew (hew) wrote :

Gnome and Fedora have this bug filed under g-p-m. If someone knowledgeable on this issue believes I was wrong to triage it for g-p-m, then it should be changed.

Changed in gnome-session:
status: Unknown → Confirmed
Kjell Braden (afflux) wrote :

Moving to gnome-power to avoid confusion with gnome-session.

Changed in gnome-session:
importance: Unknown → Undecided
status: Confirmed → New
status: New → Invalid
Pedro Villavicencio (pedro) wrote :

there's a fix at ted's ppa https://edge.launchpad.net/~ted-gould/+archive ; I've tried it yesterday and it works as it should for me at least, may someone else try it too and give feedback here in the report? thanks.

Michael Rooney (mrooney) wrote :

Yes, it seems to work after a restart, showing the power options dialog instead of the logout dialog. I still think having them all together was nice, and some people will complain that they can't logout/lock from the power button now, but this is surely better! Is there any page or archived discussion regarding the separation of the dialogs? I assume this was just an upstream Gnome decision?

Yes, it was an upstream change. I think it was related to the dialog
being considered too "busy."

Fair enough, I can understand the reasoning. It would be extra slick
if the Power Management option "Ask me" was then appropriately split
into two options, something roughly like "Prompt me with power
options" and "Prompt me with session options", since I imagine some
people only used the power button to logout or lock and might prefer
this option. I understand the UI is frozen, but it might be something
to consider for Jaunty. If anyone agrees I can make a wishlist bug;
let me know.

Changed in gnome-power:
status: Unknown → Confirmed
vaughn (vaughngrisham) wrote :

I totally agree Mike. I for one never log off or switch user. I just want to shut down or restart. I'd like that option.

Dirk (rptq) wrote :

I am not so sure whether splitting the dialogs is such good idea, and I never considered the old dialog particularly busy. Anyhow, I understand there are different scenarios depending on whether the machine is running 24 hours, whether it's a family PC, a server or a single-user laptop. Each one would probably need its own subset of operations that should appear when the power button is pressed. On my laptop I would agree with Vaughn, but I'd like to see the "lock" as well. Different story on my desktop. Maybe we should have a list where we can select the functions. But for now, I would prefer to have the complete list back.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-power-manager - 2.24.0-0ubuntu6

---------------
gnome-power-manager (2.24.0-0ubuntu6) intrepid; urgency=low

  * Adding 21_idle_key_removal.patch which makes it so that the glib
    mainloop has to hit the idle state before we'll accept another key
    from X. This should remove quickly repeated keys and keys that were
    queued before suspend. (LP: #261084)
  * Adding 22_xfce_desktop_files.patch which adds XFCE to the ShowIn
    properties of the preferences and statistics desktop files.
  * Added 23_numlock_hotkey.patch which is the changes from 0ubuntu4 and put
    it into a patch.
  * Adding 24_interactive_shutdown_dbus.patch which is based on the patch
    in GNOME Bug: #507393. Made to build on 2.24.0 and also put in more
    error checking and a fallback to XSMP when DBus based session management
    is not available. (LP: #252795)

 -- Ted Gould <email address hidden> Wed, 15 Oct 2008 11:10:23 -0500

Changed in gnome-power-manager:
status: Triaged → Fix Released

I already have Version: 2.24.0-0ubuntu7 and still get the logout option, instead of shutdown

Ted Gould (ted) wrote :

On Thu, 2008-10-16 at 13:59 +0000, BUGabundo wrote:
> I already have Version: 2.24.0-0ubuntu7 and still get the logout option,
> instead of shutdown

Did you restart your machine after upgrading?

> Did you restart your machine after upgrading?

I havent restarted my laptop in two days....

/me is glad hibernation works

--
BUGabundo :o)
(``-_-´´) http://LinuxNoDEI.BUGabundo.net
Linux user #443786 GPG key 1024D/A1784EBB
My new micro-blog @ http://BUGabundo.net

Alexander Jones (alex-weej) wrote :

Same. Yes. I didn't even see the changelog entry corresponding to the fix.
:(

Rebooted and when I now press my power button I get the expecte menu.

Thanks

Changed in gnome-power:
status: Confirmed → Fix Released
Changed in gnome-power:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.