Ubuntu

closing the lid should suspend if and only if no external video is connected

Reported by Marius Gedminas on 2008-06-28
60
This bug affects 11 people
Affects Status Importance Assigned to Milestone
gnome-power
Fix Released
Wishlist
gnome-power-manager (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-power-manager

On laptops it's very convenient to have the laptop go to sleep when I close the lid. However, when I connect an external monitor (or a TV) to a laptop, I often want to close the lid so that the smaller internal screen doesn't get in the way. Blanking the screen or going to sleep is exactly what I don't want in those use cases.

g-p-m should offer me a choice to ignore lid events when there's an external monitor connected to the laptop, and I'd even go as far as to say this choice should be the default.

Use cases:

  * Bob is working on his laptop and needs to go somewhere. Bob closes the lid, laptop goes to sleep.

  * Mary comes home with her nice small Asus EeePC, plugs in a large external monitor, a USB keyboard and wants to close the laptop screen to save power (or desk space). The laptop shouldn't go to sleep.

  * John wants to watch a movie on a large TV. He plugs the cables, starts the movie, and closes the lid to avoid having an extra light source showing the same (but much smaller) picture next to the TV. The laptop shouldn't go to sleep.

Changed in gnome-power:
status: Unknown → Invalid
Changed in gnome-power-manager (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Changed in gnome-power:
status: Invalid → New
Changed in gnome-power-manager (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-power:
importance: Unknown → Wishlist
Changed in gnome-power:
status: New → Fix Released
Matthew Paul Thomas (mpt) wrote :

Besides being marked fixed upstream, this may be a duplicate of bug 138102. There the problem is with all screens blanking, but the cause is probably the same.

Dac Chartrand (conner-bw) wrote :

New use case that affects me pretty much every other day.

Dan is working at the office with his laptop and an external monitor plugged in. Dan is in a rush to get home. Dan closes the lid, unlplugs his monitor, and stuffs the laptop in his napsack. A few hours later he opens his bag only to find an overheated laptop still running. Sweat forms on his brow because he now worries sectors on his hard drive are corrupted.

Running Ubuntu 12.10

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.