Brightness applet loses sync with screen brightness

Bug #235363 reported by Ryan Steele on 2008-05-28
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-power-manager

I can adjust the brightness of the screen with the brightness applet or with the Fn-Home (increase brightness) and Fn-End (decrease brightness) keyboard shortcuts. When I press Fn-End, the screen dims, the "brightness meter" appears on the screen and the slider in the brighness applet is changed accordingly. However, if I use the Fn-Home key combination, the brightness increases, but the "brightness meter" does not appear and the slider in the brightness applet is not updated. Usually when the slider in the brightness applet is adjusted the screen brightness "catches up" with it but on a couple occasions the slider stops working and the following message appears in /var/log/syslog:

May 27 17:11:40 csb-laptop kernel: [ 155.937282] thinkpad_acpi: CMOS NVRAM (4) and EC (5) do not agree on display brightness level
May 27 17:11:40 csb-laptop kernel: [ 155.967048] thinkpad_acpi: CMOS NVRAM (4) and EC (5) do not agree on display brightness level
May 27 17:11:40 csb-laptop kernel: [ 156.009140] thinkpad_acpi: CMOS NVRAM (4) and EC (5) do not agree on display brightness level
May 27 17:11:40 csb-laptop kernel: [ 156.038740] thinkpad_acpi: CMOS NVRAM (4) and EC (5) do not agree on display brightness level
May 27 17:11:40 csb-laptop kernel: [ 156.098716] thinkpad_acpi: CMOS NVRAM (4) and EC (5) do not agree on display brightness level
May 27 17:11:40 csb-laptop kernel: [ 156.128828] thinkpad_acpi: CMOS NVRAM (4) and EC (5) do not agree on display brightness level

The numbers in the parentheses varies. I'm not able to reproduce this particular behaviour consistently.

Steps to reproduce:
1. Decrease the screen brightness with the slider in the brightness applet.
2. Increase the screen brightness with the Fn-Home key combination

Expected result:
The screen brightness increases, the brightness indicator is displayed on-screen, and the slider in the brightness applet is updated

Actual result:
The screen brightness increases, but the brightness indicator is not displayed and the slider is not updated

ProblemType: Bug
Architecture: i386
Date: Tue May 27 17:19:25 2008
DistroRelease: Ubuntu 8.04
NonfreeKernelModules: fglrx ath_hal
Package: gnome-power-manager 2.22.1-1ubuntu4
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_CA.UTF-8
SourcePackage: gnome-power-manager
Uname: Linux 2.6.24-17-generic i686

Ryan Steele (rgsteele) wrote :
Ryan Steele (rgsteele) wrote :

Sorry, forgot to mention this is an IBM ThinkPad T43, type 2668-95U.

Ryan Steele (rgsteele) wrote :

I tried the steps on https://wiki.ubuntu.com/LaptopTestingTeam/HotkeyResearch. I'm not getting a keycode for the "increase brightness" key using any of the four methods.

Pedro Villavicencio (pedro) wrote :

Thanks for your report, is this still an issue with latest kernel? that's maybe is an acpi issue or a kernel one. GPM just read that info from them, thanks.

Changed in gnome-power-manager:
importance: Undecided → Low
status: New → Incomplete
Ryan Steele (rgsteele) wrote :

Yes, I'm running 2.6.24-19, and this is still an issue.

Jeff Fortin Tam (kiddo) wrote :

I can confirm this bug on the latest kernel in 8.04.1. I think it happened in gutsy too, but I don't remember. On my end, this happens even if I set gnome-power-manager's gconf keys to not do anything with screen brightness or dimming. What more info is needed?

Changed in gnome-power-manager:
status: Incomplete → Confirmed
maticmatija (maticmatija) wrote :

I had same problem with thinkpad r50e but it looks solved with 8.10

But the dmesg's message :

thinkpad_acpi: CMOS NVRAM (7) and EC (6) do not agree on display brightness level

still remains.

Oded Arbel (oded-geek) wrote :

I think I have the same problem with Lucid Alpha on Thinkpad X61s: The brightness applet works correctly, but if the system automatically dims the brightness after a set period, the brightness applet still sees the brightness as maximum value. I have to go and change the brightness to some other value for it sync the brightness value.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers