Opposite Response on Power Event

Bug #231278 reported by Melk79 on 2008-05-17
2
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 8.04 LTS, Kernel Linux 2.6.24-16-generic, Gnome-Power-Manager 2.22.1

Power events cause the opposite response from selected settings under System>Preferences>Power Management

- Icon in top panel is always correct (e.g. power cord when plugged in, battery when not) However, if you hold the cursor over the icon when battery is displayed, message returns "Computer is running on AC power"

- Unplug power the screen brightens and the screen blanks on lid close. This matches the power settings for "On AC power"

- Plug the power back in the screen dims and the computer sleeps on lid close. This matches the power settings for "On Battery Power"

This behavior began after an update that performed the following in SPM:
Commit Log for Wed May 14 20:20:20 2008

Upgraded the following packages:
compiz (1:0.7.4-0ubuntu6) to 1:0.7.4-0ubuntu6+ppa1
compiz-core (1:0.7.4-0ubuntu6) to 1:0.7.4-0ubuntu6+ppa1
compiz-gnome (1:0.7.4-0ubuntu6) to 1:0.7.4-0ubuntu6+ppa1
compiz-plugins (1:0.7.4-0ubuntu6) to 1:0.7.4-0ubuntu6+ppa1
gnome-about (1:2.22.1-0ubuntu6.1) to 1:2.22.1-0ubuntu6.2
gnome-desktop-data (1:2.22.1-0ubuntu6.1) to 1:2.22.1-0ubuntu6.2
gnome-settings-daemon (2.22.1-0ubuntu1) to 2.22.1-0ubuntu2
gnome-system-monitor (2.22.1-0ubuntu1) to 2.22.1-0ubuntu2
hal (0.5.11~rc2-1ubuntu8) to 0.5.11~rc2-1ubuntu8.1
libdecoration0 (1:0.7.4-0ubuntu6) to 1:0.7.4-0ubuntu6+ppa1
libgnome-desktop-2 (1:2.22.1-0ubuntu6.1) to 1:2.22.1-0ubuntu6.2
libhal-storage1 (0.5.11~rc2-1ubuntu8) to 0.5.11~rc2-1ubuntu8.1
libhal1 (0.5.11~rc2-1ubuntu8) to 0.5.11~rc2-1ubuntu8.1
libssl0.9.8 (0.9.8g-4ubuntu3) to 0.9.8g-4ubuntu3.1
openssh-client (1:4.7p1-8ubuntu1) to 1:4.7p1-8ubuntu1.2
openssl (0.9.8g-4ubuntu3) to 0.9.8g-4ubuntu3.1
python-virtkey (0.50build1) to 0.50ubuntu0.1
ssh-askpass-gnome (1:4.7p1-8ubuntu1) to 1:4.7p1-8ubuntu1.2
ssl-cert (1.0.14-0ubuntu2) to 1.0.14-0ubuntu2.1
transmission-common (1.06-0ubuntu4) to 1.06-0ubuntu5
transmission-gtk (1.06-0ubuntu4) to 1.06-0ubuntu5
update-manager (1:0.87.24) to 1:0.87.27
update-manager-core (1:0.87.24) to 1:0.87.27
xserver-xorg-video-intel (2:2.2.1-1ubuntu12) to 2:2.2.1-1ubuntu13

Installed the following packages:
openssl-blacklist (0.1-0ubuntu0.8.04.2)

Pedro Villavicencio (pedro) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please attach the resulting log file of: gnome-power-bugreport.sh &> gpm.log to the report? You might also want to take a look to the Debugging instructions located at https://wiki.ubuntu.com/DebuggingGNOMEPowerManager for submit any other logs related to your problem.Thanks in advance.

Changed in gnome-power-manager:
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in gnome-power-manager:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers