Gnome Power Manager doesn't show battery tab if accumulator isn't inserted

Bug #228932 reported by unggnu on 2008-05-10
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-power
In Progress
Medium
gnome-power-manager (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-power-manager

Normally I remove the battery if my laptop is connected to AC to save the lifetime of it. If I do this there is no battery tab in Gnome Power Manager anymore. The battery tab is only shown in battery mode so it is impossible to change energy saving settings with connected ac. Adding battery in ac mode doesn't change anything in gpm but the loading symbol in systray is shown. This happens since Hardy and works fine in all version before. The battery status is shown like before under proc.
I am using a Sony Vaio TX2 notebook.

cat /proc/acpi/battery/BAT1/state
present: no

Pedro Villavicencio (pedro) wrote :

Thanks for your report, can you get the gpm logs before and after removing the battery? please attach the resulting log file of: gnome-power-bugreport.sh &> gpm.log to the report, thanks.

Changed in gnome-power-manager:
importance: Undecided → Low
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!.

Changed in gnome-power-manager:
status: Incomplete → Invalid
Laurent Bigonville (bigon) wrote :

reoppening as I have the same issue on my T61

Changed in gnome-power-manager:
status: Invalid → New
Laurent Bigonville (bigon) wrote :

$ cat /proc/acpi/battery/BAT0/*
alarm: 2878 mWh
present: yes
design capacity: 56160 mWh
last full capacity: 57570 mWh
battery technology: rechargeable
design voltage: 10800 mV
design capacity warning: 2878 mWh
design capacity low: 200 mWh
capacity granularity 1: 1 mWh
capacity granularity 2: 1 mWh
model number: 42T4504
serial number: 6444
battery type: LION
OEM info: SANYO
present: yes
capacity state: ok
charging state: discharging
present rate: 24238 mW
remaining capacity: 36440 mWh
present voltage: 11417 mV

Laurent Bigonville (bigon) wrote :
Laurent Bigonville (bigon) wrote :

$ cat /proc/acpi/battery/BAT0/*
alarm: 2878 mWh
present: yes
design capacity: 56160 mWh
last full capacity: 57570 mWh
battery technology: rechargeable
design voltage: 10800 mV
design capacity warning: 2878 mWh
design capacity low: 200 mWh
capacity granularity 1: 1 mWh
capacity granularity 2: 1 mWh
model number: 42T4504
serial number: 6444
battery type: LION
OEM info: SANYO
present: yes
capacity state: ok
charging state: charging
present rate: 41981 mW
remaining capacity: 36990 mWh
present voltage: 12151 mV

Laurent Bigonville (bigon) wrote :

after reinstering the battery the battery tab still missing

Scott Howard (showard314) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Karmic Koala. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/. Thanks again and we appreciate your help.

Changed in gnome-power-manager (Ubuntu):
status: New → Incomplete
unggnu (unggnu) wrote :

Still an issue in Karmic.

Scott Howard (showard314) wrote :

Thanks for checking in Karmic. This should be send directly to the upstream authors at bugzilla.gnome.org, for forwarding instructions please have a look to http://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you forward the bug, please post a link to the upstream bug report here. Thanks in advance.

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → Confirmed
IKT (ikt) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: https://bugzilla.gnome.org/show_bug.cgi?id=607092

Changed in gnome-power:
importance: Undecided → Unknown
status: New → Unknown
Changed in gnome-power-manager (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-power:
importance: Unknown → Medium
status: Unknown → New
Changed in gnome-power:
status: New → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.