Brightness Level resets after closing lid to laptop.

Bug #223954 reported by Liftoff on 2008-04-28
42
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Medium
Snehal
Nominated for Intrepid by Liftoff
Nominated for Karmic by Géza Búza

Bug Description

gnome-power-manager and the brightness applet had some very annoying bugs in Gutsy (see https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/137598).

For a while after upgrading to Hardy, it seemed as through the aforementioned bug had been resolved. I was able to adjust the screen brightness with [Fn + Up] and [Fn + Down] without issue. But now that I have been using Hardy for a few days, it seems that some of the bugs remain. If I set my brightness via the Brightness Applet, the chosen brightness will change after I close/reopen my laptop lid. However, if I use the [Fn + Up] and [FN + Down] keystrokes, the brightness will be "saved" until the computer restarts. Once the computer restarts, the brightness level returns to a level different from the level set with [Fn + Up] or [Fn + Down].

I have not done any extensive testing, and thus cannot provide with certainty a "Steps to reproduce" section. But it is clear that something is wrong, as the brightness level should not modify itself when I close my laptop lid. If anyone can confirm similar buggy activity or would like to provide any other relevant information, please do so in the comments section.

Luke Faraone (lfaraone) wrote :

Thank you for your bug report.

If this is the same bug as you were experiencing before, please mark this as a duplicate and repost this to Bug #137598.

Liftoff (liftoff) wrote :

I'm not sure if it is technically the same bug. That is, I don't know that it is caused by the same code or even the same package.

Liftoff (liftoff) on 2008-05-08
description: updated
bgcommon (bgcommon) wrote :

The issue is still open. Set brightness level to less than maximim. Then close laptop lid and then reopen. The brightness level is reset to max. I have my display set to blank out when laptop lid is closed.

Hi.

Thanks for your report but we need more information about your bug. Please, run gnome-power-bugreport.sh and gconftool -a /apps/gnome-power-manager/backlight.

Bye

Changed in gnome-power-manager:
status: New → Incomplete
Liftoff (liftoff) wrote :
Download full text (3.4 KiB)

As bgcommon notes, the bug is easily triggered. Set your brightness to a certain level with the Brightness Applet. Alter the brightness with the [Fn + Up] or [Fn + Down] key. Close/reopen the laptop lid and the level will revert to that which had originally been set in the Brightness Applet.

As you requested, here are the results of the commands. The commands were executed after setting the brightness with the Brightness Applet but before using the [Fn + *] key:

gconftool -a /apps/gnome-power-manager/backlight
--------------------
 idle_dim_battery = true
 idle_brightness = 30
 dpms_method_battery = default
 dpms_method_ac = default
 idle_dim_time = 30
 brightness_battery = 70
 enable = true
 idle_dim_ac = false
 brightness_ac = 81
 battery_reduce = true

gnome-power-bugreport.sh
--------------------
Distro version: DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu 8.04"
Kernel version: 2.6.24-19-generic
g-p-m version: 2.22.1
HAL version: 0.5.11rc2
System manufacturer: missing
System version: missing
System product: missing
AC adapter present: yes
Battery present: yes
Laptop panel present: yes
CPU scaling present: yes
Battery Information:
  battery.charge_level.current = 50116 (0xc3c4) (int)
  battery.charge_level.design = 53280 (0xd020) (int)
  battery.charge_level.last_full = 50116 (0xc3c4) (int)
  battery.charge_level.percentage = 100 (0x64) (int)
  battery.charge_level.rate = 11 (0xb) (int)
  battery.is_rechargeable = true (bool)
  battery.model = ' DELLUD2657' (string)
  battery.present = true (bool)
  battery.rechargeable.is_charging = false (bool)
  battery.rechargeable.is_discharging = false (bool)
  battery.reporting.current = 4800 (0x12c0) (int)
  battery.reporting.design = 4800 (0x12c0) (int)
  battery.reporting.last_full = 4515 (0x11a3) (int)
  battery.reporting.rate = 1 (0x1) (int)
  battery.reporting.technology = 'Li-ion' (string)
  battery.reporting.unit = 'mAh' (string)
  battery.technology = 'lithium-ion' (string)
  battery.type = 'primary' (string)
  battery.vendor = 'SMP' (string)
  battery.voltage.current = 12424 (0x3088) (int)
  battery.voltage.design = 11100 (0x2b5c) (int)
  battery.voltage.unit = 'mV' (string)
GNOME Power Manager Process Information:
john 7017 0.0 1.1 247184 11636 ? Ss 14:16 0:00 gnome-power-manager
john 7109 0.0 1.0 225616 10816 ? S 14:17 0:00 /usr/lib/gnome-power-manager/gnome-brightness-applet --oaf-activate-iid=OAFIID:GNOME_BrightnessApplet_Factory --oaf-ior-fd=36
HAL Process Information:
107 5669 0.0 0.4 40208 4828 ? Ss 14:13 0:03 /usr/sbin/hald
root 5735 0.0 0.1 22048 1316 ? S 14:13 0:00 \_ hald-runner
root 5748 0.0 0.2 34628 2404 ? S 14:13 0:00 \_ /usr/lib/hal/hald-addon-dell-backlight
root 5749 0.0 0.1 24156 1296 ? S 14:13 0:00 \_ hald-addon-input: Listening on /dev/input/event8 /dev/input/event10 /dev/input/event9 /dev/input/event1 /dev/input/event4 /dev/input/event5 /dev/input/event6
root 5759 0.0 0.1 24168 1324 ? S 14:13 ...

Read more...

Toby Bartels (tobybartels) wrote :

I have this problem too, although it doesn't behave quite the same way.

If I set brightness to the dimmest setting using the brightness app (I put a button for this on my panel and use that), then this will be reset to full brightness whenever I close the laptop lid or log out. In the first case, the brightness app still shows that it's set to dim, but I need to wiggle the bar to get the screen to remember this fact. In the latter case (log out and log back in), then my setting is lost. Note that each user has their own separate brightness setting, and there seems to be NO way to lower the brightness for the log in screen or the Shift-Alt-F1–F6 consoles.

I am running Hardy (installed from a LiveCD written from a downloaded disk image) on a Dell Inspirion E1505 laptop. I don't really understand how Gnome works, but I do know how to use the terminal, so I can report the contents of configuration files and the outputs of diagnostic commands, if you tell me what you need.

Please note that Bug #137598 is marked at Fix Released in Hardy, because that bug is about the way thinks went wrong in Gutsy. This bug probably has the same underlying causes, but it is about the behaviour in Hardy, which is different (and in my opinion, not as bad).

Liftoff (liftoff) wrote :

Regarding Toby's comment - The problems I have been experiencing (see bug description above) are also happening on a Dell E1505.

Michael Rooney (mrooney) wrote :

Setting as Confirmed as John has provided the information Marlon asked for. Marlon, if you are going to mark a bug as Incomplete it is quite preferable that you adjust the status again when the person has provided the necessary information; otherwise the original filer may have no idea how to do this and a legitimate bug can expire.

Changed in gnome-power-manager:
status: Incomplete → Confirmed
bgcommon (bgcommon) wrote :

I'm posting the results of the commands Marlon has asked for in the hope that this bug would be fixed soon:

gnome-power-bugreport.sh:

Distro version: DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu 8.04.1"
Kernel version: 2.6.24-19-generic
g-p-m version: 2.22.1
HAL version: 0.5.11rc2
System manufacturer: missing
System version: missing
System product: missing
AC adapter present: yes
Battery present: yes
Laptop panel present: yes
CPU scaling present: yes
Battery Information:
  battery.charge_level.current = 41958 (0xa3e6) (int)
  battery.charge_level.design = 42174 (0xa4be) (int)
  battery.charge_level.last_full = 42174 (0xa4be) (int)
  battery.charge_level.percentage = 99 (0x63) (int)
  battery.charge_level.rate = 0 (0x0) (int)
  battery.is_rechargeable = true (bool)
  battery.model = 'Primary' (string)
  battery.present = true (bool)
  battery.rechargeable.is_charging = false (bool)
  battery.rechargeable.is_discharging = false (bool)
  battery.reporting.current = 3885 (0xf2d) (int)
  battery.reporting.design = 3905 (0xf41) (int)
  battery.reporting.last_full = 3905 (0xf41) (int)
  battery.reporting.rate = 0 (0x0) (int)
  battery.reporting.technology = 'Li-ion' (string)
  battery.reporting.unit = 'mAh' (string)
  battery.technology = 'lithium-ion' (string)
  battery.type = 'primary' (string)
  battery.vendor = 'Hewlett-Packard' (string)
  battery.voltage.current = 12517 (0x30e5) (int)
  battery.voltage.design = 10800 (0x2a30) (int)
  battery.voltage.unit = 'mV' (string)
GNOME Power Manager Process Information:
bgcommon 7096 0.0 1.0 25812 10624 ? Ss 15:57 0:02 gnome-power-manager
HAL Process Information:
111 5945 0.0 0.4 6336 4396 ? Ss 15:56 0:11 /usr/sbin/hald
root 5949 0.0 0.1 3352 1180 ? S 15:56 0:01 \_ hald-runner
root 6024 0.0 0.1 3416 1160 ? S 15:56 0:00 \_ hald-addon-input: Listening on /dev/input/event6 /dev/input/event1 /dev/input/event3 /dev/input/event4 /dev/input/event5
root 6039 0.0 0.1 3428 1260 ? S 15:56 0:00 \_ /usr/lib/hal/hald-addon-cpufreq
111 6040 0.0 0.0 2204 960 ? S 15:56 0:00 \_ hald-addon-acpi: listening on acpid socket /var/run/acpid.socket

gconftool -a /apps/gnome-power-manager/backlight
 idle_dim_battery = true
 idle_brightness = 30
 dpms_method_battery = default
 dpms_method_ac = default
 idle_dim_time = 30
 brightness_battery = 70
 enable = true
 battery_reduce = true
 idle_dim_ac = false
 brightness_ac = 100

Luke Faraone (lfaraone) on 2008-09-29
Changed in gnome-power-manager:
importance: Undecided → Low
Liftoff (liftoff) wrote :

There is another bug which doesn't seem to have been mentioned.

Using the [Fn + Up] and [Fn + Dn] keystrokes changes the brightness in huge increments. The keystrokes basically allow me three separate brightness levels: very dim, medium, and very bright. By comparison, my Dell's sound buttons allow me to adjust the sound in very small increments, allowing me to access about 10 different volume levels.

I wouldn't mark this bug as low priority, as I would be hesitant to argue that these problems are of low annoyance to any user. Can we get some of these issues fixed for Intrepid?

Luke Faraone (lfaraone) wrote :

Please review https://wiki.ubuntu.com/Bugs/Importance for an explanation on the priority of bugs.

Liftoff (liftoff) wrote :

To quote https://wiki.ubuntu.com/Bugs/Importance

-----
Low: Bugs which affect functionality, but to a lesser extent than most bugs, examples are:
    * Ones that can be easily worked around
    * Ones that affect unusual configurations or uncommon hardware
    * A bug that has a moderate impact on a non-core application
    * A cosmetic/usability issue that does not limit the functionality of an application
-----

I guess you could make the argument that this is a cosmetic issue, but that seems like a bit of a stretch. I mean, it's not like this is a bug in Compiz or anything like that.

And the bugs certainly do not meet any of the other criteria to be considered Low priority. There is no known workaround to these bugs, let alone an easy workaround, this bug is not related to "unusual configurations" or "uncommon hardware", and this bug is related to core functionality.

I would recommend that the priority of these bugs be changed to Medium as they have "a moderate impact on a core application".

Luke Faraone (lfaraone) on 2008-10-03
Changed in gnome-power-manager:
importance: Low → Medium
Géza Búza (medve) wrote :

The problem also exists in 9.10 beta1 Ubuntu karmic (development branch), live CD.
This issue can be reproduced in other ways, regardless of using Fn+ keys or GNOME Brightness Applet:
- change virtual terminal (sudo chvt 1) and back with Ctrl+Alt+F7
- switch to anther user and back
- close the lid and open again

Anzenketh (anzenketh) on 2010-02-24
summary: - Brightness control still has major bugs
+ Brightness Level resets after closing lid to laptop.
W5WMW (w5wmw) wrote :

This bug also exists in Kubuntu 10.04. Someone was able to hack their way around it:

http://www.linuxquestions.org/questions/slackware-14/laptop-screen-brightness%3B-constantly-reverts-to-minimum-698371/

Dimitris (bestoftherest7) wrote :

There is a bug in my ubuntu 14.04.3 64bit version. if i change brightness level when i close or restart computer brightness come back in 100% . i have tried a lot of solutions . i am happy using ubuntu. thanks and please fix this issue via an update. sorry for my bad english.

Snehal (snehaltkr) on 2015-10-06
Changed in gnome-power-manager (Ubuntu):
assignee: nobody → Snehal (snehaltkr)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers