[hardy] Doesn't wake from sleep after lid-close causes suspend to RAM

Bug #223478 reported by Brian Campbell on 2008-04-28
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)

Bug Description

I have just upgraded my girlfriend's computer (a Dell Inspiron 6000) from Gutsy to Hardy. When she closes the lid, it goes to sleep just fine, and when opening the lid back up again, it appears to wake up, but the screen never turns back on. I've tried a few things (switching virtual terminals, pressing the power button briefly), but none of them seem to wake the computer up. We've had to shut the computer down and start it back up again to get it working. Checking /var/log/messages indicates that it thinks it's resuming, and it logged the times I pressed the power key after resuming, but never did the display show anything in that time. Before upgrading from Gutsy to Hardy, suspend and resume worked mostly fine, though with some occasion flakiness.

Brian Campbell (unlambda) wrote :

After further experimentation, it turns out that this only happens when suspending by closing the lid; if I suspend by using the power button on the gnome panel, the power button on the laptop, the Function-Suspend key combination, or '/etc/acpi/sleep.sh force', it suspends and resumes just fine. Only if I put it to sleep via closing the lid does it have a problem. It seems to wake up fine other than the screen; I can ssh in, put it to sleep using /etc/acpi/sleep.sh force, and then wake it up with the power button. And if I put it to sleep in any of the ways besides closing the lid, close it, and open it, it wakes up just fine. The only way it breaks is by going to sleep via closing the lid.

Brian Campbell (unlambda) wrote :

I have also tried switching virtual terminals upon resuming using Ctrl-Alt-F1-10, with no luck. If I put the computer back to sleep using the Function-Standby key combination, and wake it again, it is still broken, but putting it to sleep using /etc/acpi/sleep.sh force seems to always reset it to a good state, and I can wake it up just fine.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Intrepid Ibex. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in gnome-power-manager:
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in gnome-power-manager:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers