Doesn't detect lid closing on Dell Inspiron 5150

Bug #223192 reported by Joel Parker on 2008-04-27
4
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Undecided
Unassigned

Bug Description

I have a Dell Inspiron 5150, and Hardy Heron isn't detecting when I close the lid. I've changed my power preferences between Blank Screen and Suspend when the lid is closed, and neither ever happens.

Hi Joel.

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please attach your X server configuration file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.0.log) to the bug report as individual uncompressed file attachments using the "Attachment:" box below. Could you please also try to run without any /etc/X11/xorg.conf and let Xorg autodetect your display and video card? Please also attach the /var/log/Xorg.0.log from this attempt. Thanks in advance.

Joel Parker (jjkp) wrote :
Joel Parker (jjkp) wrote :
Joel Parker (jjkp) wrote :
Pedro Villavicencio (pedro) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please attach the resulting log file of: gnome-power-bugreport.sh &> gpm.log to the report? You might also want to take a look to the Debugging instructions located at https://wiki.ubuntu.com/DebuggingGNOMEPowerManager for submit any other logs related to your problem.Thanks in advance.

Changed in gnome-power-manager:
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in gnome-power-manager:
status: Incomplete → Invalid
Joel Parker (jjkp) wrote :

Sorry for the delay here. I've attached my gpm.log.

Changed in gnome-power-manager:
status: Invalid → New
cologic (cologic) wrote :

I have experienced this as well, across both Kubuntu 8.04 and 8.10 on a Dell Inspiron 5100. Under 8.04 the workaround used inhttp://ubuntuforums.org/archive/index.php/t-346225.html functioned adequately; updated the reference to /etc/acpi/sleepbtn.sh keeps it functioning now.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Could you try to reproduce the same with Ubuntu 9.04? Thanks in advance.

Changed in gnome-power-manager (Ubuntu):
status: New → Incomplete
Joel Parker (jjkp) wrote :

Yes, this is still an issue in 9.04.

Scott Howard (showard314) wrote :

Thanks for checking with 9.04. To investigate further, could you please attach the resulting log files of:

/usr/share/gnome-power-manager/gnome-power-bugreport &> gpm.log

gconftool --recursive-list /apps/gnome-power-manager > gpm.gconf.values.txt

and:

1) run: dbus-monitor --session "type='signal',interface='org.freedesktop.PowerManagement'" 2) close and open your lid 3) post the output from dbus-monitor

1) run: "lshal -m > lshal.log.txt" 2) close and open your lid 3) attach lshal.log.txt to the bug report. This may be a problem with HAL/pm-utils.

Thanks in advance.

cologic (cologic) wrote :

I use KDE, not GNOME, so the two steps related to gnome-power-manager don't apply. The lshal -m output is empty (0 bytes).

cologic (cologic) wrote :

This problem still occurs in Kubuntu 9.04 for me.

cologic (cologic) wrote :

I should add that currently I set up a cron script to run the attached suspendhack.sh to check for lid closing and manually trigger, via dbus, suspending.

Scott Howard (showard314) wrote :

Thank you for taking the time to report this bug, the workaround script, and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 44058, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers