Mystery power button events on resume

Bug #222852 reported by Chris D on 2008-04-27
2
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-power-manager

gnome-power-manager is detecting dozens of Power button events after resuming from S3. This is accompanied by a large number of "Action Forbidden - The policy timeout is invalid" popups on the desktop. I have no idea where these events are coming from, however they do cause many problems. For example, if in gnome-power-manager the power button action is set to "Ask Me", you will get the logout screen displayed to you, over and over. If you set the action to "Suspend", the system gets stuck in a seemingly infinite loop of suspends.

To replicate:
1. In gnome-power-manager, set the Power Button action to "Ask Me"
2. Suspend the system.
3. Resume the system.

Expected: system resumes and normal work can continue.
Actual: unable to perform anything because the logout screen keeps popping up. Restarting X with Ctrl+Alt+Backspace doesn't help.

Temporary workaround - disable the Power Button action in gconf-editor under apps/gnome-power-manager/buttons by setting the "power" entry to "nothing".

Hardware:
Desktop PC with AMD X2 5600+, 2Gb DDR, 2 SATA hard disks.

Peter Wagner (o-petris) wrote :

I have the same problem, unable to work in Ubuntu. Possibly it was caused after a TAR installation of an ica Client from their download site. In the Czech wiki, this is recommended even if Citrix offers only SuSe and redhat solutions (as "Linux"). But maybe I've overseen something, because finally it didn't work. The problems arised from the next (?) reboot.

No matter. Now I've no idea how to get back into. I've tried to remove user related settings (.gconf, .gconfd, .config, .gnome2), no improvement.
I've entered gconftool-2 --set "/apps/gnome-power-manager/buttons/power" --type string "nothing", no change. Even the gnome-power-manager directory didn't appear.
I've tried also to generate the XML file at this location, no change.

I have a Celeron 1.7 GHz desktop, 1.25 GB DDR-2, 2 SATA disks

Peter Wagner (o-petris) wrote :

CANCEL !

No power-manager, no ICA Client, the only responsible was the keyboard who started to go its own life (after it has been working for weeks under Ubuntu and until now under Windows).

Thanks to David Strnad from the Czech Ubuntu community I got rid of this ugly error and may continue with Ubuntu.

Pedro Villavicencio (pedro) wrote :

closing this bug then, thanks for the feedback.

Changed in gnome-power-manager (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers