Unresponsive programs hang g-p-m on logout

Bug #209222 reported by Sitsofe Wheeler on 2008-03-30
6
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-power-manager

Description of the problem:
If a GNOME program has hung it can stop the logout process indefinitely and without warning.

Steps to reproduce:
1. Download http://gstreamer.freedesktop.org/media/small/multi.ogg and save it to the desktop.
2. Double click it to open it with Totem Movie Player.
3. When the music has stopped playing drag multi.ogg on to totem's play area. This should make totem lock up and stop updating its window contents and show a busy animation when the pointer is over it.
4. Go to System -> Quit... and then click on Log Out.

Expected results:
All program's to be quit. Possibly for some program's to ask questions (but to be killed if the answer is not forthcoming).

Actual results:
Program's which are stuck will cause the log out process to be stalled. Menus become unresponsive and log out will not complete until the stuck application is Force Quited using the X at the top right hand corner and using the dialog that appears.

How reproducible is the problem?
It is reproducible every time.

Version information:
Ubuntu hardy (development branch)
gnome-power-manager 2.22.0-0ubuntu2

Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in gnome-power-manager:
importance: Undecided → Medium
status: New → Incomplete
Sitsofe Wheeler (sitsofe) wrote :

Pedro, how is totem's backtrace going to help this? I actually can't provide it either as I don't have space for debugging symbols presently...

Changed in gnome-power-manager:
status: Incomplete → New
Bornakke (bornakke) wrote :

Seems to have the same problem. Haven't been able to find the program that are stuck, but the button is on responsive every 2. time i want to restart and it seems to be relate to when ever something crashed.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Could you try to reproduce the same with Ubuntu 9.04? Thanks in advance.

Changed in gnome-power-manager (Ubuntu):
status: New → Incomplete
Bornakke (bornakke) wrote :

For me I don't think it is a problem with 9.04...

Sitsofe Wheeler (sitsofe) wrote :

With 9.04 when a logout happens with an unresponsive program a dialog pops up reporting which programs are unresponsive and asking if you wish to log out anyway.

Resolve fixed?

Bornakke (bornakke) wrote :

That should fix it yes...

Sitsofe Wheeler (sitsofe) wrote :

Marking as fixed release.

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers