screen doesn't switch off by itself

Bug #207553 reported by Robin Sheat on 2008-03-27
14
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Medium
Ted Gould
Nominated for Hardy by Pausanias

Bug Description

Binary package hint: gnome-power-manager

I have power management on my desktop set to turn the screen off after 40 minutes, however it never actually turns off. The screensaver comes on (just blanking the screen), and remains that way. According to xset q, DPMS timeouts are all '0'. This is on hardy beta.

CirclingTheSun (circlingthesun) wrote :

Happens here too with hardy heron beta (all updates installed)

Changed in gnome-power-manager:
status: New → Confirmed
Milan Knizek (knizek) wrote :

Same here (current hardy, nvidia driver, external LCD Samsung XL20).

$ xset -q | grep -A1 DPMS
DPMS (Energy Star):
  Standby: 0 Suspend: 0 Off: 0
  DPMS is Enabled
  Monitor is On

$ xset dpms 20 0 0

Then the screen blanks after 20 secs and then turns on again as the LCD searches the input signal and after a few seconds goes to standby (i.e. the LED backlight + fan are switched off).

Pausanias (pausanias) wrote :

Same here. Screensaver comes on, screen is set to turn off in 15 minutes, but it never does, even after hours.

mannheim (kronheim) wrote :

Reverting to gnome-power-manager 2.21.92-0ubuntu1 in hardy fixed the problem. So the bug does seem to be in recent versions of gnome-power-manager, as the original report suggests. I haven't tried the in-between versions.

Kees Cook (kees) wrote :

This is a regression caused by the patch for bug 137598.

Changed in gnome-power-manager:
assignee: nobody → ted-gould
importance: Undecided → Medium
milestone: none → ubuntu-8.04
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-power-manager - 2.22.1-1ubuntu2

---------------
gnome-power-manager (2.22.1-1ubuntu2) hardy; urgency=low

  * Removing 01_no_backlight_on_idle.patch as the code is covered
    in 04_brightness_events.patch and it is breaking things by being
    in the general callback. LP: #207553

 -- Ted Gould <email address hidden> Tue, 01 Apr 2008 15:34:51 -0700

Changed in gnome-power-manager:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers