Screen power saving mode will not resume after using VNC prorgram

Bug #194732 reported by wpshooter on 2008-02-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Undecided
Unassigned

Bug Description

After using the remote desktop program & the VNC viewer programs that are included with the Gutsy version of Ubuntu, the screen blanking/power saving mode function will not resume on the computer that was BEING controlled remotely after the VNC session has been ended by the computer that was DOING the controlling.

I have the screen power saving mode set to go blank after 3 minutes of inactivity on the computer.

Once the VNC session is ended the controlled computer will NOT go into/resume the screen blanking function unless the mouse/cursor is moved or a key is pressed (Of course, if I am at a remote location, say at work and the computer being controlled is at my home, then It is sort of hard for me to either move the mouse or press at key, if I am not there in person).

After the mouse/cursor is moved (when I get home) the screen blanking function WILL resume as normal. However, it would seem to me that once the VNC session is ended that this screen blanking/power saving function should resume without any user intervention. It is as if somehow that computer thinks that there is still activity (i.e. either mouse movement of keyboard activity is taking place) even though there is not.

If you need anymore information, please let me know.

Thanks.

wpshooter (joverstreet) wrote :

Just an after-thought.

I am surely not the only person that has tried using VNC to remote into one of their Ubuntu workstations on their network and found that when they got back home (or wherever the remote workstation might be located) and found that the monitor had been on/active/displaying ever since the remote session was ended.

It would seem like to me, that this problem would have been discovered, reported & fixed long, long ago !!!

Thanks.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Intrepid Ibex. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in gnome-power-manager:
status: New → Incomplete
wpshooter (joverstreet1) wrote :

It has been a while since I did any use of VNC, but when I get a chance I will test this with the beta version of Intrepid (that is if I can recall what all I did to setup VNC).

I will report result on this bug report when I finish the testing.

Thanks.

Jonathan Thomas (echidnaman) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → Invalid
wallymann (wamanning) wrote :

fyi...i had this exact same problem running ubuntu 14.04.

the monitor powersave function would work fine when sitting at the machine and interacting directly with it. when i'd step away, the monitor would power-off as expected.

but when i would interact remotely via VNC (desktop sharing) and stop using the machine, the workstation's monitor would stay on indefinitely regardless of the powersave settings.

this undesired behaviour was consistent whether i was using xfce-power-manager or light-locker to manage the monitor powersave settings.

but when i tried xscreensaver instead (after removing both xfce-power-manager and light-locker), it worked fine -- the monitor powersave would activate whether i was working directly with the machine or accessing remotely via VNC.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers